summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-05-11 00:01:42 -0700
committerArmin Kuster <akuster808@gmail.com>2018-05-17 08:25:29 -0700
commit327292a30089783236bfe482ec43834f9d118327 (patch)
tree8f04a8e450cbf3f1e3b527fe2143b3f24df64a34
parenta913abb3364355889dfce345ae376813f9834f25 (diff)
downloadmeta-openembedded-327292a30089783236bfe482ec43834f9d118327.tar.gz
poppler: Update to 0.64
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch29
-rw-r--r--meta-oe/recipes-support/poppler/poppler_0.64.0.bb (renamed from meta-oe/recipes-support/poppler/poppler_0.63.0.bb)18
2 files changed, 39 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch b/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch
new file mode 100644
index 000000000..7ed795ef7
--- /dev/null
+++ b/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch
@@ -0,0 +1,29 @@
1From d488de23b75b2f3e235f1c184b2253d1402b4c0f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 10 May 2018 23:47:56 -0700
4Subject: [PATCH] glib/CMakeLists.txt: Add libpoppler to link along with
5 poppler-glib
6
7This is required since poppler-glib uses symbols from poppler and
8we use --as-needed
9
10Upstream-Status: Pending
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 glib/CMakeLists.txt | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/glib/CMakeLists.txt b/glib/CMakeLists.txt
18index 33c6608..87e1b44 100644
19--- a/glib/CMakeLists.txt
20+++ b/glib/CMakeLists.txt
21@@ -127,7 +127,7 @@ if (HAVE_INTROSPECTION AND BUILD_SHARED_LIBS)
22 get_directory_property(_tmp_includes INCLUDE_DIRECTORIES)
23 _list_prefix(_includes _tmp_includes "-I")
24 set(Poppler_0_18_gir_CFLAGS ${_includes} -L${CMAKE_BINARY_DIR})
25- set(Poppler_0_18_gir_LIBS poppler-glib)
26+ set(Poppler_0_18_gir_LIBS poppler-glib poppler)
27 _list_prefix(_abs_introspection_files introspection_files "${CMAKE_CURRENT_SOURCE_DIR}/")
28 list(APPEND _abs_introspection_files
29 ${CMAKE_CURRENT_BINARY_DIR}/poppler-enums.c
diff --git a/meta-oe/recipes-support/poppler/poppler_0.63.0.bb b/meta-oe/recipes-support/poppler/poppler_0.64.0.bb
index 8acb35628..1e87ae6e6 100644
--- a/meta-oe/recipes-support/poppler/poppler_0.63.0.bb
+++ b/meta-oe/recipes-support/poppler/poppler_0.64.0.bb
@@ -2,15 +2,15 @@ SUMMARY = "Poppler is a PDF rendering library based on the xpdf-3.0 code base"
2LICENSE = "GPLv2" 2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" 3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4 4
5SRC_URI = " \ 5SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.xz \
6 http://poppler.freedesktop.org/${BP}.tar.xz \ 6 file://0001-Do-not-overwrite-all-our-build-flags.patch \
7 file://0001-Do-not-overwrite-all-our-build-flags.patch \ 7 file://0002-CairoOutputDev.cc-fix-build-error-when-using-fixedpo.patch \
8 file://0002-CairoOutputDev.cc-fix-build-error-when-using-fixedpo.patch \ 8 file://0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch \
9" 9 "
10SRC_URI[md5sum] = "66a54da4896b1408611699feda5c1821" 10SRC_URI[md5sum] = "f7f687ebb60004f8ad61994575018044"
11SRC_URI[sha256sum] = "27cc8addafc791e1a26ce6acc2b490926ea73a4f89196dd8a7742cff7cf8a111" 11SRC_URI[sha256sum] = "b21df92ca99f78067785cf2dc8e06deb04726b62389c0ee1f5d8b103c77f64b1"
12 12
13DEPENDS = "fontconfig zlib cairo lcms" 13DEPENDS = "fontconfig zlib cairo lcms glib-2.0"
14 14
15inherit cmake pkgconfig gobject-introspection 15inherit cmake pkgconfig gobject-introspection
16 16
@@ -29,9 +29,11 @@ inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'cmake_qt5', '', d)}
29SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}" 29SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
30 30
31EXTRA_OECMAKE += " \ 31EXTRA_OECMAKE += " \
32 -DENABLE_CMS=lcms2 \
32 -DENABLE_XPDF_HEADERS=ON \ 33 -DENABLE_XPDF_HEADERS=ON \
33 -DBUILD_GTK_TESTS=OFF \ 34 -DBUILD_GTK_TESTS=OFF \
34 -DENABLE_ZLIB=ON \ 35 -DENABLE_ZLIB=ON \
36 -DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}' \
35" 37"
36 38
37do_configure_append() { 39do_configure_append() {