summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-11 18:31:03 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-11 22:48:22 -0700
commit205d83988e82ec0358bba237218cc5d3b7f62d4a (patch)
treeaad3aac4200be44b9f14022a72367e932e02caf3
parentaee5ef8906978314f30d3a4c02c90ecedee5a43a (diff)
downloadmeta-openembedded-205d83988e82ec0358bba237218cc5d3b7f62d4a.tar.gz
lcdproc: Update to master tip
* Do not build on musl/arm since it does not build due to musl not implementing ioperm() function on ARM Drop 0001-include-asm-ioctl.h-explicitly.patch its fixed differently upstream already Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/lcdproc/lcdproc/0001-include-asm-ioctl.h-explicitly.patch43
-rw-r--r--meta-oe/recipes-extended/lcdproc/lcdproc_git.bb7
2 files changed, 4 insertions, 46 deletions
diff --git a/meta-oe/recipes-extended/lcdproc/lcdproc/0001-include-asm-ioctl.h-explicitly.patch b/meta-oe/recipes-extended/lcdproc/lcdproc/0001-include-asm-ioctl.h-explicitly.patch
deleted file mode 100644
index abdedad5d..000000000
--- a/meta-oe/recipes-extended/lcdproc/lcdproc/0001-include-asm-ioctl.h-explicitly.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From b5ca64c7398d516e9845d849e8306df7ac024bc4 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 11 Apr 2017 13:59:34 -0700
4Subject: [PATCH] include asm/ioctl.h explicitly
5
6Needed for _IOC* defines
7
8helps compiling with musl where this file is
9not included indirectly
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 server/drivers/hd44780-pifacecad.c | 1 +
14 server/drivers/hd44780-spi.c | 1 +
15 2 files changed, 2 insertions(+)
16
17diff --git a/server/drivers/hd44780-pifacecad.c b/server/drivers/hd44780-pifacecad.c
18index 43db19c..e2798ad 100644
19--- a/server/drivers/hd44780-pifacecad.c
20+++ b/server/drivers/hd44780-pifacecad.c
21@@ -54,6 +54,7 @@
22 #include <unistd.h>
23 #include <fcntl.h>
24 #include <sys/ioctl.h>
25+#include <asm/ioctl.h>
26 #include <stdint.h>
27 #include <linux/spi/spidev.h>
28
29diff --git a/server/drivers/hd44780-spi.c b/server/drivers/hd44780-spi.c
30index 5f94333..8a4015b 100644
31--- a/server/drivers/hd44780-spi.c
32+++ b/server/drivers/hd44780-spi.c
33@@ -29,6 +29,7 @@
34 #include <unistd.h>
35 #include <fcntl.h>
36 #include <sys/ioctl.h>
37+#include <asm/ioctl.h>
38 #include <stdint.h>
39 #include <linux/spi/spidev.h>
40
41--
422.12.2
43
diff --git a/meta-oe/recipes-extended/lcdproc/lcdproc_git.bb b/meta-oe/recipes-extended/lcdproc/lcdproc_git.bb
index fad1d616c..93a09f28a 100644
--- a/meta-oe/recipes-extended/lcdproc/lcdproc_git.bb
+++ b/meta-oe/recipes-extended/lcdproc/lcdproc_git.bb
@@ -11,15 +11,16 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760 \
11 11
12BASEPV = "0.5.9" 12BASEPV = "0.5.9"
13PV = "${BASEPV}+git${SRCPV}" 13PV = "${BASEPV}+git${SRCPV}"
14SRCREV = "79fa538647c3e09a87ecc86aae1abbb82e0a25c5" 14SRCREV = "a4b5a7e058fdd0d914a61138748b589c0128b45b"
15SRC_URI = "git://github.com/lcdproc/lcdproc;branch=lcdproc-${BASEPV} \ 15SRC_URI = "git://github.com/lcdproc/lcdproc \
16 file://0001-include-asm-ioctl.h-explicitly.patch \
17 " 16 "
18 17
19S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
20 19
21inherit autotools pkgconfig update-rc.d 20inherit autotools pkgconfig update-rc.d
22 21
22COMPATIBLE_HOST_arm_libc-musl = "null"
23
23LCD_DRIVERS ?= "all,!irman,!svga" 24LCD_DRIVERS ?= "all,!irman,!svga"
24LCD_DEFAULT_DRIVER ?= "curses" 25LCD_DEFAULT_DRIVER ?= "curses"
25 26