summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-12-05 12:50:59 +0000
committerKhem Raj <raj.khem@gmail.com>2018-12-05 10:18:59 -0800
commit120f62d4fbed16517e689b1de6ba58901ae88943 (patch)
tree502e0715a6ba250d4cf57e9691173e02b4f27ff7
parent83c38fc544333a7db6f68078f4254886a56d604a (diff)
downloadmeta-openembedded-120f62d4fbed16517e689b1de6ba58901ae88943.tar.gz
iwd: add more PACKAGECONFIG options
Disabled by default (as per upstream defaults), but expose ofono and wired options (wired installs the EAD service). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_0.12.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_0.12.bb b/meta-oe/recipes-connectivity/iwd/iwd_0.12.bb
index a4261547e..3caad20a4 100644
--- a/meta-oe/recipes-connectivity/iwd/iwd_0.12.bb
+++ b/meta-oe/recipes-connectivity/iwd/iwd_0.12.bb
@@ -10,9 +10,9 @@ SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git"
10SRCREV = "d7609915db4b57229f7dd4c04b4eabcce637872a" 10SRCREV = "d7609915db4b57229f7dd4c04b4eabcce637872a"
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12
13SYSTEMD_SERVICE_${PN} = "iwd.service"
14
15PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" 13PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
14PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
15PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
16PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd" 16PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
17 17
18EXTRA_OECONF += "--enable-external-ell" 18EXTRA_OECONF += "--enable-external-ell"
@@ -22,3 +22,5 @@ do_configure_prepend () {
22} 22}
23 23
24FILES_${PN} += "${datadir}/dbus-1" 24FILES_${PN} += "${datadir}/dbus-1"
25
26SYSTEMD_SERVICE_${PN} = "iwd.service ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)}"