summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardas Meile <eduardas.m@fods.com>2018-12-06 17:33:00 +0200
committerKhem Raj <raj.khem@gmail.com>2018-12-06 08:11:52 -0800
commit0bb29681c49516d83a448dae383d7870e265805d (patch)
treef13d57d01e02cd8943269e93ec120833a0489ef7
parent646bbf10ea8a395765a73891150b41f1780113c5 (diff)
downloadmeta-openembedded-0bb29681c49516d83a448dae383d7870e265805d.tar.gz
mksh: add version 56
The MirBSD Korn Shell is a permissively licensed shell currently used by Android. Signed-off-by: Eduardas Meile <eduardas.m@fods.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-shells/mksh/mksh_56.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-shells/mksh/mksh_56.bb b/meta-oe/recipes-shells/mksh/mksh_56.bb
new file mode 100644
index 000000000..324b5b611
--- /dev/null
+++ b/meta-oe/recipes-shells/mksh/mksh_56.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "The MirBSD Korn Shell - an enhanced version of the public domain ksh"
2HOMEPAGE = "http://www.mirbsd.org/mksh.htm"
3SECTION = "base/shell"
4
5LICENSE = "${@bb.utils.contains("TCLIBC", "glibc", "MirOS & ISC", "MirOS", d)}"
6LIC_FILES_CHKSUM = "file://main.c;beginline=6;endline=25;md5=7204fec4d12912f2a13fe8745bc356f9 \
7 file://strlcpy.c;beginline=1;endline=17;md5=d953f28f0c43ee29e238ec9bc15df2a0 \
8 "
9
10SRC_URI = "http://www.mirbsd.org/MirOS/dist/mir/mksh/mksh-R56c.tgz"
11
12SRC_URI[md5sum] = "4799a9ac6d55871d79ba66713d928663"
13SRC_URI[sha256sum] = "dd86ebc421215a7b44095dc13b056921ba81e61b9f6f4cdab08ca135d02afb77"
14
15inherit update-alternatives
16
17S = "${WORKDIR}/${PN}"
18
19ALTERNATIVE_${PN} = "sh"
20ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
21ALTERNATIVE_TARGET[sh] = "${base_bindir}/${BPN}"
22ALTERNATIVE_PRIORITY = "100"
23
24do_compile() {
25 sh ${S}/Build.sh -r
26}
27
28do_install() {
29 install -d ${D}${base_bindir}
30 install -m 0755 ${S}/mksh ${D}${base_bindir}/mksh
31
32 install -d ${D}${sysconfdir}/skel
33 install -m 0644 ${S}/dot.mkshrc ${D}${sysconfdir}/skel/.mkshrc
34}
35
36RPROVIDES_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/sh', '', d)}"