summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorParthiban Nallathambi <parthitce@gmail.com>2019-05-01 14:20:40 +0200
committerKhem Raj <raj.khem@gmail.com>2019-05-02 14:13:57 -0700
commitc5c6e9b545d1f108975498cb4b0d34b40a254d91 (patch)
treecdbd885d592d473a711cda36d15657894e96ca5e
parent941481128020cf062a9f1c263c526cad726390cb (diff)
downloadmeta-openembedded-c5c6e9b545d1f108975498cb4b0d34b40a254d91.tar.gz
python3-supervisor: add version 4.0.2
Added python3-supervisor with following missing DEPENDS - python3-meld3 version 1.0.2 Signed-off-by: Parthiban Nallathambi <parthitce@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-meld3.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-supervisor.inc30
-rw-r--r--meta-python/recipes-devtools/python/python3-meld3_1.0.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-supervisor/supervisor.service15
-rw-r--r--meta-python/recipes-devtools/python/python3-supervisor/supervisord.conf31
-rw-r--r--meta-python/recipes-devtools/python/python3-supervisor_4.0.2.bb2
6 files changed, 95 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-meld3.inc b/meta-python/recipes-devtools/python/python-meld3.inc
new file mode 100644
index 000000000..d4e274e60
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-meld3.inc
@@ -0,0 +1,15 @@
1SUMMARY = "meld3 templating system used by Supervisor"
2DESCRIPTION = "\
3meld3 is an HTML/XML templating system for Python which keeps \
4template markup and dynamic rendering logic separate from one \
5another. See http://www.entrian.com/PyMeld for a treatise on the \
6benefits of this pattern."
7HOMEPAGE = "https://github.com/supervisor/meld3"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9e7581cef5645475fcefebdc15ed7abf"
10
11SRC_URI[md5sum] = "3ccc78cd79cffd63a751ad7684c02c91"
12SRC_URI[sha256sum] = "f7b754a0fde7a4429b2ebe49409db240b5699385a572501bb0d5627d299f9558"
13
14PYPI_PACKAGE = "meld3"
15inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-supervisor.inc b/meta-python/recipes-devtools/python/python-supervisor.inc
new file mode 100644
index 000000000..beab49739
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-supervisor.inc
@@ -0,0 +1,30 @@
1SUMMARY = "Supervisor: A Process Control System"
2DESCRIPTION = "\
3Supervisor is a client/server system that allows its users \
4to monitorand control a number of processes on UNIX-like \
5operating systems."
6HOMEPAGE = "https://github.com/Supervisor/supervisor"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e"
9
10SRC_URI[md5sum] = "ac70dadd051dcaf1d03c467d51a3aac1"
11SRC_URI[sha256sum] = "5604457da4fb89d850e78c128205fe4938c9277f87301885b33c94c60361e575"
12
13PYPI_PACKAGE = "supervisor"
14inherit pypi systemd
15RDEPENDS_${PN} = "\
16 ${PYTHON_PN}-meld3 \
17"
18
19SRC_URI += "file://supervisord.conf \
20 file://supervisor.service \
21 "
22SYSTEMD_SERVICE_${PN} = "supervisor.service"
23
24do_install_append() {
25 install -d ${D}${sysconfdir}/supervisor
26 install -d ${D}${systemd_system_unitdir}
27
28 install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor
29 install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir}
30}
diff --git a/meta-python/recipes-devtools/python/python3-meld3_1.0.2.bb b/meta-python/recipes-devtools/python/python3-meld3_1.0.2.bb
new file mode 100644
index 000000000..f69591629
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-meld3_1.0.2.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-meld3.inc
diff --git a/meta-python/recipes-devtools/python/python3-supervisor/supervisor.service b/meta-python/recipes-devtools/python/python3-supervisor/supervisor.service
new file mode 100644
index 000000000..e9d3f706b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-supervisor/supervisor.service
@@ -0,0 +1,15 @@
1[Unit]
2Description=Supervisor process control system for UNIX
3Documentation=http://supervisord.org
4After=network.target
5
6[Service]
7ExecStart=/usr/bin/supervisord -n -c /etc/supervisor/supervisord.conf
8ExecStop=/usr/bin/supervisorctl $OPTIONS shutdown
9ExecReload=/usr/bin/supervisorctl -c /etc/supervisor/supervisord.conf $OPTIONS reload
10KillMode=process
11Restart=on-failure
12RestartSec=50s
13
14[Install]
15WantedBy=multi-user.target
diff --git a/meta-python/recipes-devtools/python/python3-supervisor/supervisord.conf b/meta-python/recipes-devtools/python/python3-supervisor/supervisord.conf
new file mode 100644
index 000000000..3fb9b492d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-supervisor/supervisord.conf
@@ -0,0 +1,31 @@
1; supervisor config file
2
3[unix_http_server]
4file=/var/run/supervisor.sock ; (the path to the socket file)
5chmod=0700 ; sockef file mode (default 0700)
6
7[supervisord]
8logfile=/var/log/supervisord.log ; (main log file;default $CWD/supervisord.log)
9pidfile=/var/run/supervisord.pid ; (supervisord pidfile;default supervisord.pid)
10childlogdir=/var/log/ ; ('AUTO' child log dir, default $TEMP)
11
12; the below section must remain in the config file for RPC
13; (supervisorctl/web interface) to work, additional interfaces may be
14; added by defining them in separate rpcinterface: sections
15[rpcinterface:supervisor]
16supervisor.rpcinterface_factory = supervisor.rpcinterface:make_main_rpcinterface
17
18[supervisorctl]
19serverurl=unix:///var/run/supervisor.sock ; use a unix:// URL for a unix socket
20
21; The [include] section can just contain the "files" setting. This
22; setting can list multiple files (separated by whitespace or
23; newlines). It can also contain wildcards. The filenames are
24; interpreted as relative to this file. Included files *cannot*
25; include files themselves.
26
27[include]
28files = /etc/supervisor/conf.d/*.conf
29
30;[inet_http_server]
31;port=127.0.0.1:9001
diff --git a/meta-python/recipes-devtools/python/python3-supervisor_4.0.2.bb b/meta-python/recipes-devtools/python/python3-supervisor_4.0.2.bb
new file mode 100644
index 000000000..d29e1d6b6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-supervisor_4.0.2.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-supervisor.inc