diff options
author | Alexander Kanavin <alexander.kanavin@linux.intel.com> | 2016-02-22 19:37:08 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-03-14 12:15:33 +0100 |
commit | c259f032feb7213420451972ea00d4a89eb03edb (patch) | |
tree | 2efcfc24569a59cf125ead17a1f47c153156a317 | |
parent | bbc895b6eaf270c7d25da71362d12f8e543bec46 (diff) | |
download | meta-openembedded-c259f032feb7213420451972ea00d4a89eb03edb.tar.gz |
omgps: remove the recipe
The project is dead upstream, and relies on pygobject 2.x which has been replaced
by 3.x in oe.core.
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
9 files changed, 0 insertions, 386 deletions
diff --git a/meta-oe/recipes-navigation/omgps/omgps/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch b/meta-oe/recipes-navigation/omgps/omgps/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch deleted file mode 100644 index 6b9f465a2..000000000 --- a/meta-oe/recipes-navigation/omgps/omgps/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | From 22bcf06637d64e40af6c152e28b31eef41e3f583 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 13 Jun 2013 02:35:22 -0700 | ||
4 | Subject: [PATCH] g_type_init() is deprecated for glib >= 2.35.0 | ||
5 | |||
6 | Call it for old versions. | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | --- | ||
12 | src/main.c | 4 ++-- | ||
13 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/src/main.c b/src/main.c | ||
16 | index e984da4..a63ddf3 100644 | ||
17 | --- a/src/main.c | ||
18 | +++ b/src/main.c | ||
19 | @@ -486,9 +486,9 @@ int main(int argc, char **argv) | ||
20 | if (strcmp(argv[1], "-log2file") == 0) | ||
21 | log2console = FALSE; | ||
22 | } | ||
23 | - | ||
24 | +#if !GLIB_CHECK_VERSION(2,35,0) | ||
25 | g_type_init(); | ||
26 | - | ||
27 | +#endif | ||
28 | gdk_threads_init(); | ||
29 | |||
30 | gdk_threads_enter(); | ||
31 | -- | ||
32 | 1.7.9.5 | ||
33 | |||
diff --git a/meta-oe/recipes-navigation/omgps/omgps/fix.build.with.gcc.4.9.patch b/meta-oe/recipes-navigation/omgps/omgps/fix.build.with.gcc.4.9.patch deleted file mode 100644 index 1680bc062..000000000 --- a/meta-oe/recipes-navigation/omgps/omgps/fix.build.with.gcc.4.9.patch +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | omgps: omgps fails compilation due to uninitialized variables | ||
2 | |||
3 | omgps does not compile with gcc 4.9 due to uninitialized variables | ||
4 | with the option -Werror=maybe-uninitialized | ||
5 | To solve the problem, just initiated the variable and checked for side | ||
6 | effects. | ||
7 | Upstream-Status: Submitted | ||
8 | +https://code.google.com/p/omgps/issues/detail?id=16 | ||
9 | |||
10 | Signed-off-by: Raphael Silva <rapphil@gmail.com> | ||
11 | diff -urpN omgps.orig/src/sound.c omgps/src/sound.c | ||
12 | --- omgps.orig/src/sound.c 2014-12-14 15:13:29.609243994 -0200 | ||
13 | +++ omgps/src/sound.c 2014-12-14 15:14:13.831116745 -0200 | ||
14 | @@ -44,7 +44,7 @@ static gboolean play_sound_files(char *f | ||
15 | return FALSE; | ||
16 | |||
17 | char *bak = strdup(files); | ||
18 | - char *saveptr; | ||
19 | + char *saveptr = NULL; | ||
20 | char *p = strtok_r(bak, ";", &saveptr); | ||
21 | |||
22 | #define MAX_SOUND_FILES 14 | ||
diff --git a/meta-oe/recipes-navigation/omgps/omgps/fix.build.with.glib.2.34.patch b/meta-oe/recipes-navigation/omgps/omgps/fix.build.with.glib.2.34.patch deleted file mode 100644 index ec3bde0cd..000000000 --- a/meta-oe/recipes-navigation/omgps/omgps/fix.build.with.glib.2.34.patch +++ /dev/null | |||
@@ -1,125 +0,0 @@ | |||
1 | Upstream-Status: Submitted | ||
2 | https://code.google.com/p/omgps/issues/detail?id=15 | ||
3 | |||
4 | diff -uNr omgps.orig/src/dbus_intf.c omgps/src/dbus_intf.c | ||
5 | --- omgps.orig/src/dbus_intf.c 2011-12-12 12:22:47.000000000 +0100 | ||
6 | +++ omgps/src/dbus_intf.c 2012-11-14 14:44:45.435381443 +0100 | ||
7 | @@ -171,7 +171,7 @@ | ||
8 | gpsdata->svinfo_valid = TRUE; | ||
9 | |||
10 | int i, j; | ||
11 | - GValueArray *val; | ||
12 | + GArray *val; | ||
13 | svinfo_channel_t *sv; | ||
14 | |||
15 | j = 0; | ||
16 | @@ -179,16 +179,16 @@ | ||
17 | val = satellites->pdata[i]; | ||
18 | |||
19 | sv = &gpsdata->sv_channels[j]; | ||
20 | - sv->sv_id = g_value_get_uint(g_value_array_get_nth(val, 0)); | ||
21 | + sv->sv_id = g_array_index(val, guint, 0); | ||
22 | |||
23 | - if (g_value_get_boolean(g_value_array_get_nth(val, 1))) { | ||
24 | + if (g_array_index(val, gboolean, 1)) { | ||
25 | ++gpsdata->sv_in_use; | ||
26 | sv->flags = 0x01; | ||
27 | } | ||
28 | |||
29 | - sv->elevation = (int)g_value_get_uint(g_value_array_get_nth(val, 2)); | ||
30 | - sv->azimuth = (int)g_value_get_uint(g_value_array_get_nth(val, 3)); | ||
31 | - sv->cno = g_value_get_uint(g_value_array_get_nth(val, 4)); | ||
32 | + sv->elevation = (int)g_array_index(val, guint, 2); | ||
33 | + sv->azimuth = (int)g_array_index(val, guint, 3); | ||
34 | + sv->cno = g_array_index(val, guint, 4); | ||
35 | if (sv->cno > 0) | ||
36 | ++gpsdata->sv_get_signal; | ||
37 | |||
38 | diff -uNr omgps.orig/src/main.c omgps/src/main.c | ||
39 | --- omgps.orig/src/main.c 2011-12-12 12:22:47.000000000 +0100 | ||
40 | +++ omgps/src/main.c 2012-11-14 14:46:00.345402222 +0100 | ||
41 | @@ -489,9 +489,6 @@ | ||
42 | |||
43 | g_type_init(); | ||
44 | |||
45 | - if (! g_thread_supported ()) | ||
46 | - g_thread_init(NULL); | ||
47 | - | ||
48 | gdk_threads_init(); | ||
49 | |||
50 | gdk_threads_enter(); | ||
51 | diff -uNr omgps.orig/src/tab_gpscfg.c omgps/src/tab_gpscfg.c | ||
52 | --- omgps.orig/src/tab_gpscfg.c 2011-12-12 12:22:47.000000000 +0100 | ||
53 | +++ omgps/src/tab_gpscfg.c 2012-11-14 15:23:47.526925258 +0100 | ||
54 | @@ -222,7 +222,7 @@ | ||
55 | |||
56 | static gboolean change_platform_model_cmd(void *model_id) | ||
57 | { | ||
58 | - U1 model = (U1)(int) model_id; | ||
59 | + U1 model = (U1)GPOINTER_TO_INT(model_id); | ||
60 | int gps_dev_fd = 0; | ||
61 | |||
62 | /* non ubx means: we need open serial port | ||
63 | @@ -269,7 +269,7 @@ | ||
64 | static void change_platmodel_button_clicked(GtkWidget *widget, gpointer data) | ||
65 | { | ||
66 | int idx = gtk_combo_box_get_active(GTK_COMBO_BOX(platmodel_list)); | ||
67 | - char *model_id = (void *)(int)platmodel_values[idx]; | ||
68 | + void *model_id = (void *)GINT_TO_POINTER(platmodel_values[idx]); | ||
69 | |||
70 | if (POLL_ENGINE_TEST(UBX)) { | ||
71 | gtk_widget_set_sensitive(change_platmodel_button, FALSE); | ||
72 | diff -uNr omgps.orig/src/tab_menu.c omgps/src/tab_menu.c | ||
73 | --- omgps.orig/src/tab_menu.c 2011-12-12 12:22:47.000000000 +0100 | ||
74 | +++ omgps/src/tab_menu.c 2012-11-14 15:25:08.217941513 +0100 | ||
75 | @@ -65,7 +65,7 @@ | ||
76 | |||
77 | static void poll_button_clicked(GtkWidget *widget, gpointer data) | ||
78 | { | ||
79 | - gboolean is_start_bt = (gboolean)data; | ||
80 | + gboolean is_start_bt = (gboolean) GPOINTER_TO_INT(data); | ||
81 | |||
82 | if (POLL_STATE_TEST(RUNNING) == is_start_bt) | ||
83 | return; | ||
84 | diff -uNr omgps.orig/src/tab_tile.c omgps/src/tab_tile.c | ||
85 | --- omgps.orig/src/tab_tile.c 2011-12-12 12:22:47.000000000 +0100 | ||
86 | +++ omgps/src/tab_tile.c 2012-11-14 15:25:30.392945800 +0100 | ||
87 | @@ -101,7 +101,7 @@ | ||
88 | static gboolean set_bg_map(GtkTreeModel *model, GtkTreePath *path, GtkTreeIter *iter, gpointer data) | ||
89 | { | ||
90 | map_repo_t *repo; | ||
91 | - gboolean clear = (gboolean)data; | ||
92 | + gboolean clear = (gboolean)GPOINTER_TO_INT(data); | ||
93 | |||
94 | int type; | ||
95 | |||
96 | @@ -240,7 +240,7 @@ | ||
97 | |||
98 | static void alpha_radio_toggled (GtkWidget *widget, gpointer user_data) | ||
99 | { | ||
100 | - int idx = (int)user_data; | ||
101 | + int idx = (int)GPOINTER_TO_INT(user_data); | ||
102 | |||
103 | if (g_view.bg_alpha_idx == idx) | ||
104 | return; | ||
105 | @@ -384,7 +384,7 @@ | ||
106 | |||
107 | for (i=0; i<ALPHA_LEVELS; i++) { | ||
108 | g_signal_connect (G_OBJECT (alpha_radios[i]), "toggled", | ||
109 | - G_CALLBACK (alpha_radio_toggled), (gpointer)i); | ||
110 | + G_CALLBACK (alpha_radio_toggled), GINT_TO_POINTER(i)); | ||
111 | gtk_container_add(GTK_CONTAINER (alpha_hbox), alpha_radios[i]); | ||
112 | } | ||
113 | |||
114 | diff -uNr omgps.orig/src/tab_view.c omgps/src/tab_view.c | ||
115 | --- omgps.orig/src/tab_view.c 2011-12-12 12:22:47.000000000 +0100 | ||
116 | +++ omgps/src/tab_view.c 2012-11-14 15:25:47.018949453 +0100 | ||
117 | @@ -534,7 +534,7 @@ | ||
118 | |||
119 | static void* change_zoom_routine(void *args) | ||
120 | { | ||
121 | - gboolean is_zoom_in = (gboolean)args; | ||
122 | + gboolean is_zoom_in = (gboolean)GPOINTER_TO_INT(args); | ||
123 | stop = FALSE; | ||
124 | |||
125 | int hi = (is_zoom_in)? | ||
diff --git a/meta-oe/recipes-navigation/omgps/omgps/fix.capability.patch b/meta-oe/recipes-navigation/omgps/omgps/fix.capability.patch deleted file mode 100644 index 3ed86d8a9..000000000 --- a/meta-oe/recipes-navigation/omgps/omgps/fix.capability.patch +++ /dev/null | |||
@@ -1,62 +0,0 @@ | |||
1 | Upstream-Status: Submitted | ||
2 | https://code.google.com/p/omgps/issues/detail?id=15 | ||
3 | |||
4 | we need to include config.h first to know if HAVE_SYS_CAPABILITY_H is enabled or no, otherwise | ||
5 | sys/capability.h is not included and later used | ||
6 | | src/network.c: In function 'can_ping': | ||
7 | | src/network.c:198:2: error: 'cap_flag_value_t' undeclared (first use in this function) | ||
8 | | src/network.c:198:2: note: each undeclared identifier is reported only once for each function it appears in | ||
9 | | src/network.c:198:19: error: expected ';' before 'cap' | ||
10 | | src/network.c:199:2: error: 'cap_t' undeclared (first use in this function) | ||
11 | | src/network.c:199:8: error: expected ';' before 'caps' | ||
12 | | src/network.c:200:6: error: 'caps' undeclared (first use in this function) | ||
13 | | cc1: warnings being treated as errors | ||
14 | | src/network.c:203:2: error: implicit declaration of function 'cap_get_flag' | ||
15 | | src/network.c:203:21: error: 'CAP_SYS_NICE' undeclared (first use in this function) | ||
16 | | src/network.c:203:35: error: 'CAP_EFFECTIVE' undeclared (first use in this function) | ||
17 | | src/network.c:203:51: error: 'cap' undeclared (first use in this function) | ||
18 | | src/network.c:204:17: error: 'CAP_CLEAR' undeclared (first use in this function) | ||
19 | | src/network.c:210:1: error: control reaches end of non-void function | ||
20 | | make[1]: *** [omgps-network.o] Error 1 | ||
21 | |||
22 | and -lcap is needed for 2 functions later (should be added only for HAVE_SYS_CAPABILITY_H enabled, but I don't care enough) | ||
23 | | omgps-network.o: In function `can_ping': | ||
24 | | /OE/tmpdir-shr/work/armv4t-oe-linux-gnueabi/omgps-0.1+svnr109-r1/omgps/src/network.c:199: undefined reference to `cap_get_proc' | ||
25 | | /OE/tmpdir-shr/work/armv4t-oe-linux-gnueabi/omgps-0.1+svnr109-r1/omgps/src/network.c:203: undefined reference to `cap_get_flag' | ||
26 | | collect2: ld returned 1 exit status | ||
27 | |||
28 | --- omgps.orig/src/network.c 2009-10-28 18:51:16.000000000 +0100 | ||
29 | +++ omgps/src/network.c 2011-05-09 09:59:11.637676772 +0200 | ||
30 | @@ -19,16 +19,16 @@ | ||
31 | #include <assert.h> | ||
32 | #include <glib.h> | ||
33 | |||
34 | -#if (HAVE_SYS_CAPABILITY_H) | ||
35 | -#undef _POSIX_SOURCE | ||
36 | -#include <sys/capability.h> | ||
37 | -#endif | ||
38 | - | ||
39 | #include "config.h" | ||
40 | #include "util.h" | ||
41 | #include "network.h" | ||
42 | #include "customized.h" | ||
43 | |||
44 | +#if (HAVE_SYS_CAPABILITY_H) | ||
45 | +#undef _POSIX_SOURCE | ||
46 | +#include <sys/capability.h> | ||
47 | +#endif | ||
48 | + | ||
49 | /** | ||
50 | * Ping: reference <Unix network programming>, volume 1, third edition. | ||
51 | */ | ||
52 | --- omgps.orig/Makefile.am 2009-10-28 18:51:17.000000000 +0100 | ||
53 | +++ omgps/Makefile.am 2011-05-09 10:04:58.578676679 +0200 | ||
54 | @@ -33,7 +33,7 @@ | ||
55 | |||
56 | omgps_CFLAGS = $(common_CFLAGS) -O2 | ||
57 | omgps_LDFLAGS = | ||
58 | -omgps_LDADD = @DEPENDENCIES_LIBS@ -lpython$(PY_VERSION) | ||
59 | +omgps_LDADD = @DEPENDENCIES_LIBS@ -lcap -lpython$(PY_VERSION) | ||
60 | |||
61 | omgps_SOURCES = \ | ||
62 | src/ctx_agps_online.c \ | ||
diff --git a/meta-oe/recipes-navigation/omgps/omgps/gcc-4.4.patch b/meta-oe/recipes-navigation/omgps/omgps/gcc-4.4.patch deleted file mode 100644 index 41f6471d4..000000000 --- a/meta-oe/recipes-navigation/omgps/omgps/gcc-4.4.patch +++ /dev/null | |||
@@ -1,71 +0,0 @@ | |||
1 | Upstream-Status: Submitted | ||
2 | https://code.google.com/p/omgps/issues/detail?id=15 | ||
3 | |||
4 | diff -uNr omgps.orig/src/include/map_repo.h omgps/src/include/map_repo.h | ||
5 | --- omgps.orig/src/include/map_repo.h 2009-07-20 19:54:08.000000000 +0200 | ||
6 | +++ omgps/src/include/map_repo.h 2010-01-17 14:55:24.000000000 +0100 | ||
7 | @@ -3,6 +3,9 @@ | ||
8 | |||
9 | #include <glib.h> | ||
10 | #include <gdk/gdk.h> | ||
11 | +// workaround Python.h unconditionally (re)defines _XOPEN_SOURCE and _POSIX_C_SOURCE | ||
12 | +#undef _XOPEN_SOURCE | ||
13 | +#undef _POSIX_C_SOURCE | ||
14 | #include <Python.h> | ||
15 | |||
16 | #define MAP_MAX_BG_COLORS 5 | ||
17 | diff -uNr omgps.orig/src/include/py_ext.h omgps/src/include/py_ext.h | ||
18 | --- omgps.orig/src/include/py_ext.h 2009-07-20 19:54:08.000000000 +0200 | ||
19 | +++ omgps/src/include/py_ext.h 2010-01-17 14:55:57.000000000 +0100 | ||
20 | @@ -4,8 +4,8 @@ | ||
21 | void py_ext_init(); | ||
22 | void py_ext_cleanup(); | ||
23 | |||
24 | -void inline py_ext_trylock(); | ||
25 | -void inline py_ext_lock(); | ||
26 | -void inline py_ext_unlock(); | ||
27 | +void py_ext_trylock(); | ||
28 | +void py_ext_lock(); | ||
29 | +void py_ext_unlock(); | ||
30 | |||
31 | #endif /* PY_EXT_H_ */ | ||
32 | diff -uNr omgps.orig/src/include/uart.h omgps/src/include/uart.h | ||
33 | --- omgps.orig/src/include/uart.h 2009-07-20 19:54:08.000000000 +0200 | ||
34 | +++ omgps/src/include/uart.h 2010-01-17 14:33:00.000000000 +0100 | ||
35 | @@ -12,9 +12,9 @@ | ||
36 | extern void uart_cleanup(); | ||
37 | extern void uart_close(); | ||
38 | |||
39 | -extern inline int read_with_timeout(U1 *buf, int len); | ||
40 | -extern inline int write_with_timeout(U1 *buf, int len); | ||
41 | -extern inline gboolean read_fixed_len(U1 *buf, int expected_len); | ||
42 | +extern int read_with_timeout(U1 *buf, int len); | ||
43 | +extern int write_with_timeout(U1 *buf, int len); | ||
44 | +extern gboolean read_fixed_len(U1 *buf, int expected_len); | ||
45 | |||
46 | extern int sysfs_get_gps_device_power(); | ||
47 | extern gboolean gps_device_power_on(); | ||
48 | diff -uNr omgps.orig/src/py_ext.c omgps/src/py_ext.c | ||
49 | --- omgps.orig/src/py_ext.c 2009-07-20 19:54:08.000000000 +0200 | ||
50 | +++ omgps/src/py_ext.c 2010-01-17 14:56:46.000000000 +0100 | ||
51 | @@ -26,17 +26,17 @@ | ||
52 | Py_Finalize(); | ||
53 | } | ||
54 | |||
55 | -void inline py_ext_trylock() | ||
56 | +void py_ext_trylock() | ||
57 | { | ||
58 | TRYLOCK_MUTEX(&lock); | ||
59 | } | ||
60 | |||
61 | -void inline py_ext_lock() | ||
62 | +void py_ext_lock() | ||
63 | { | ||
64 | LOCK_MUTEX(&lock); | ||
65 | } | ||
66 | |||
67 | -void inline py_ext_unlock() | ||
68 | +void py_ext_unlock() | ||
69 | { | ||
70 | UNLOCK_MUTEX(&lock); | ||
71 | } | ||
diff --git a/meta-oe/recipes-navigation/omgps/omgps/gdk-pixbuf-2.26.5.patch b/meta-oe/recipes-navigation/omgps/omgps/gdk-pixbuf-2.26.5.patch deleted file mode 100644 index 688080573..000000000 --- a/meta-oe/recipes-navigation/omgps/omgps/gdk-pixbuf-2.26.5.patch +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | Upstream-Status: Submitted | ||
2 | https://code.google.com/p/omgps/issues/detail?id=15 | ||
3 | |||
4 | diff -uNr omgps/src/tab_scratch.c omgps.new/src/tab_scratch.c | ||
5 | --- omgps/src/tab_scratch.c 2012-12-22 18:13:25.994788128 +0100 | ||
6 | +++ omgps.new/src/tab_scratch.c 2012-12-22 18:12:45.876790644 +0100 | ||
7 | @@ -51,7 +51,7 @@ | ||
8 | } | ||
9 | |||
10 | gboolean ret = gdk_pixbuf_save (pixbuf, buf, SCREENSHOT_FILE_TYPE, &err, "tEXt::Software", "omgps", NULL); | ||
11 | - gdk_pixbuf_unref(pixbuf); | ||
12 | + g_object_unref(pixbuf); | ||
13 | |||
14 | if (ret) { | ||
15 | char buf1[128]; | ||
diff --git a/meta-oe/recipes-navigation/omgps/omgps/sysfs.node.2.6.32.patch b/meta-oe/recipes-navigation/omgps/omgps/sysfs.node.2.6.32.patch deleted file mode 100644 index 290c5e6a7..000000000 --- a/meta-oe/recipes-navigation/omgps/omgps/sysfs.node.2.6.32.patch +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | Upstream-Status: Submitted | ||
2 | https://code.google.com/p/omgps/issues/detail?id=15 | ||
3 | |||
4 | diff -uNr omgps.orig//src/uart.c omgps/src/uart.c | ||
5 | --- omgps.orig//src/uart.c 2010-08-22 23:34:09.000000000 +0200 | ||
6 | +++ omgps/src/uart.c 2010-08-22 23:33:54.000000000 +0200 | ||
7 | @@ -30,6 +30,7 @@ | ||
8 | * NOTE: these file paths are subject to change according to kernel and distribution. | ||
9 | */ | ||
10 | static const char *sysfs_gps_power[] = { | ||
11 | + "/sys/bus/platform/devices/gta02-pm-gps.0/power_on", | ||
12 | "/sys/bus/platform/devices/neo1973-pm-gps.0/power_on", | ||
13 | "/sys/bus/platform/devices/neo1973-pm-gps.0/pwron" | ||
14 | }; | ||
diff --git a/meta-oe/recipes-navigation/omgps/omgps/use.unused.variable.patch b/meta-oe/recipes-navigation/omgps/omgps/use.unused.variable.patch deleted file mode 100644 index 3ccb14ea9..000000000 --- a/meta-oe/recipes-navigation/omgps/omgps/use.unused.variable.patch +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | Upstream-Status: Submitted | ||
2 | https://code.google.com/p/omgps/issues/detail?id=15 | ||
3 | |||
4 | --- a/src/settings.c 2011-12-12 13:21:30.573400795 +0100 | ||
5 | +++ b/src/settings.c 2011-12-12 14:11:05.269606119 +0100 | ||
6 | @@ -278,6 +278,9 @@ | ||
7 | } | ||
8 | |||
9 | ret = check_settings(errbuf, ERRBUF_LEN); | ||
10 | + if (ret == FALSE) { | ||
11 | + snprintf(errbuf, ERRBUF_LEN, "Something wrong while loading settings file"); | ||
12 | + } | ||
13 | |||
14 | if (fd > 0) | ||
15 | close(fd); | ||
diff --git a/meta-oe/recipes-navigation/omgps/omgps_svn.bb b/meta-oe/recipes-navigation/omgps/omgps_svn.bb deleted file mode 100644 index 696e8630f..000000000 --- a/meta-oe/recipes-navigation/omgps/omgps_svn.bb +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | SUMMARY = "GPS application for openmoko freerunner" | ||
2 | HOMEPAGE = "http://omgps.googlecode.com" | ||
3 | SECTION = "openmoko/applications" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" | ||
6 | DEPENDS = "gtk+ python-pygobject dbus-glib libcap" | ||
7 | SRCREV = "109" | ||
8 | PV = "0.1+svnr${SRCPV}" | ||
9 | PR = "r2" | ||
10 | S = "${WORKDIR}/${BPN}" | ||
11 | |||
12 | do_configure_prepend() { | ||
13 | sed -i "s#PY_VERSION = 2.6#PY_VERSION = ${PYTHON_BASEVERSION}#g" ${S}/Makefile.am | ||
14 | sed -i "s#PY_INC_DIR = \$(OPIEDIR)#PY_INC_DIR = ${STAGING_DIR_HOST}#g" ${S}/Makefile.am | ||
15 | sed -i "s#dist_conf_DATA = data/etc/\*\.\*#dist_conf_DATA = ${S}/data/etc/\*\.\*#g" ${S}/Makefile.am | ||
16 | } | ||
17 | |||
18 | SRC_URI = "svn://omgps.googlecode.com/svn/trunk;module=omgps;protocol=http \ | ||
19 | file://gcc-4.4.patch \ | ||
20 | file://sysfs.node.2.6.32.patch \ | ||
21 | file://fix.capability.patch \ | ||
22 | file://use.unused.variable.patch \ | ||
23 | file://fix.build.with.glib.2.34.patch \ | ||
24 | file://gdk-pixbuf-2.26.5.patch \ | ||
25 | file://0001-g_type_init-is-deprecated-for-glib-2.35.0.patch \ | ||
26 | file://fix.build.with.gcc.4.9.patch \ | ||
27 | " | ||
28 | |||
29 | inherit autotools pkgconfig | ||