summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-10-30 13:06:03 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-06 17:49:40 +0100
commitb6a62aa38242a2bd0cebbe18219af36da5b0e6dd (patch)
tree4fe9bf3e339f87ccf2a5eb54f118e34202db6fdf
parent51abcdcbdced22cceadba65f5a45f1eb84dd8055 (diff)
downloadmeta-openembedded-b6a62aa38242a2bd0cebbe18219af36da5b0e6dd.tar.gz
libubox: fix libdir
The library dir maybe /usr/lib64 or /usr/lib, so use the variable CMAKE_INSTALL_LIBDIR, not hardcode to lib Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/libubox/libubox/fix-libdir.patch40
-rw-r--r--meta-oe/recipes-devtools/libubox/libubox_git.bb1
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/libubox/libubox/fix-libdir.patch b/meta-oe/recipes-devtools/libubox/libubox/fix-libdir.patch
new file mode 100644
index 000000000..6f09c8b29
--- /dev/null
+++ b/meta-oe/recipes-devtools/libubox/libubox/fix-libdir.patch
@@ -0,0 +1,40 @@
1[PATCH] fix the CMAKE_INSTALL_LIBDIR
2
3Upstream-Status: Pending
4
5libdir maybe /usr/lib64 for 64bit machine
6
7Signed-off-by: Roy Li <rongqing.li@windriver.com>
8---
9 CMakeLists.txt | 8 ++++----
10 1 file changed, 4 insertions(+), 4 deletions(-)
11
12diff --git a/CMakeLists.txt b/CMakeLists.txt
13index 57804cf..2c7bdc1 100644
14--- a/CMakeLists.txt
15+++ b/CMakeLists.txt
16@@ -35,8 +35,8 @@ INSTALL(FILES ${headers}
17 DESTINATION include/libubox
18 )
19 INSTALL(TARGETS ubox ubox-static
20- ARCHIVE DESTINATION lib
21- LIBRARY DESTINATION lib
22+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
23+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
24 )
25
26 ADD_SUBDIRECTORY(lua)
27@@ -58,8 +58,8 @@ IF(EXISTS ${json})
28 TARGET_LINK_LIBRARIES(json_script ubox)
29
30 INSTALL(TARGETS blobmsg_json blobmsg_json-static jshn json_script
31- ARCHIVE DESTINATION lib
32- LIBRARY DESTINATION lib
33+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
34+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
35 RUNTIME DESTINATION bin
36 )
37
38--
391.9.1
40
diff --git a/meta-oe/recipes-devtools/libubox/libubox_git.bb b/meta-oe/recipes-devtools/libubox/libubox_git.bb
index 3e886b766..d0da2c54f 100644
--- a/meta-oe/recipes-devtools/libubox/libubox_git.bb
+++ b/meta-oe/recipes-devtools/libubox/libubox_git.bb
@@ -15,6 +15,7 @@ LIC_FILES_CHKSUM = "\
15SRC_URI = "\ 15SRC_URI = "\
16 git://git.openwrt.org/project/libubox.git \ 16 git://git.openwrt.org/project/libubox.git \
17 file://0001-version-libraries.patch \ 17 file://0001-version-libraries.patch \
18 file://fix-libdir.patch \
18" 19"
19 20
20SRCREV = "136a5196266d03d537f822c4e67d2fde2ed59505" 21SRCREV = "136a5196266d03d537f822c4e67d2fde2ed59505"