summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnders Darander <anders@chargestorm.se>2012-01-19 19:53:07 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-01-20 08:24:37 +0100
commitacfe5820feacb045751e8f9c63cb020427fcfd35 (patch)
tree804ea9b179f5caa9b929c00a4f6c3ac0770b1687
parent6cb51af0e1f09e7658cd1bfdc721cb5106ec9dfd (diff)
downloadmeta-openembedded-acfe5820feacb045751e8f9c63cb020427fcfd35.tar.gz
systemd: split out systemd-analyze
Split systemd-analyze to a separate package, to remove the implicit dependency on python. (At least the rpm-packaging backend created a run-time dependency on python). Add an RDEPENDS_${PN}-analyze on python-dbus, as this is required for systemd-analyze to work. Add an RRECOMMENDS_${PN}-analyze on python-pycairo, as the plot command in systemd-analyze requires this package. Signed-off-by: Anders Darander <anders@chargestorm.se> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 32bdee941..b779f61d9 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,7 +14,7 @@ inherit gitpkgv
14PKGV = "v${GITPKGVTAG}" 14PKGV = "v${GITPKGVTAG}"
15 15
16PV = "git" 16PV = "git"
17PR = "r8" 17PR = "r9"
18 18
19inherit useradd pkgconfig autotools vala perlnative 19inherit useradd pkgconfig autotools vala perlnative
20 20
@@ -58,11 +58,15 @@ do_install() {
58 ln -s ${base_bindir}/systemd ${D}/init 58 ln -s ${base_bindir}/systemd ${D}/init
59} 59}
60 60
61PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs" 61PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs ${PN}-analyze"
62 62
63USERADD_PACKAGES = "${PN}" 63USERADD_PACKAGES = "${PN}"
64GROUPADD_PARAM_${PN} = "-r lock" 64GROUPADD_PARAM_${PN} = "-r lock"
65 65
66FILES_${PN}-analyze = "${bindir}/systemd-analyze"
67RDEPENDS_${PN}-analyze = "python-dbus"
68RRECOMMENDS_${PN}-analyze = "python-pycairo"
69
66FILES_${PN}-initramfs = "/init" 70FILES_${PN}-initramfs = "/init"
67RDEPENDS_${PN}-initramfs = "${PN}" 71RDEPENDS_${PN}-initramfs = "${PN}"
68 72