diff options
author | Nick Lewis <nick.lewis@usa.g4s.com> | 2014-06-16 14:39:20 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-06-21 10:36:53 +0200 |
commit | a6eaef942529ed9fc511bd86dd00369862297b26 (patch) | |
tree | 47881563a70171411b1da7728908903e2801432b | |
parent | 87317f52e9b9a22e64454da6ad6cbd48a89ed951 (diff) | |
download | meta-openembedded-a6eaef942529ed9fc511bd86dd00369862297b26.tar.gz |
libxml++: fix ptest target paths
Signed-off-by: Nick Lewis <nick.lewis@usa.g4s.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch | 23 |
1 files changed, 16 insertions, 7 deletions
diff --git a/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch b/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch index 1e847be7a..82960f112 100644 --- a/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch +++ b/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch | |||
@@ -12,10 +12,19 @@ index d4aadb1..0e36756 100644 | |||
12 | # Optional: auto-generate the ChangeLog file from the git log on make dist | 12 | # Optional: auto-generate the ChangeLog file from the git log on make dist |
13 | include $(top_srcdir)/macros/dist-changelog.am | 13 | include $(top_srcdir)/macros/dist-changelog.am |
14 | diff --git a/examples/Makefile.am b/examples/Makefile.am | 14 | diff --git a/examples/Makefile.am b/examples/Makefile.am |
15 | index d9541ca..c28b49c 100644 | 15 | index d9541ca..c27e088 100644 |
16 | --- a/examples/Makefile.am | 16 | --- a/examples/Makefile.am |
17 | +++ b/examples/Makefile.am | 17 | +++ b/examples/Makefile.am |
18 | @@ -36,6 +36,23 @@ check_PROGRAMS = \ | 18 | @@ -19,6 +19,8 @@ AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir) -I. $(LIBXMLXX_CFLAGS) |
19 | AM_CXXFLAGS = $(LIBXMLXX_WXXFLAGS) | ||
20 | LDADD = $(top_builddir)/libxml++/libxml++-$(LIBXMLXX_API_VERSION).la $(LIBXMLXX_LIBS) | ||
21 | |||
22 | +LOG_DRIVER = $(SHELL) ../macros/test-driver | ||
23 | + | ||
24 | check_PROGRAMS = \ | ||
25 | dom_build/dom_build \ | ||
26 | dom_parse_entities/dom_parse_entities \ | ||
27 | @@ -36,6 +38,23 @@ check_PROGRAMS = \ | ||
19 | schemavalidation/schemavalidation \ | 28 | schemavalidation/schemavalidation \ |
20 | textreader/textreader | 29 | textreader/textreader |
21 | 30 | ||
@@ -39,20 +48,20 @@ index d9541ca..c28b49c 100644 | |||
39 | # Shell scripts that call the example programs. | 48 | # Shell scripts that call the example programs. |
40 | check_SCRIPTS = \ | 49 | check_SCRIPTS = \ |
41 | dom_build/make_check.sh \ | 50 | dom_build/make_check.sh \ |
42 | @@ -147,10 +164,10 @@ dist_noinst_DATA = \ | 51 | @@ -147,10 +166,10 @@ dist_noinst_DATA = \ |
43 | # file are located in different directories. | 52 | # file are located in different directories. |
44 | dom_read_write/make_check.sh: Makefile | 53 | dom_read_write/make_check.sh: Makefile |
45 | echo '# Generated and used by "make check"' >$@ | 54 | echo '# Generated and used by "make check"' >$@ |
46 | - echo 'dom_read_write/dom_read_write "$(srcdir)/dom_read_write/example.xml" dom_read_write/example_output.xml >/dev/null' >>$@ | 55 | - echo 'dom_read_write/dom_read_write "$(srcdir)/dom_read_write/example.xml" dom_read_write/example_output.xml >/dev/null' >>$@ |
47 | + echo 'dom_read_write/.libs/dom_read_write "$(srcdir)/dom_read_write/example.xml" dom_read_write/example_output.xml >/dev/null' >>$@ | 56 | + echo 'cd dom_read_write && .libs/dom_read_write "example.xml" example_output.xml >/dev/null' >>$@ |
48 | chmod +x $@ | 57 | chmod +x $@ |
49 | 58 | ||
50 | -script_template = cd "$(srcdir)/<!progname!>" && "$(abs_builddir)/<!progname!>/<!progname!>" >/dev/null | 59 | -script_template = cd "$(srcdir)/<!progname!>" && "$(abs_builddir)/<!progname!>/<!progname!>" >/dev/null |
51 | +script_template = cd "$(srcdir)/<!progname!>" && ".libs/<!progname!>" >/dev/null | 60 | +script_template = cd "<!progname!>" && ".libs/<!progname!>" >/dev/null |
52 | standard_scripts = $(filter-out dom_read_write/make_check.sh,$(check_SCRIPTS)) | 61 | standard_scripts = $(filter-out dom_read_write/make_check.sh,$(check_SCRIPTS)) |
53 | 62 | ||
54 | # All other script files are generated like so: | 63 | # All other script files are generated like so: |
55 | @@ -162,3 +179,18 @@ $(standard_scripts): Makefile | 64 | @@ -162,3 +181,18 @@ $(standard_scripts): Makefile |
56 | CLEANFILES = \ | 65 | CLEANFILES = \ |
57 | dom_read_write/example_output.xml \ | 66 | dom_read_write/example_output.xml \ |
58 | $(check_SCRIPTS) | 67 | $(check_SCRIPTS) |
@@ -65,7 +74,7 @@ index d9541ca..c28b49c 100644 | |||
65 | + $(MKDIR_P) $(DESTDIR)/examples | 74 | + $(MKDIR_P) $(DESTDIR)/examples |
66 | + cp --parents $(check_DOTLIBS) $(DESTDIR)/examples | 75 | + cp --parents $(check_DOTLIBS) $(DESTDIR)/examples |
67 | + cp --parents $(check_SCRIPTS) $(DESTDIR)/examples | 76 | + cp --parents $(check_SCRIPTS) $(DESTDIR)/examples |
68 | + $(foreach i, $(dist_noinst_DATA), cp --parents $(srcdir)/$(i) $(DESTDIR)/examples;) | 77 | + cd $(srcdir) && cp --parents $(dist_noinst_DATA) $(DESTDIR)/examples |
69 | + cp Makefile $(DESTDIR)/examples | 78 | + cp Makefile $(DESTDIR)/examples |
70 | + $(MKDIR_P) $(DESTDIR)/macros | 79 | + $(MKDIR_P) $(DESTDIR)/macros |
71 | + cp $(srcdir)/../macros/test-driver $(DESTDIR)/macros | 80 | + cp $(srcdir)/../macros/test-driver $(DESTDIR)/macros |