diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-01-24 12:50:57 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-01-24 13:20:51 +0100 |
commit | a388dabbcd734ecb6926c79c2a418613b9fff1dd (patch) | |
tree | 65e73a9f2ba04b4a6d78bef6e6904a8189a86ec2 | |
parent | 926b8427285306545df5e46a3dfe30b92d66afb3 (diff) | |
download | meta-openembedded-a388dabbcd734ecb6926c79c2a418613b9fff1dd.tar.gz |
xbmc: enable libusb and fix zeroconf
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r-- | meta-oe/recipes-multimedia/xbmc/xbmc/0004-ARM-Don-t-forcefully-disable-avahi-configure-has-che.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/xbmc/xbmc_git.bb | 7 |
2 files changed, 36 insertions, 2 deletions
diff --git a/meta-oe/recipes-multimedia/xbmc/xbmc/0004-ARM-Don-t-forcefully-disable-avahi-configure-has-che.patch b/meta-oe/recipes-multimedia/xbmc/xbmc/0004-ARM-Don-t-forcefully-disable-avahi-configure-has-che.patch new file mode 100644 index 000000000..303f382df --- /dev/null +++ b/meta-oe/recipes-multimedia/xbmc/xbmc/0004-ARM-Don-t-forcefully-disable-avahi-configure-has-che.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From e8112cd4bafdbbfd88f3cc9a10b7b8e08fbbea01 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Tue, 24 Jan 2012 12:40:29 +0100 | ||
4 | Subject: [PATCH 4/4] [ARM] Don't forcefully disable avahi, configure has checks for it already | ||
5 | |||
6 | This fixes zeroconf on ARM platforms that do support avahi like Beagleboard/Angstrom | ||
7 | |||
8 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
9 | --- | ||
10 | |||
11 | Upstream-status: Pending | ||
12 | |||
13 | xbmc/system.h | 2 -- | ||
14 | 1 files changed, 0 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/xbmc/system.h b/xbmc/system.h | ||
17 | index c838dc8..b10ebae 100644 | ||
18 | --- a/xbmc/system.h | ||
19 | +++ b/xbmc/system.h | ||
20 | @@ -222,8 +222,6 @@ | ||
21 | |||
22 | // ARM does not support certain features... disable them here! | ||
23 | #ifdef _ARMEL | ||
24 | -#undef HAS_AVAHI | ||
25 | -#undef HAS_ZEROCONF | ||
26 | #undef HAS_VISUALISATION | ||
27 | #undef HAS_FILESYSTEM_HTSP | ||
28 | #endif | ||
29 | -- | ||
30 | 1.7.2.5 | ||
31 | |||
diff --git a/meta-oe/recipes-multimedia/xbmc/xbmc_git.bb b/meta-oe/recipes-multimedia/xbmc/xbmc_git.bb index 092f1fe0a..4e8c9b04f 100644 --- a/meta-oe/recipes-multimedia/xbmc/xbmc_git.bb +++ b/meta-oe/recipes-multimedia/xbmc/xbmc_git.bb | |||
@@ -3,18 +3,19 @@ DESCRIPTION = "XBMC Media Center" | |||
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=6eb631b6da7fdb01508a80213ffc35ff" | 4 | LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=6eb631b6da7fdb01508a80213ffc35ff" |
5 | 5 | ||
6 | DEPENDS = "libcec libplist expat yajl gperf-native libxmu fribidi mpeg2dec ffmpeg samba fontconfig curl python libass libmodplug libmicrohttpd wavpack libmms cmake-native libsdl-image libsdl-mixer virtual/egl mysql5 sqlite3 libmms faad2 libcdio libpcre boost lzo enca avahi libsamplerate0 libxinerama libxrandr libxtst bzip2 virtual/libsdl jasper zip-native zlib" | 6 | DEPENDS = "libusb1 libcec libplist expat yajl gperf-native libxmu fribidi mpeg2dec ffmpeg samba fontconfig curl python libass libmodplug libmicrohttpd wavpack libmms cmake-native libsdl-image libsdl-mixer virtual/egl mysql5 sqlite3 libmms faad2 libcdio libpcre boost lzo enca avahi libsamplerate0 libxinerama libxrandr libxtst bzip2 virtual/libsdl jasper zip-native zlib" |
7 | #require recipes/egl/egl.inc | 7 | #require recipes/egl/egl.inc |
8 | 8 | ||
9 | SRCREV = "f119e6aa5ff44d8bf8e670d5d7c21e2fc4832a7c" | 9 | SRCREV = "f119e6aa5ff44d8bf8e670d5d7c21e2fc4832a7c" |
10 | 10 | ||
11 | PV = "11.0" | 11 | PV = "11.0" |
12 | PR = "r4" | 12 | PR = "r5" |
13 | PR_append = "+gitr${SRCPV}" | 13 | PR_append = "+gitr${SRCPV}" |
14 | SRC_URI = "git://github.com/xbmc/xbmc.git;branch=eden;protocol=git \ | 14 | SRC_URI = "git://github.com/xbmc/xbmc.git;branch=eden;protocol=git \ |
15 | file://0001-configure-don-t-run-python-distutils-to-find-STAGING.patch \ | 15 | file://0001-configure-don-t-run-python-distutils-to-find-STAGING.patch \ |
16 | file://0002-Revert-fixed-ios-Add-memory-barriers-to-atomic-Add-S.patch \ | 16 | file://0002-Revert-fixed-ios-Add-memory-barriers-to-atomic-Add-S.patch \ |
17 | file://0003-Revert-fixed-ios-Add-memory-barriers-to-cas-assembly.patch \ | 17 | file://0003-Revert-fixed-ios-Add-memory-barriers-to-cas-assembly.patch \ |
18 | file://0004-ARM-Don-t-forcefully-disable-avahi-configure-has-che.patch \ | ||
18 | " | 19 | " |
19 | 20 | ||
20 | inherit autotools gettext python-dir | 21 | inherit autotools gettext python-dir |
@@ -24,6 +25,8 @@ S = "${WORKDIR}/git" | |||
24 | EXTRA_OECONF = " \ | 25 | EXTRA_OECONF = " \ |
25 | --disable-rpath \ | 26 | --disable-rpath \ |
26 | --enable-gles \ | 27 | --enable-gles \ |
28 | --enable-libusb \ | ||
29 | --enable-airplay \ | ||
27 | --disable-optical-drive \ | 30 | --disable-optical-drive \ |
28 | --enable-external-libraries \ | 31 | --enable-external-libraries \ |
29 | " | 32 | " |