diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2018-08-14 00:22:20 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-15 08:20:06 -0700 |
commit | 7e06f7e4a21319d8e6b14be804691f02c5012332 (patch) | |
tree | 8d484b2046f490575cee04d717889cef3fa728ef | |
parent | ca016f115d5cc601b970245eb9cf49cf3a79506a (diff) | |
download | meta-openembedded-7e06f7e4a21319d8e6b14be804691f02c5012332.tar.gz |
python3-blivet: add `-Z y' and `-y' to lvm.pvcreate
While reinstall a crypt fs, it occasionally failed
[snip]
|gi.overrides.BlockDev.LVMError: Process reported exit code 5:
WARNING: atari signature detected on /dev/mapper/luks-0e5f891c
-7701-48bc-a41e-8d626b6ef953 at offset 466. Wipe it? [y/n]:
[snip]
Add `-Z y' and `-y' to lvm.pvcreate
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-extended/python-blivet/python3-blivet/0013-add-Z-y-and-y-to-lvm.pvcreate.patch | 41 | ||||
-rw-r--r-- | meta-python/recipes-extended/python-blivet/python3-blivet_3.0.1.bb | 1 |
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0013-add-Z-y-and-y-to-lvm.pvcreate.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0013-add-Z-y-and-y-to-lvm.pvcreate.patch new file mode 100644 index 000000000..33b5f51f9 --- /dev/null +++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0013-add-Z-y-and-y-to-lvm.pvcreate.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | From bddbfa499df16b108f2d892ee48d65617523c33d Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Thu, 9 Aug 2018 11:00:39 +0800 | ||
4 | Subject: [PATCH] add `-Z y' and `-y' to lvm.pvcreate | ||
5 | |||
6 | While reinstall a crypt fs, it occasionally failed | ||
7 | [snip] | ||
8 | |gi.overrides.BlockDev.LVMError: Process reported exit code 5: | ||
9 | WARNING: atari signature detected on /dev/mapper/luks-0e5f891c | ||
10 | -7701-48bc-a41e-8d626b6ef953 at offset 466. Wipe it? [y/n]: | ||
11 | [snip] | ||
12 | |||
13 | Add `-Z y' and `-y' to lvm.pvcreate | ||
14 | |||
15 | Upstream-Status: Submitted [https://github.com/storaged-project/blivet/pull/714] | ||
16 | |||
17 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
18 | --- | ||
19 | blivet/formats/lvmpv.py | 6 +++--- | ||
20 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
21 | |||
22 | diff --git a/blivet/formats/lvmpv.py b/blivet/formats/lvmpv.py | ||
23 | index 260cc0b..4bbb46f 100644 | ||
24 | --- a/blivet/formats/lvmpv.py | ||
25 | +++ b/blivet/formats/lvmpv.py | ||
26 | @@ -120,9 +120,9 @@ class LVMPhysicalVolume(DeviceFormat): | ||
27 | log_method_call(self, device=self.device, | ||
28 | type=self.type, status=self.status) | ||
29 | |||
30 | - # Consider use of -Z|--zero | ||
31 | - # -f|--force or -y|--yes may be required | ||
32 | - blockdev.lvm.pvcreate(self.device, data_alignment=self.data_alignment) | ||
33 | + ea_zero = blockdev.ExtraArg.new("-Z", "y") | ||
34 | + ea_yes = blockdev.ExtraArg.new("-y", "") | ||
35 | + blockdev.lvm.pvcreate(self.device, data_alignment=self.data_alignment, extra=[ea_zero, ea_yes]) | ||
36 | |||
37 | def _destroy(self, **kwargs): | ||
38 | log_method_call(self, device=self.device, | ||
39 | -- | ||
40 | 2.7.4 | ||
41 | |||
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.0.1.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.0.1.bb index 5fcbd88eb..75f02f13d 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.0.1.bb +++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.0.1.bb | |||
@@ -22,6 +22,7 @@ SRC_URI = "git://github.com/rhinstaller/blivet;branch=3.1-release \ | |||
22 | file://0010-invoking-mkfs-with-infinite-timeout.patch \ | 22 | file://0010-invoking-mkfs-with-infinite-timeout.patch \ |
23 | file://0011-invoking-dd-with-infinite-timeout.patch \ | 23 | file://0011-invoking-dd-with-infinite-timeout.patch \ |
24 | file://0012-remove-dmraid-dependency-check.patch \ | 24 | file://0012-remove-dmraid-dependency-check.patch \ |
25 | file://0013-add-Z-y-and-y-to-lvm.pvcreate.patch \ | ||
25 | " | 26 | " |
26 | 27 | ||
27 | UPSTREAM_CHECK_GITTAGREGEX = "blivet-(?P<pver>\d+(\.\d+)+)$" | 28 | UPSTREAM_CHECK_GITTAGREGEX = "blivet-(?P<pver>\d+(\.\d+)+)$" |