summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-11-25 16:37:09 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-25 20:53:06 +0100
commit639323c998a8c53eef864bcde091c6e0bd2dc00a (patch)
tree3294ccce896d3d62d0794f34f12f901609aa3692
parent8130a2f78cfec19f5d0e829bdec133a39e2672fd (diff)
downloadmeta-openembedded-639323c998a8c53eef864bcde091c6e0bd2dc00a.tar.gz
digitemp: fix build for non x86 architectures
* fix Makefile to allow CC and CFLAGS override * clean binaries before build Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch20
-rw-r--r--meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb11
2 files changed, 30 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch b/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch
new file mode 100644
index 000000000..c0d552d54
--- /dev/null
+++ b/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch
@@ -0,0 +1,20 @@
1digitemp: allow override of CC and CFLAGS vars
2
3Upstream-Status: Inappropriate [embedded specific]
4
5Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
6
7--- a/Makefile 2008-08-28 21:37:00.000000000 +0000
8+++ b/Makefile 2011-11-24 22:22:39.882511272 +0000
9@@ -11,8 +11,9 @@
10
11 VERSION = 3.6.0
12
13-CC = gcc
14-CFLAGS = -I./src -I./userial -O2 -Wall # -g
15+CC ?= gcc
16+CFLAGS ?= -O2 -Wall # -g
17+CFLAGS += -I./src -I./userial
18
19 OBJS = src/digitemp.o src/device_name.o src/ds2438.o
20 HDRS = src/digitemp.h src/device_name.h
diff --git a/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb b/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb
index e2ad6919a..395e56ad3 100644
--- a/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb
+++ b/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb
@@ -4,10 +4,19 @@ DEPENDS = "libusb1"
4LICENSE = "GPLv2" 4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=44fee82a1d2ed0676cf35478283e0aa0" 5LIC_FILES_CHKSUM = "file://COPYING;md5=44fee82a1d2ed0676cf35478283e0aa0"
6 6
7SRC_URI = "http://www.digitemp.com/software/linux/digitemp-${PV}.tar.gz" 7PR = "r1"
8
9SRC_URI = "http://www.digitemp.com/software/linux/digitemp-${PV}.tar.gz \
10 file://makefile-fix.patch"
8 11
9inherit autotools 12inherit autotools
10 13
14EXTRA_OEMAKE = "ds9097 ds9097u"
15
16do_configure() {
17 rm -f digitemp_*
18}
19
11do_install() { 20do_install() {
12 install -d ${D}${sbindir} 21 install -d ${D}${sbindir}
13 install digitemp_* ${D}${sbindir} 22 install digitemp_* ${D}${sbindir}