diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-03 20:45:22 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-03 20:45:22 +0100 |
commit | 4fafe9bf33d015defd2fd3324a53ff2d17876c33 (patch) | |
tree | daf8a566b312fba6b95ca8ac79f2b85fb7f88fee | |
parent | 120753e7437bc893462356ef153b67d38f7f696e (diff) | |
download | meta-openembedded-4fafe9bf33d015defd2fd3324a53ff2d17876c33.tar.gz |
lighttpd: bbapend 1.4.29 to add native systemd support
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r-- | meta-oe/recipes-extended/lighttpd/lighttpd/lighttpd.service | 13 | ||||
-rw-r--r-- | meta-oe/recipes-extended/lighttpd/lighttpd_1.4.29.bbappend | 16 |
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/lighttpd/lighttpd/lighttpd.service b/meta-oe/recipes-extended/lighttpd/lighttpd/lighttpd.service new file mode 100644 index 000000000..18b752f15 --- /dev/null +++ b/meta-oe/recipes-extended/lighttpd/lighttpd/lighttpd.service | |||
@@ -0,0 +1,13 @@ | |||
1 | [Unit] | ||
2 | Description=Lightning Fast Webserver With Light System Requirements | ||
3 | After=syslog.target | ||
4 | |||
5 | [Service] | ||
6 | Type=oneshot | ||
7 | EnvironmentFile=-/etc/sysconfig/lighttpd | ||
8 | ExecStart=/usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf | ||
9 | RemainAfterExit=yes | ||
10 | |||
11 | [Install] | ||
12 | WantedBy=multi-user.target | ||
13 | |||
diff --git a/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.29.bbappend b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.29.bbappend new file mode 100644 index 000000000..b914405b7 --- /dev/null +++ b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.29.bbappend | |||
@@ -0,0 +1,16 @@ | |||
1 | FILESEXTRAPATHS := "${THISDIR}/${PN}" | ||
2 | |||
3 | PRINC = "1" | ||
4 | |||
5 | SRC_URI += "file://lighttpd.service" | ||
6 | |||
7 | do_install_append() { | ||
8 | install -d ${D}${base_libdir}/systemd/systemd/ | ||
9 | install -m 0644 ${WORKDIR}/lighttpd.service ${D}${base_libdir}/systemd/systemd/ | ||
10 | |||
11 | install -d ${D}${base_libdir}/systemd/systemd/multi-user.target.wants | ||
12 | ln -sf ../lighttpd.service ${D}${base_libdir}/systemd/systemd/multi-user.target.wants | ||
13 | } | ||
14 | |||
15 | FILES_${PN} += "${base_libdir}/systemd" | ||
16 | |||