summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2016-05-30 03:39:23 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:24 +0200
commit0cce9fee049c3186cd07d791f602ada52e5afbc9 (patch)
tree34989061bd0cb1683650f983a04966810fb5a7df
parent25f31a59529a7df6895cd0df16a5b4541af86b33 (diff)
downloadmeta-openembedded-0cce9fee049c3186cd07d791f602ada52e5afbc9.tar.gz
efivar-native: fix compile failure with older host gcc (<=4.6)
While host gcc version is 4.6.3 in ubuntu 1204, it did not recognize -std=gnu11 and -Wmaybe-uninitialized. While host gcc version is 4.4.7 in centos6, it did not recognize -std=gnu11, -Wmaybe-uninitialized, and -flto. For native build, use -std=gnu99 to replace -std=gnu11, and directly remove -Wmaybe-uninitialized and -flto. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/efivar/efivar/fix-compile-failure-with-host-gcc-4.6.patch45
-rw-r--r--meta-oe/recipes-extended/efivar/efivar_0.23.bb2
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/efivar/efivar/fix-compile-failure-with-host-gcc-4.6.patch b/meta-oe/recipes-extended/efivar/efivar/fix-compile-failure-with-host-gcc-4.6.patch
new file mode 100644
index 000000000..1c68a2934
--- /dev/null
+++ b/meta-oe/recipes-extended/efivar/efivar/fix-compile-failure-with-host-gcc-4.6.patch
@@ -0,0 +1,45 @@
1From 1361225abbaba878960f970df39a4570bbc39553 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Thu, 26 May 2016 21:50:01 -0400
4Subject: [PATCH] fix compile failure with older host gcc (<=4.6)
5
6While host gcc version is 4.6.3 in ubuntu 1204, it
7did not recognize -std=gnu11 and -Wmaybe-uninitialized.
8
9While host gcc version is 4.4.7 in centos6, it
10did not recognize -std=gnu11, -Wmaybe-uninitialized,
11and -flto.
12
13For native build, use -std=gnu99 to replace -std=gnu11,
14and directly remove -Wmaybe-uninitialized and -flto.
15
16Upstream-Status: Pending
17
18Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
19---
20 gcc.specs | 4 ++--
21 1 file changed, 2 insertions(+), 2 deletions(-)
22
23diff --git a/gcc.specs b/gcc.specs
24index 0d4bbda..3802ca6 100644
25--- a/gcc.specs
26+++ b/gcc.specs
27@@ -2,13 +2,13 @@
28 + -D_GNU_SOURCE
29
30 *efivar_cpp_options:
31- -Werror -Wall -std=gnu11 -Wextra
32+ -Werror -Wall -std=gnu99 -Wextra
33
34 *cpp_options:
35 + %(efivar_cpp_options)
36
37 *cc1_options:
38-+ %(efivar_cpp_options) -Wmaybe-uninitialized -fno-merge-constants -flto -fvisibility=hidden %{!r:%{!fpie:%{!fPIE:%{!fpic:%{!fPIC:%{!fno-pic:-fPIE}}}}}}
39++ %(efivar_cpp_options) -fno-merge-constants -fvisibility=hidden %{!r:%{!fpie:%{!fPIE:%{!fpic:%{!fPIC:%{!fno-pic:-fPIE}}}}}}
40
41 *self_spec:
42 + %{!shared:%{!static:%{!r:-pie}}} %{static:-Wl,-no-fatal-warnings -Wl,-static -static -Wl,-z,relro,-z,now}
43--
442.8.1
45
diff --git a/meta-oe/recipes-extended/efivar/efivar_0.23.bb b/meta-oe/recipes-extended/efivar/efivar_0.23.bb
index 6e9a51fc9..046cad974 100644
--- a/meta-oe/recipes-extended/efivar/efivar_0.23.bb
+++ b/meta-oe/recipes-extended/efivar/efivar_0.23.bb
@@ -14,6 +14,8 @@ SRC_URI_append_class-target = " file://0001-efivar-fix-for-cross-compile.patch \
14 file://0003-efivar-fix-for-cross-compile.patch \ 14 file://0003-efivar-fix-for-cross-compile.patch \
15 file://0004-fix-unknow-option-for-gold-linker.patch \ 15 file://0004-fix-unknow-option-for-gold-linker.patch \
16 " 16 "
17SRC_URI_append_class-native = " file://fix-compile-failure-with-host-gcc-4.6.patch \
18 "
17 19
18S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
19 21