summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianfranco Costamagna <costamagna.gianfranco@gmail.com>2020-01-09 11:36:51 +0100
committerArmin Kuster <akuster808@gmail.com>2020-01-19 09:01:43 -0800
commiteb8090f27afb865878a04aaeff6caac34abdbac0 (patch)
tree189062942ae0bced4d141bcebc3de369195b0421
parent636660b7b2431da724d391d237d3680a72470121 (diff)
downloadmeta-openembedded-eb8090f27afb865878a04aaeff6caac34abdbac0.tar.gz
websocketpp: add various upstream accepted and proposed patches to fix various issues, including:
- build failure with boost 1.71 - bad installation of header files correct version on some OSes. - fix version minor number - fix Scons script not being Python3 ready - build examples and tests only if ptest is enabled in DISTRO_FEATURES - do not depend on websocketpp from -dev package, because this is an header only dev package for now Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it> Signed-off-by: Gianfranco Costamagna <locutusofborg@debian.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 7cd26041725e57dd0680767a513955193e1f0d63) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/771.patch22
-rw-r--r--meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/842.patch30
-rw-r--r--meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch23
-rw-r--r--meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/857.patch132
-rw-r--r--meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb15
5 files changed, 221 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/771.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/771.patch
new file mode 100644
index 000000000..bc65efb7d
--- /dev/null
+++ b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/771.patch
@@ -0,0 +1,22 @@
1From 4bccfb04a264704ec9b80ba332ee1cf113ce7f1b Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Wolfgang=20St=C3=B6ggl?= <c72578@yahoo.de>
3Date: Thu, 1 Nov 2018 20:58:10 +0100
4Subject: [PATCH] Update version number in CMakeLists.txt to 0.8.1
5
6---
7 CMakeLists.txt | 2 +-
8 1 file changed, 1 insertion(+), 1 deletion(-)
9
10diff --git a/CMakeLists.txt b/CMakeLists.txt
11index 2786aba9..2d13117b 100644
12--- a/CMakeLists.txt
13+++ b/CMakeLists.txt
14@@ -24,7 +24,7 @@ endif ()
15 ############ Project name and version
16 set (WEBSOCKETPP_MAJOR_VERSION 0)
17 set (WEBSOCKETPP_MINOR_VERSION 8)
18-set (WEBSOCKETPP_PATCH_VERSION 0)
19+set (WEBSOCKETPP_PATCH_VERSION 1)
20 set (WEBSOCKETPP_VERSION ${WEBSOCKETPP_MAJOR_VERSION}.${WEBSOCKETPP_MINOR_VERSION}.${WEBSOCKETPP_PATCH_VERSION})
21
22 if(POLICY CMP0048)
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/842.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/842.patch
new file mode 100644
index 000000000..c3651e94a
--- /dev/null
+++ b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/842.patch
@@ -0,0 +1,30 @@
1From 7f7e2be01b4fa6580ce27f668e61adf37853ad67 Mon Sep 17 00:00:00 2001
2From: Schrijvers Luc <begasus@gmail.com>
3Date: Wed, 18 Sep 2019 11:35:43 +0200
4Subject: [PATCH] Fix "include" directory installation. the variable
5 INSTALL_INCLUDE_DIR already exists, and defaults to include if not
6 specificied otherwise. Using it allows people to customize the installation
7 from outside, fixing issues with other OS like Haiku
8
9Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
10Signed-off-by: Gianfranco Costamagna <locutusofborg@debian.org>
11---
12 cmake/CMakeHelpers.cmake | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/cmake/CMakeHelpers.cmake b/cmake/CMakeHelpers.cmake
16index 1478f4b..f603632 100644
17--- a/cmake/CMakeHelpers.cmake
18+++ b/cmake/CMakeHelpers.cmake
19@@ -80,7 +80,7 @@ macro (final_target)
20 endif ()
21
22 install (DIRECTORY ${CMAKE_SOURCE_DIR}/${TARGET_NAME}
23- DESTINATION include/
24+ DESTINATION ${INSTALL_INCLUDE_DIR}/
25 FILES_MATCHING PATTERN "*.hpp*")
26 endmacro ()
27
28--
292.17.1
30
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch
new file mode 100644
index 000000000..a1ee627b3
--- /dev/null
+++ b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch
@@ -0,0 +1,23 @@
1From 3590d77bb9753fbbf076028e2395182ced6466ba Mon Sep 17 00:00:00 2001
2From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
3Date: Wed, 8 Jan 2020 17:59:48 +0100
4Subject: [PATCH] Fix cmake find boost with version >= 1.71
5
6For some reasons "system;thread;random;unit_test_framework" was seen as a single module, because of the quotes.
7---
8 CMakeLists.txt | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/CMakeLists.txt b/CMakeLists.txt
12index 2d13117b..9a46bc10 100644
13--- a/CMakeLists.txt
14+++ b/CMakeLists.txt
15@@ -213,7 +213,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
16 set (Boost_USE_MULTITHREADED TRUE)
17 set (Boost_ADDITIONAL_VERSIONS "1.39.0" "1.40.0" "1.41.0" "1.42.0" "1.43.0" "1.44.0" "1.46.1") # todo: someone who knows better spesify these!
18
19- find_package (Boost 1.39.0 COMPONENTS "${WEBSOCKETPP_BOOST_LIBS}")
20+ find_package (Boost 1.39.0 COMPONENTS ${WEBSOCKETPP_BOOST_LIBS})
21
22 if (Boost_FOUND)
23 # Boost is a project wide global dependency.
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/857.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/857.patch
new file mode 100644
index 000000000..f221cd699
--- /dev/null
+++ b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/857.patch
@@ -0,0 +1,132 @@
1From 931a55347a322f38eb82d5f387b2924e6c7a1746 Mon Sep 17 00:00:00 2001
2From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
3Date: Thu, 9 Jan 2020 10:07:20 +0100
4Subject: [PATCH] Update SConstruct with new Python3 syntax: - new raise
5 keyword syntax - has_key deprecated method is now removed - commands
6 deprecated library is replaced by subprocess - print function fixes
7
8This should fix FTBFS against new scons 3.1.2
9https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=947584
10---
11 SConstruct | 45 +++++++++++++++++++++++----------------------
12 1 file changed, 23 insertions(+), 22 deletions(-)
13
14diff --git a/SConstruct b/SConstruct
15index ae3df10b..9d1c8914 100644
16--- a/SConstruct
17+++ b/SConstruct
18@@ -1,18 +1,19 @@
19-import os, sys, commands
20+import os, sys
21+from subprocess import check_output
22 env = Environment(ENV = os.environ)
23
24 # figure out a better way to configure this
25-if os.environ.has_key('CXX'):
26+if 'CXX' in os.environ:
27 env['CXX'] = os.environ['CXX']
28
29-if os.environ.has_key('DEBUG'):
30+if 'DEBUG' in os.environ:
31 env['DEBUG'] = os.environ['DEBUG']
32
33-if os.environ.has_key('CXXFLAGS'):
34+if 'CXXFLAGS' in os.environ:
35 #env['CXXFLAGS'] = os.environ['CXXFLAGS']
36 env.Append(CXXFLAGS = os.environ['CXXFLAGS'])
37
38-if os.environ.has_key('LINKFLAGS'):
39+if 'LINKFLAGS' in os.environ:
40 #env['LDFLAGS'] = os.environ['LDFLAGS']
41 env.Append(LINKFLAGS = os.environ['LINKFLAGS'])
42
43@@ -22,24 +23,24 @@ if os.environ.has_key('LINKFLAGS'):
44 ## or set BOOST_INCLUDES and BOOST_LIBS if Boost comes with your OS distro e.g. and
45 ## needs BOOST_INCLUDES=/usr/include/boost and BOOST_LIBS=/usr/lib like Ubuntu.
46 ##
47-if os.environ.has_key('BOOSTROOT'):
48+if 'BOOSTROOT' in os.environ:
49 os.environ['BOOST_ROOT'] = os.environ['BOOSTROOT']
50
51-if os.environ.has_key('BOOST_ROOT'):
52+if 'BOOST_ROOT' in os.environ:
53 env['BOOST_INCLUDES'] = os.environ['BOOST_ROOT']
54 env['BOOST_LIBS'] = os.path.join(os.environ['BOOST_ROOT'], 'stage', 'lib')
55-elif os.environ.has_key('BOOST_INCLUDES') and os.environ.has_key('BOOST_LIBS'):
56+elif 'BOOST_INCLUDES' in os.environ and 'BOOST_LIBS' in os.environ:
57 env['BOOST_INCLUDES'] = os.environ['BOOST_INCLUDES']
58 env['BOOST_LIBS'] = os.environ['BOOST_LIBS']
59 else:
60- raise SCons.Errors.UserError, "Neither BOOST_ROOT, nor BOOST_INCLUDES + BOOST_LIBS was set!"
61+ raise SCons.Errors.UserError("Neither BOOST_ROOT, nor BOOST_INCLUDES + BOOST_LIBS were set!")
62
63 ## Custom OpenSSL
64-if os.environ.has_key('OPENSSL_PATH'):
65+if 'OPENSSL_PATH' in os.environ:
66 env.Append(CPPPATH = os.path.join(os.environ['OPENSSL_PATH'], 'include'))
67 env.Append(LIBPATH = os.environ['OPENSSL_PATH'])
68
69-if os.environ.has_key('WSPP_ENABLE_CPP11'):
70+if 'WSPP_ENABLE_CPP11' in os.environ:
71 env['WSPP_ENABLE_CPP11'] = True
72 else:
73 env['WSPP_ENABLE_CPP11'] = False
74@@ -76,7 +77,7 @@ if env['PLATFORM'].startswith('win'):
75 env['CCFLAGS'] = '%s /EHsc /GR /GS- /MD /nologo %s %s' % (warn_flags, arch_flags, opt_flags)
76 env['LINKFLAGS'] = '/INCREMENTAL:NO /MANIFEST /NOLOGO /OPT:REF /OPT:ICF /MACHINE:X86'
77 elif env['PLATFORM'] == 'posix':
78- if env.has_key('DEBUG'):
79+ if 'DEBUG' in env:
80 env.Append(CCFLAGS = ['-g', '-O0'])
81 else:
82 env.Append(CPPDEFINES = ['NDEBUG'])
83@@ -84,9 +85,9 @@ elif env['PLATFORM'] == 'posix':
84 env.Append(CCFLAGS = ['-Wall'])
85 #env['LINKFLAGS'] = ''
86 elif env['PLATFORM'] == 'darwin':
87- if not os.environ.has_key('CXX'):
88+ if not 'CXX' in os.environ:
89 env['CXX'] = "clang++"
90- if env.has_key('DEBUG'):
91+ if 'DEBUG' in env:
92 env.Append(CCFLAGS = ['-g', '-O0'])
93 else:
94 env.Append(CPPDEFINES = ['NDEBUG'])
95@@ -157,29 +158,29 @@ env_cpp11 = env.Clone ()
96
97 if env_cpp11['CXX'].startswith('g++'):
98 # TODO: check g++ version
99- GCC_VERSION = commands.getoutput(env_cpp11['CXX'] + ' -dumpversion')
100+ GCC_VERSION = check_output([env_cpp11['CXX'], '-dumpversion'])
101
102- if GCC_VERSION > "4.4.0":
103- print "C++11 build environment partially enabled"
104+ if GCC_VERSION.decode('utf-8') > "4.4.0":
105+ print("C++11 build environment partially enabled")
106 env_cpp11.Append(WSPP_CPP11_ENABLED = "true",CXXFLAGS = ['-std=c++0x'],TOOLSET = ['g++'],CPPDEFINES = ['_WEBSOCKETPP_CPP11_STL_'])
107 else:
108- print "C++11 build environment is not supported on this version of G++"
109+ print("C++11 build environment is not supported on this version of G++")
110 elif env_cpp11['CXX'].startswith('clang++'):
111- print "C++11 build environment enabled"
112+ print("C++11 build environment enabled")
113 env.Append(CXXFLANGS = ['-stdlib=libc++'],LINKFLAGS=['-stdlib=libc++'])
114 env_cpp11.Append(WSPP_CPP11_ENABLED = "true",CXXFLAGS = ['-std=c++0x','-stdlib=libc++'],LINKFLAGS = ['-stdlib=libc++'],TOOLSET = ['clang++'],CPPDEFINES = ['_WEBSOCKETPP_CPP11_STL_'])
115
116 # look for optional second boostroot compiled with clang's libc++ STL library
117 # this prevents warnings/errors when linking code built with two different
118 # incompatible STL libraries.
119- if os.environ.has_key('BOOST_ROOT_CPP11'):
120+ if 'BOOST_ROOT_CPP11' in os.environ:
121 env_cpp11['BOOST_INCLUDES'] = os.environ['BOOST_ROOT_CPP11']
122 env_cpp11['BOOST_LIBS'] = os.path.join(os.environ['BOOST_ROOT_CPP11'], 'stage', 'lib')
123- elif os.environ.has_key('BOOST_INCLUDES_CPP11') and os.environ.has_key('BOOST_LIBS_CPP11'):
124+ elif 'BOOST_INCLUDES_CPP11' in os.environ and 'BOOST_LIBS_CPP11' in os.environ:
125 env_cpp11['BOOST_INCLUDES'] = os.environ['BOOST_INCLUDES_CPP11']
126 env_cpp11['BOOST_LIBS'] = os.environ['BOOST_LIBS_CPP11']
127 else:
128- print "C++11 build environment disabled"
129+ print("C++11 build environment disabled")
130
131 # if the build system is known to allow the isystem modifier for library include
132 # values then use it for the boost libraries. Otherwise just add them to the
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb b/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
index 05f14d2f4..8a2a3e1b8 100644
--- a/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
+++ b/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
@@ -3,14 +3,27 @@ SECTION = "libs/network"
3HOMEPAGE = "https://github.com/zaphoyd/websocketpp" 3HOMEPAGE = "https://github.com/zaphoyd/websocketpp"
4LICENSE = "BSD-3-Clause" 4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=4d168d763c111f4ffc62249870e4e0ea" 5LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=4d168d763c111f4ffc62249870e4e0ea"
6DEPENDS = "openssl boost zlib" 6
7DEPENDS = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'openssl boost zlib', '', d)} "
7 8
8SRC_URI = "git://github.com/zaphoyd/websocketpp.git;protocol=https \ 9SRC_URI = "git://github.com/zaphoyd/websocketpp.git;protocol=https \
9 file://0001-Replace-make_shared-with-new-in-some-cases.patch \ 10 file://0001-Replace-make_shared-with-new-in-some-cases.patch \
10 file://0002-Fix-missed-entries-fix-testing.patch \ 11 file://0002-Fix-missed-entries-fix-testing.patch \
11 file://0001-cmake-Use-GNUInstallDirs.patch \ 12 file://0001-cmake-Use-GNUInstallDirs.patch \
13 file://842.patch \
14 file://771.patch \
15 file://855.patch \
16 file://857.patch \
12 " 17 "
13 18
19EXTRA_OECMAKE = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '-DBUILD_EXAMPLES=ON -DBUILD_TESTS=ON', '', d)} "
20
21# this is an header only library, do not depend on the main package
22RDEPENDS_${PN}-dev = ""
23
24# to add this package to an SDK, since it isn't a reverse-dependency of anything, just use something like this:
25# TOOLCHAIN_TARGET_TASK_append = " websocketpp-dev"
26
14# tag 0.8.1 27# tag 0.8.1
15SRCREV= "c6d7e295bf5a0ab9b5f896720cc1a0e0fdc397a7" 28SRCREV= "c6d7e295bf5a0ab9b5f896720cc1a0e0fdc397a7"
16 29