summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-10 22:01:28 -0800
committerArmin Kuster <akuster808@gmail.com>2020-01-19 09:04:08 -0800
commitc5cf476e8ab0378253675af5d4b6d39083786de0 (patch)
tree3c8e02e5d04b5424bae603e9f80277bca02c5c19
parenteb8090f27afb865878a04aaeff6caac34abdbac0 (diff)
downloadmeta-openembedded-c5cf476e8ab0378253675af5d4b6d39083786de0.tar.gz
websocketpp: Fix clang specific flags in cmake files
Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit f7030891ef062eeb0e9ca01d4a6191b309e6a307) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch32
-rw-r--r--meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch
new file mode 100644
index 000000000..421789728
--- /dev/null
+++ b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch
@@ -0,0 +1,32 @@
1From 5ccaff351297bca0e254bbfd66e3f03fef9d9c75 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 10 Jan 2020 21:54:39 -0800
4Subject: [PATCH] Correct clang compiler flags
5
6Fix misplaced quotes, this was leading to spurious ; in compiler cmdline
7Remove demanding libc++, clang can link with both libc++ and libstdc++
8and platforms have their own defaults, user can demand non defaults via
9adding it to cmake flags
10
11Upstream-Status: Submitted [https://github.com/zaphoyd/websocketpp/pull/859]
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 CMakeLists.txt | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/CMakeLists.txt b/CMakeLists.txt
18index 2d13117..c17354a 100644
19--- a/CMakeLists.txt
20+++ b/CMakeLists.txt
21@@ -148,7 +148,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
22 endif()
23 set (WEBSOCKETPP_PLATFORM_TLS_LIBS ssl crypto)
24 set (WEBSOCKETPP_BOOST_LIBS system thread)
25- set (CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS} "-std=c++0x -stdlib=libc++") # todo: is libc++ really needed here?
26+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
27 if (NOT APPLE)
28 add_definitions (-DNDEBUG -Wall -Wno-padded) # todo: should we use CMAKE_C_FLAGS for these?
29 endif ()
30--
312.24.1
32
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb b/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
index 8a2a3e1b8..97c1df2d5 100644
--- a/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
+++ b/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
@@ -14,6 +14,7 @@ SRC_URI = "git://github.com/zaphoyd/websocketpp.git;protocol=https \
14 file://771.patch \ 14 file://771.patch \
15 file://855.patch \ 15 file://855.patch \
16 file://857.patch \ 16 file://857.patch \
17 file://0001-Correct-clang-compiler-flags.patch \
17 " 18 "
18 19
19EXTRA_OECMAKE = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '-DBUILD_EXAMPLES=ON -DBUILD_TESTS=ON', '', d)} " 20EXTRA_OECMAKE = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '-DBUILD_EXAMPLES=ON -DBUILD_TESTS=ON', '', d)} "