summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-21 13:50:44 -0800
committerArmin Kuster <akuster808@gmail.com>2020-03-15 13:30:34 -0700
commit9e60d30669a2ad0598e9abf0cd15ee06b523986b (patch)
tree4893fd462f5c237c8a778abc8d1121f47d1221bd
parent60d819329833d5efaabf131bf4b15c2f1316b484 (diff)
downloadmeta-openembedded-9e60d30669a2ad0598e9abf0cd15ee06b523986b.tar.gz
sanlock: Replace cp -a with cp -R --no-dereference
helps to stop leaking builder's UID into sstate cache Fixes Exception: KeyError: 'getpwuid(): uid not found: 6000' Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 80d4d7538a85123603eea3d87542c1c0433febb7) [ak: fixes build issue Exception: KeyError: 'getpwuid(): uid not found: 1000'] Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/sanlock/sanlock/0001-sanlock-Replace-cp-a-with-cp-R-no-dereference-preser.patch51
-rw-r--r--meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb4
2 files changed, 54 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/sanlock/sanlock/0001-sanlock-Replace-cp-a-with-cp-R-no-dereference-preser.patch b/meta-oe/recipes-extended/sanlock/sanlock/0001-sanlock-Replace-cp-a-with-cp-R-no-dereference-preser.patch
new file mode 100644
index 000000000..a0b721c46
--- /dev/null
+++ b/meta-oe/recipes-extended/sanlock/sanlock/0001-sanlock-Replace-cp-a-with-cp-R-no-dereference-preser.patch
@@ -0,0 +1,51 @@
1From 78a9cffb1c760466933bbbcbae7ecb9b30a3e6a5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 21 Nov 2019 13:47:42 -0800
4Subject: [PATCH] sanlock: Replace "cp -a" with "cp -R --no-dereference
5 --preserve=mode, links"
6
7Using "cp -a" leaks UID of user running the builds
8
9Upstream-Status: Pending
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/Makefile | 8 ++++----
14 wdmd/Makefile | 4 ++--
15 2 files changed, 6 insertions(+), 6 deletions(-)
16
17diff --git a/src/Makefile b/src/Makefile
18index 533dd79..2fc9ba5 100644
19--- a/src/Makefile
20+++ b/src/Makefile
21@@ -127,9 +127,9 @@ install: all
22 $(INSTALL) -c -m 755 $(LIBSO_CLIENT_TARGET) $(DESTDIR)/$(LIBDIR)
23 $(INSTALL) -c -m 644 $(LIBPC_ENTIRE_TARGET) $(DESTDIR)/$(LIBDIR)/pkgconfig
24 $(INSTALL) -c -m 644 $(LIBPC_CLIENT_TARGET) $(DESTDIR)/$(LIBDIR)/pkgconfig
25- cp -a $(LIB_ENTIRE_TARGET).so $(DESTDIR)/$(LIBDIR)
26- cp -a $(LIB_CLIENT_TARGET).so $(DESTDIR)/$(LIBDIR)
27- cp -a $(LIB_ENTIRE_TARGET).so.$(SOMAJOR) $(DESTDIR)/$(LIBDIR)
28- cp -a $(LIB_CLIENT_TARGET).so.$(SOMAJOR) $(DESTDIR)/$(LIBDIR)
29+ cp -R --no-dereference --preserve=mode,links $(LIB_ENTIRE_TARGET).so $(DESTDIR)/$(LIBDIR)
30+ cp -R --no-dereference --preserve=mode,links $(LIB_CLIENT_TARGET).so $(DESTDIR)/$(LIBDIR)
31+ cp -R --no-dereference --preserve=mode,links $(LIB_ENTIRE_TARGET).so.$(SOMAJOR) $(DESTDIR)/$(LIBDIR)
32+ cp -R --no-dereference --preserve=mode,links $(LIB_CLIENT_TARGET).so.$(SOMAJOR) $(DESTDIR)/$(LIBDIR)
33 $(INSTALL) -c -m 644 $(HEADER_TARGET) $(DESTDIR)/$(HEADIR)
34 $(INSTALL) -m 644 $(MAN_TARGET) $(DESTDIR)/$(MANDIR)/man8/
35diff --git a/wdmd/Makefile b/wdmd/Makefile
36index 5849efc..4894517 100644
37--- a/wdmd/Makefile
38+++ b/wdmd/Makefile
39@@ -68,7 +68,7 @@ install: all
40 $(INSTALL) -d $(DESTDIR)/$(MANDIR)/man8
41 $(INSTALL) -c -m 755 $(CMD_TARGET) $(DESTDIR)/$(BINDIR)
42 $(INSTALL) -c -m 755 $(SHLIB_TARGET) $(DESTDIR)/$(LIBDIR)
43- cp -a $(LIB_TARGET).so $(DESTDIR)/$(LIBDIR)
44- cp -a $(LIB_TARGET).so.$(SOMAJOR) $(DESTDIR)/$(LIBDIR)
45+ cp -R --no-dereference --preserve=mode,links $(LIB_TARGET).so $(DESTDIR)/$(LIBDIR)
46+ cp -R --no-dereference --preserve=mode,links $(LIB_TARGET).so.$(SOMAJOR) $(DESTDIR)/$(LIBDIR)
47 $(INSTALL) -c -m 644 $(HEADER_TARGET) $(DESTDIR)/$(HEADIR)
48 $(INSTALL) -m 644 $(MAN_TARGET) $(DESTDIR)/$(MANDIR)/man8
49--
502.24.0
51
diff --git a/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb b/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
index 9f7ce9c57..850690fe9 100644
--- a/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
+++ b/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
@@ -11,7 +11,9 @@ SECTION = "utils"
11LICENSE = "LGPLv2+ & GPLv2 & GPLv2+" 11LICENSE = "LGPLv2+ & GPLv2 & GPLv2+"
12LIC_FILES_CHKSUM = "file://README.license;md5=60487bf0bf429d6b5aa72b6d37a0eb22" 12LIC_FILES_CHKSUM = "file://README.license;md5=60487bf0bf429d6b5aa72b6d37a0eb22"
13 13
14SRC_URI = "git://pagure.io/sanlock.git;protocol=http" 14SRC_URI = "git://pagure.io/sanlock.git;protocol=http \
15 file://0001-sanlock-Replace-cp-a-with-cp-R-no-dereference-preser.patch \
16 "
15SRCREV = "7afe0e66f5c7f24894896fad20ffa6f39733d80f" 17SRCREV = "7afe0e66f5c7f24894896fad20ffa6f39733d80f"
16S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
17 19