diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2017-04-24 04:38:17 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-26 20:13:33 +0200 |
commit | 8dec4d3f93fead21beea2a817068a006ea955571 (patch) | |
tree | 3c73e27c08f272ed90541b4095e5f21f92c80e22 | |
parent | 47a9500b47f062be9d1b625b6090b1642e324007 (diff) | |
download | meta-openembedded-8dec4d3f93fead21beea2a817068a006ea955571.tar.gz |
ntfs-3g-ntfsprogs: fix install failed while host dir not exist
While cross compiling, if the dir of "$(rootlibdir)" and "$(libdir)"
(such as "/usr/lib64") do not exist on host system, the do_instal failed.
-----------------------
make[3]: Entering directory `tmp/work/core2-64-wrs-linux/ntfs-3g-ntfsprogs/2017.3.23-r0/build/libntfs-3g'
if [ ! "/usr/lib64" -ef "/usr/lib64" ]; then \
mv -f "tmp/work/core2-64-wrs-linux/ntfs-3g-ntfsprogs/2017.3.23-r0/image//usr/lib64"/libntfs-3g.so* \
"tmp/work/core2-64-wrs-linux/ntfs-3g-ntfsprogs/2017.3.23-r0/image//usr/lib64"; \
fi
mv:...are the same file
-----------------------
Use `=' rather than `-ef' to compare them, the cross compile does not
care about host dir.
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
2 files changed, 55 insertions, 1 deletions
diff --git a/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/files/0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch b/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/files/0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch new file mode 100644 index 000000000..7b8eec7cb --- /dev/null +++ b/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/files/0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch | |||
@@ -0,0 +1,52 @@ | |||
1 | From 575591caf1e8972f765885679b76787ef92de77b Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Mon, 24 Apr 2017 04:24:10 -0400 | ||
4 | Subject: [PATCH] libntfs-3g/Makefile.am: fix install failed while host dir not exist | ||
5 | |||
6 | While cross compiling, if the dir of "$(rootlibdir)" and "$(libdir)" | ||
7 | (such as "/usr/lib64") do not exist on host system, the do_instal failed. | ||
8 | ----------------------- | ||
9 | make[3]: Entering directory `tmp/work/core2-64-wrs-linux/ntfs-3g-ntfsprogs/2017.3.23-r0/build/libntfs-3g' | ||
10 | if [ ! "/usr/lib64" -ef "/usr/lib64" ]; then \ | ||
11 | mv -f "tmp/work/core2-64-wrs-linux/ntfs-3g-ntfsprogs/2017.3.23-r0/image//usr/lib64"/libntfs-3g.so* \ | ||
12 | "tmp/work/core2-64-wrs-linux/ntfs-3g-ntfsprogs/2017.3.23-r0/image//usr/lib64"; \ | ||
13 | fi | ||
14 | mv:...are the same file | ||
15 | ----------------------- | ||
16 | |||
17 | Use `=' rather than `-ef' to compare them, the cross compile does not | ||
18 | care about host dir. | ||
19 | |||
20 | Upstream-Status: Pending | ||
21 | |||
22 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
23 | --- | ||
24 | libntfs-3g/Makefile.am | 6 +++--- | ||
25 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
26 | |||
27 | diff --git a/libntfs-3g/Makefile.am b/libntfs-3g/Makefile.am | ||
28 | index d6b150e..806109d 100644 | ||
29 | --- a/libntfs-3g/Makefile.am | ||
30 | +++ b/libntfs-3g/Makefile.am | ||
31 | @@ -59,15 +59,15 @@ endif | ||
32 | # And create ldscript or symbolic link from /usr | ||
33 | install-exec-hook: install-rootlibLTLIBRARIES | ||
34 | if INSTALL_LIBRARY | ||
35 | - if [ ! "$(rootlibdir)" -ef "$(libdir)" ]; then \ | ||
36 | + if [ "$(rootlibdir)" != "$(libdir)" ]; then \ | ||
37 | $(MV) -f "$(DESTDIR)/$(libdir)"/libntfs-3g.so* "$(DESTDIR)/$(rootlibdir)"; \ | ||
38 | fi | ||
39 | if GENERATE_LDSCRIPT | ||
40 | - if [ ! "$(rootlibdir)" -ef "$(libdir)" ]; then \ | ||
41 | + if [ "$(rootlibdir)" != "$(libdir)" ]; then \ | ||
42 | $(install_sh_PROGRAM) "libntfs-3g.script.so" "$(DESTDIR)/$(libdir)/libntfs-3g.so"; \ | ||
43 | fi | ||
44 | else | ||
45 | - if [ ! "$(rootlibdir)" -ef "$(libdir)" ]; then \ | ||
46 | + if [ "$(rootlibdir)" != "$(libdir)" ]; then \ | ||
47 | $(LN_S) "$(rootlibdir)/libntfs-3g.so" "$(DESTDIR)/$(libdir)/libntfs-3g.so"; \ | ||
48 | fi | ||
49 | endif | ||
50 | -- | ||
51 | 2.8.1 | ||
52 | |||
diff --git a/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb b/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb index 63627deda..9e77766e6 100644 --- a/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb +++ b/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb | |||
@@ -6,7 +6,9 @@ LICENSE = "GPLv2 & LGPLv2" | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ |
7 | file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a" | 7 | file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a" |
8 | 8 | ||
9 | SRC_URI = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${PV}.tgz" | 9 | SRC_URI = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${PV}.tgz \ |
10 | file://0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch \ | ||
11 | " | ||
10 | S = "${WORKDIR}/ntfs-3g_ntfsprogs-${PV}" | 12 | S = "${WORKDIR}/ntfs-3g_ntfsprogs-${PV}" |
11 | SRC_URI[md5sum] = "d97474ae1954f772c6d2fa386a6f462c" | 13 | SRC_URI[md5sum] = "d97474ae1954f772c6d2fa386a6f462c" |
12 | SRC_URI[sha256sum] = "3e5a021d7b761261836dcb305370af299793eedbded731df3d6943802e1262d5" | 14 | SRC_URI[sha256sum] = "3e5a021d7b761261836dcb305370af299793eedbded731df3d6943802e1262d5" |