summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-03-05 08:20:05 +0800
committerArmin Kuster <akuster808@gmail.com>2020-03-15 13:30:34 -0700
commit7932e835f1fb218a28a7f32ddc2edff630614830 (patch)
tree131088c59ea4369e48a342a43fb54477c2ade7f6
parent94cc8b862ac4df7c7f66933dea42846c80f707df (diff)
downloadmeta-openembedded-7932e835f1fb218a28a7f32ddc2edff630614830.tar.gz
ade: Fix install paths in multilib builds
Fixes ERROR: ade-0.1.1f-r0 do_package: QA Issue: ade: Files/directories were installed but not shipped in any package: /usr/lib /usr/lib/libade.a Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Sanjeev Nahulanthran <sanjeev.nahulanthran@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/opencv/ade/0001-use-GNUInstallDirs-for-detecting-install-paths.patch39
-rw-r--r--meta-oe/recipes-support/opencv/ade_0.1.1f.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/ade/0001-use-GNUInstallDirs-for-detecting-install-paths.patch b/meta-oe/recipes-support/opencv/ade/0001-use-GNUInstallDirs-for-detecting-install-paths.patch
new file mode 100644
index 000000000..f038b0aa9
--- /dev/null
+++ b/meta-oe/recipes-support/opencv/ade/0001-use-GNUInstallDirs-for-detecting-install-paths.patch
@@ -0,0 +1,39 @@
1From 67ccf77d97b76e8260c9d793ab172577e2393dbc Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 19 Dec 2019 21:33:46 -0800
4Subject: [PATCH] use GNUInstallDirs for detecting install paths
5
6This helps with multilib builds
7
8Upstream-Status: Submitted [https://github.com/opencv/ade/pull/19]
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 sources/ade/CMakeLists.txt | 10 ++++++----
12 1 file changed, 6 insertions(+), 4 deletions(-)
13
14diff --git a/sources/ade/CMakeLists.txt b/sources/ade/CMakeLists.txt
15index 2d1dd20..46415d1 100644
16--- a/sources/ade/CMakeLists.txt
17+++ b/sources/ade/CMakeLists.txt
18@@ -47,12 +47,14 @@ if(BUILD_ADE_DOCUMENTATION)
19 VERBATIM)
20 endif()
21
22+include(GNUInstallDirs)
23+
24 install(TARGETS ade COMPONENT dev
25 EXPORT adeTargets
26- ARCHIVE DESTINATION lib
27- LIBRARY DESTINATION lib
28- RUNTIME DESTINATION lib
29- INCLUDES DESTINATION include)
30+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
31+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
32+ RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}
33+ INCLUDES DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
34
35 install(EXPORT adeTargets DESTINATION share/ade COMPONENT dev)
36
37--
382.24.1
39
diff --git a/meta-oe/recipes-support/opencv/ade_0.1.1f.bb b/meta-oe/recipes-support/opencv/ade_0.1.1f.bb
index 332820d14..386180215 100644
--- a/meta-oe/recipes-support/opencv/ade_0.1.1f.bb
+++ b/meta-oe/recipes-support/opencv/ade_0.1.1f.bb
@@ -5,6 +5,7 @@ organizing data flow processing and execution."
5HOMEPAGE = "https://github.com/opencv/ade" 5HOMEPAGE = "https://github.com/opencv/ade"
6 6
7SRC_URI = "git://github.com/opencv/ade.git \ 7SRC_URI = "git://github.com/opencv/ade.git \
8 file://0001-use-GNUInstallDirs-for-detecting-install-paths.patch \
8 " 9 "
9 10
10SRCREV = "58b2595a1a95cc807be8bf6222f266a9a1f393a9" 11SRCREV = "58b2595a1a95cc807be8bf6222f266a9a1f393a9"