summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-28 13:48:33 -0800
committerArmin Kuster <akuster808@gmail.com>2020-01-30 18:34:36 -0800
commit40d92260341d9c46d33f6e149298138759b0c14b (patch)
treec92c93b9b76574ca9f9f82b371a38e3e33661968
parenta82494272d3cd477648c630a84f0005b4f9d1018 (diff)
downloadmeta-openembedded-40d92260341d9c46d33f6e149298138759b0c14b.tar.gz
grpc: Link with libatomic on riscv
Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit e82f1802a60d451f978cdef0f2ff69feb1f12039) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-devtools/grpc/grpc_1.24.1.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-networking/recipes-devtools/grpc/grpc_1.24.1.bb b/meta-networking/recipes-devtools/grpc/grpc_1.24.1.bb
index 34b4e317b..0b5e5c336 100644
--- a/meta-networking/recipes-devtools/grpc/grpc_1.24.1.bb
+++ b/meta-networking/recipes-devtools/grpc/grpc_1.24.1.bb
@@ -48,6 +48,14 @@ do_configure_prepend_powerpc() {
48 sed -i -e "s/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} rt m pthread)/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} atomic rt m pthread)/g" ${S}/CMakeLists.txt 48 sed -i -e "s/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} rt m pthread)/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} atomic rt m pthread)/g" ${S}/CMakeLists.txt
49} 49}
50 50
51do_configure_prepend_riscv64() {
52 sed -i -e "s/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} rt m pthread)/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} atomic rt m pthread)/g" ${S}/CMakeLists.txt
53}
54
55do_configure_prepend_riscv32() {
56 sed -i -e "s/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} rt m pthread)/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} atomic rt m pthread)/g" ${S}/CMakeLists.txt
57}
58
51do_configure_prepend_toolchain-clang_x86() { 59do_configure_prepend_toolchain-clang_x86() {
52 sed -i -e "s/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} rt m pthread)/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} atomic rt m pthread)/g" ${S}/CMakeLists.txt 60 sed -i -e "s/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} rt m pthread)/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} atomic rt m pthread)/g" ${S}/CMakeLists.txt
53} 61}