summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-17 18:48:08 -0800
committerArmin Kuster <akuster808@gmail.com>2020-01-05 14:43:51 -0800
commit22bec3b2606347b895adde3c154280a87e1f3f87 (patch)
treebc4a0759b8e216d9f6239692403eec2f7b11938d
parentc61c89918e3774926fd0e56fb40262e4cca0a7be (diff)
downloadmeta-openembedded-22bec3b2606347b895adde3c154280a87e1f3f87.tar.gz
tinyalsa: fix installation libdir path to match multilibs
Fixes ERROR: tinyalsa-1.1.1+gitAUTOINC+8449529c7e-r0 do_package: QA Issue: tinyalsa: Files/directories were installed but not shipped in any package: /usr/lib /usr/lib/libtinyalsa.a Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Andreas Müller <schnitzeltony@googlemail.com> Acked-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit d9f3e6dbed8e5d96f2069280f0a566af89afb2fa) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa.bb4
-rw-r--r--meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa/0001-Use-CMAKE_INSTALL_-path-instead-of-hardcoding-bin-li.patch46
2 files changed, 49 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa.bb b/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa.bb
index 8b86f8243..062096892 100644
--- a/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa.bb
+++ b/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa.bb
@@ -7,7 +7,9 @@ LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://NOTICE;md5=dbdefe400d894b510a9de14813181d0b" 7LIC_FILES_CHKSUM = "file://NOTICE;md5=dbdefe400d894b510a9de14813181d0b"
8 8
9SRCREV = "8449529c7e50f432091539ba7b438e79b04059b5" 9SRCREV = "8449529c7e50f432091539ba7b438e79b04059b5"
10SRC_URI = "git://github.com/tinyalsa/tinyalsa" 10SRC_URI = "git://github.com/tinyalsa/tinyalsa \
11 file://0001-Use-CMAKE_INSTALL_-path-instead-of-hardcoding-bin-li.patch \
12 "
11PV = "1.1.1+git${SRCPV}" 13PV = "1.1.1+git${SRCPV}"
12 14
13S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
diff --git a/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa/0001-Use-CMAKE_INSTALL_-path-instead-of-hardcoding-bin-li.patch b/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa/0001-Use-CMAKE_INSTALL_-path-instead-of-hardcoding-bin-li.patch
new file mode 100644
index 000000000..6f9c39996
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa/0001-Use-CMAKE_INSTALL_-path-instead-of-hardcoding-bin-li.patch
@@ -0,0 +1,46 @@
1From fe4f3c2a37a81201f463ff962364f014f50c9896 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 16 Dec 2019 22:58:41 -0800
4Subject: [PATCH] Use CMAKE_INSTALL_<path> instead of hardcoding bin/lib/
5 install paths
6
7Helps fix build/packaging issues on machines where default libdir is not
8lib but say lib64
9
10Upstream-Status: Submitted [https://github.com/tinyalsa/tinyalsa/pull/143]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 CMakeLists.txt | 14 +++++++++++---
14 1 file changed, 11 insertions(+), 3 deletions(-)
15
16diff --git a/CMakeLists.txt b/CMakeLists.txt
17index cb31c58..1cc4a85 100644
18--- a/CMakeLists.txt
19+++ b/CMakeLists.txt
20@@ -41,12 +41,20 @@ add_util("tinymix" "utils/tinymix.c")
21 install(FILES ${HDRS}
22 DESTINATION "include/tinyalsa")
23
24+if(NOT DEFINED CMAKE_INSTALL_LIBDIR)
25+ set(CMAKE_INSTALL_LIBDIR lib)
26+endif()
27+
28+if(NOT DEFINED CMAKE_INSTALL_BINDIR)
29+ set(CMAKE_INSTALL_BINDIR bin)
30+endif()
31+
32 install(TARGETS "tinyalsa"
33 "tinyplay"
34 "tinycap"
35 "tinymix"
36 "tinypcminfo"
37- RUNTIME DESTINATION "bin"
38- ARCHIVE DESTINATION "lib"
39- LIBRARY DESTINATION "lib")
40+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
41+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
42+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
43
44--
452.24.1
46