summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-08-25 11:54:04 +0300
committerKhem Raj <raj.khem@gmail.com>2023-08-26 17:32:45 -0700
commit90fbe305c538b1368cd655e5e5687e794b37a859 (patch)
tree90c8d972c272148f9b238ad8c0a3352f60b63374
parent8ff8621c4af2995b1f4033a14a117460ea663b70 (diff)
downloadmeta-openembedded-90fbe305c538b1368cd655e5e5687e794b37a859.tar.gz
aml: add new recipe
Add a new recipe for aml (Andri's Main Loop) v0.3.0. It is required for neatvnc which is required for building Weston with VNC backend. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/aml/aml_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/aml/aml_git.bb b/meta-oe/recipes-graphics/aml/aml_git.bb
new file mode 100644
index 000000000..eed62adae
--- /dev/null
+++ b/meta-oe/recipes-graphics/aml/aml_git.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Andri's Main Loop"
2DESCRIPTION = "Andri's Main Loop"
3HOMEPAGE = "https://github.com/any1/aml"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e6f3cfaa39204b96e14b68b9d50d3e4e"
6
7SRC_URI = "git://github.com/any1/aml;branch=master;protocol=https"
8
9SRCREV = "b83f3576ce4187d9285f06e9066ef43a691464d4"
10
11PV = "0.3.0+git${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG[examples] = "-Dexamples=true,-Dexamples=false"
17
18PACKAGE_BEFORE_PN += "${PN}-examples"
19ALLOW_EMPTY:${PN}-examples = "1"
20FILES:${PN}-examples = "${bindir}"
21
22inherit meson pkgconfig
23
24AML_EXAMPLES = "ticker nested-ticker reader"
25
26do_install:append () {
27 if ${@bb.utils.contains('PACKAGECONFIG', 'examples', 'true', 'false', d)}; then
28 install -d ${D}${bindir}
29 for bin in ${AML_EXAMPLES}; do
30 install -m 0755 ${B}/examples/$bin ${D}${bindir}
31 done
32 fi
33}
34
35BBCLASSEXTEND = "native"