summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilly Tu <wltu@google.com>2023-08-24 10:07:01 -0700
committerKhem Raj <raj.khem@gmail.com>2023-08-26 17:32:45 -0700
commit2703a7ca79bb238b3b8b29b4ae32a459907f6d62 (patch)
tree3cff220ca8f305e561057310a44476a031b2af3c
parentc17f9f2facb2d8b7f00c932f5e96168c505771f8 (diff)
downloadmeta-openembedded-2703a7ca79bb238b3b8b29b4ae32a459907f6d62.tar.gz
abseil-cpp: upgrade 20230125.3 -> 20230802.0
Release notes in https://github.com/abseil/abseil-cpp/releases/tag/20230802.0 Signed-off-by: Willy Tu <wltu@google.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-direct_mmap-Use-off_t-on-linux.patch42
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb7
2 files changed, 3 insertions, 46 deletions
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-direct_mmap-Use-off_t-on-linux.patch b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-direct_mmap-Use-off_t-on-linux.patch
deleted file mode 100644
index 49df528d7..000000000
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-direct_mmap-Use-off_t-on-linux.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From 45fdade6c0415ec5af3f9312e6311a4ccc682a7b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 28 Dec 2022 18:24:21 -0800
4Subject: [PATCH] direct_mmap: Use off_t on linux
5
6off64_t is not provided without defining _LARGEFILE64_SOURCE on musl
7this define is not defined automatically like glibc where it gets
8defined when _GNU_SOURCE is defined. Using off_t makes it portable
9across musl/glibc and for using 64bit off_t on glibc 32bit systems
10-D_FILE_OFFSET_BITS=64 can be defined during build via CXXFLAGS
11
12Upstream-Status: Submitted [https://github.com/abseil/abseil-cpp/pull/1349]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 absl/base/internal/direct_mmap.h | 4 ++--
16 1 file changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/absl/base/internal/direct_mmap.h b/absl/base/internal/direct_mmap.h
19index 815b8d23..fdf88f0b 100644
20--- a/absl/base/internal/direct_mmap.h
21+++ b/absl/base/internal/direct_mmap.h
22@@ -72,7 +72,7 @@ namespace base_internal {
23 // Platform specific logic extracted from
24 // https://chromium.googlesource.com/linux-syscall-support/+/master/linux_syscall_support.h
25 inline void* DirectMmap(void* start, size_t length, int prot, int flags, int fd,
26- off64_t offset) noexcept {
27+ off_t offset) noexcept {
28 #if defined(__i386__) || defined(__ARM_ARCH_3__) || defined(__ARM_EABI__) || \
29 defined(__m68k__) || defined(__sh__) || \
30 (defined(__hppa__) && !defined(__LP64__)) || \
31@@ -102,7 +102,7 @@ inline void* DirectMmap(void* start, size_t length, int prot, int flags, int fd,
32 #else
33 return reinterpret_cast<void*>(
34 syscall(SYS_mmap2, start, length, prot, flags, fd,
35- static_cast<off_t>(offset / pagesize)));
36+ offset / pagesize));
37 #endif
38 #elif defined(__s390x__)
39 // On s390x, mmap() arguments are passed in memory.
40--
412.39.0
42
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
index dd7ce4aee..f847ebf15 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
@@ -7,15 +7,14 @@ SECTION = "libs"
7LICENSE = "Apache-2.0" 7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915"
9 9
10PV = "20230125.3" 10PV = "20230802.0"
11SRCREV = "c2435f8342c2d0ed8101cb43adfd605fdc52dca2" 11SRCREV = "29bf8085f3bf17b84d30e34b3d7ff8248fda404e"
12BRANCH = "lts_2023_01_25" 12BRANCH = "lts_2023_08_02"
13SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \ 13SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \
14 file://0001-absl-always-use-asm-sgidefs.h.patch \ 14 file://0001-absl-always-use-asm-sgidefs.h.patch \
15 file://0002-Remove-maes-option-from-cross-compilation.patch \ 15 file://0002-Remove-maes-option-from-cross-compilation.patch \
16 file://abseil-ppc-fixes.patch \ 16 file://abseil-ppc-fixes.patch \
17 file://0003-Remove-neon-option-from-cross-compilation.patch \ 17 file://0003-Remove-neon-option-from-cross-compilation.patch \
18 file://0001-direct_mmap-Use-off_t-on-linux.patch \
19 " 18 "
20 19
21S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"