summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-06-11 16:54:54 +0000
committerArmin Kuster <akuster808@gmail.com>2019-06-16 08:13:43 -0700
commitf7a2d472b2d93da29febcd9588baf5f0aed774fb (patch)
tree8a3a15aea7b2ff865aebcf5c86755acf9fe6a964
parent6fa72d587aab8e9d56d67a2552eb9cfbe25c86d2 (diff)
downloadmeta-openembedded-f7a2d472b2d93da29febcd9588baf5f0aed774fb.tar.gz
gtkwave: add distro_features_check
* fixes: ERROR: Nothing PROVIDES 'gtk+' (but /OE/build/luneos-warrior/webos-ports/meta-openembedded/meta-oe/recipes-graphics/gtkwave/gtkwave_3.3.98.bb DEPENDS on or otherwise requires it) gtk+ was skipped: one of 'x11 directfb' needs to be in DISTRO_FEATURES ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'gtkwave', 'gtk+'] and ERROR: Nothing PROVIDES 'tk' (but /OE/build/luneos-warrior/webos-ports/meta-openembedded/meta-oe/recipes-graphics/gtkwave/gtkwave_3.3.98.bb DEPENDS on or otherwise requires it) tk was skipped: missing required distro feature 'x11' (not in DISTRO_FEATURES) ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'gtkwave', 'tk'] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/gtkwave/gtkwave_3.3.98.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/gtkwave/gtkwave_3.3.98.bb b/meta-oe/recipes-graphics/gtkwave/gtkwave_3.3.98.bb
index 60df6f773..b9aae0f6c 100644
--- a/meta-oe/recipes-graphics/gtkwave/gtkwave_3.3.98.bb
+++ b/meta-oe/recipes-graphics/gtkwave/gtkwave_3.3.98.bb
@@ -14,6 +14,10 @@ inherit pkgconfig autotools gettext texinfo
14DEPENDS = "tcl tk gperf-native bzip2 xz pango zlib gtk+ gdk-pixbuf glib-2.0" 14DEPENDS = "tcl tk gperf-native bzip2 xz pango zlib gtk+ gdk-pixbuf glib-2.0"
15RDEPENDS_${PN} = "tk-lib" 15RDEPENDS_${PN} = "tk-lib"
16 16
17# depends on gtk+ which has this restriction
18inherit distro_features_check
19ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
20
17EXTRA_OECONF = "--with-tcl=${STAGING_BINDIR_CROSS} --with-tk=${STAGING_BINDIR_CROSS}" 21EXTRA_OECONF = "--with-tcl=${STAGING_BINDIR_CROSS} --with-tk=${STAGING_BINDIR_CROSS}"
18 22
19FILES_${PN} = "${bindir} ${datadir}" 23FILES_${PN} = "${bindir} ${datadir}"