diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-12-22 22:37:33 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-12-23 13:29:20 -0800 |
commit | e1db44b73fe5b32f14940678db46668bdc609d55 (patch) | |
tree | 2e3e12fc80f637f36ead323a45fb52c45b3572cb | |
parent | de49264462a323f7ce60741cf77b89d5a66cca03 (diff) | |
download | meta-openembedded-e1db44b73fe5b32f14940678db46668bdc609d55.tar.gz |
mozjs: Remove -Werror=format from CXXFLAGS
This is to make way for gcc9 since it spews some extra warnings
which need to be eventually fixed
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-extended/mozjs/mozjs/format-overflow.patch | 21 | ||||
-rw-r--r-- | meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb | 1 |
2 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs/format-overflow.patch b/meta-oe/recipes-extended/mozjs/mozjs/format-overflow.patch new file mode 100644 index 000000000..29c6a7b69 --- /dev/null +++ b/meta-oe/recipes-extended/mozjs/mozjs/format-overflow.patch | |||
@@ -0,0 +1,21 @@ | |||
1 | Drop enable format string warnings to help gcc9 | ||
2 | |||
3 | Fixes | ||
4 | | /mnt/a/yoe/build/tmp/work/core2-64-yoe-linux-musl/mozjs/52.9.1-r0/mozjs-52.9.1/js/src/jit/x64/BaseAssembler-x64.h:596:13: error: '%s' directive argument is null [-Werror=format-overflow=] | ||
5 | | 596 | spew("movq " MEM_obs ", %s", ADDR_obs(offset, base, index, scale), GPReg64Name(dst)); | ||
6 | | | ~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
7 | |||
8 | Upstream-Status: Inappropriate [Workaround for gcc9] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | |||
11 | --- a/js/src/moz.build | ||
12 | +++ b/js/src/moz.build | ||
13 | @@ -785,7 +785,7 @@ if CONFIG['JS_HAS_CTYPES']: | ||
14 | DEFINES['FFI_BUILDING'] = True | ||
15 | |||
16 | if CONFIG['GNU_CXX']: | ||
17 | - CXXFLAGS += ['-Wno-shadow', '-Werror=format'] | ||
18 | + CXXFLAGS += ['-Wno-shadow'] | ||
19 | |||
20 | # Suppress warnings in third-party code. | ||
21 | if CONFIG['CLANG_CXX']: | ||
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb b/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb index 440a25b74..a28ecc57d 100644 --- a/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb +++ b/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb | |||
@@ -14,6 +14,7 @@ SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/main/m/mozjs52/mozjs52_52.9.1.o | |||
14 | file://disable-mozglue-in-stand-alone-builds.patch \ | 14 | file://disable-mozglue-in-stand-alone-builds.patch \ |
15 | file://add-riscv-support.patch \ | 15 | file://add-riscv-support.patch \ |
16 | file://0001-mozjs-fix-coredump-caused-by-getenv.patch \ | 16 | file://0001-mozjs-fix-coredump-caused-by-getenv.patch \ |
17 | file://format-overflow.patch \ | ||
17 | " | 18 | " |
18 | SRC_URI_append_libc-musl = " \ | 19 | SRC_URI_append_libc-musl = " \ |
19 | file://0006-support-musl.patch \ | 20 | file://0006-support-musl.patch \ |