diff options
author | Alejandro del Castillo <alejandro.delcastillo@ni.com> | 2018-08-27 15:33:36 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-27 17:26:46 -0700 |
commit | de3d90e865a4eb6753c10ea035f5f0fa073897ff (patch) | |
tree | 068d6c4e61a2d64048e227a81a0028ad0f2a7f07 | |
parent | 218c1e74b78068031c77df2c712a754d1e7ff160 (diff) | |
download | meta-openembedded-de3d90e865a4eb6753c10ea035f5f0fa073897ff.tar.gz |
python3-pyconnman: add recipe
Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com>
Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
3 files changed, 20 insertions, 10 deletions
diff --git a/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman.inc b/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman.inc new file mode 100644 index 000000000..beb2baf83 --- /dev/null +++ b/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman.inc | |||
@@ -0,0 +1,12 @@ | |||
1 | DESCRIPTION = "Python-based Network Connectivity Management" | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/pyconnman/" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
6 | |||
7 | SRC_URI[md5sum] = "b7fa82034b1c0e1fb1b518ffe3bb4fc0" | ||
8 | SRC_URI[sha256sum] = "46c64c0692063fd0c9fb0216d49f7884bec9fa9760d8473db4b1e2f8162fab4a" | ||
9 | |||
10 | inherit pypi | ||
11 | |||
12 | RDEPENDS_${PN} = "connman" | ||
diff --git a/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.1.0.bb b/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.1.0.bb index 77b5e4dcf..3c12db944 100644 --- a/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.1.0.bb +++ b/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.1.0.bb | |||
@@ -1,12 +1,5 @@ | |||
1 | DESCRIPTION = "Python-based Network Connectivity Management" | 1 | require python-pyconnman.inc |
2 | HOMEPAGE = "https://pypi.python.org/pypi/pyconnman/" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | 2 | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | 3 | inherit setuptools |
6 | 4 | ||
7 | SRC_URI[md5sum] = "b7fa82034b1c0e1fb1b518ffe3bb4fc0" | 5 | RDEPENDS_${PN} += "python-dbus python-pprint" |
8 | SRC_URI[sha256sum] = "46c64c0692063fd0c9fb0216d49f7884bec9fa9760d8473db4b1e2f8162fab4a" | ||
9 | |||
10 | inherit pypi setuptools | ||
11 | |||
12 | RDEPENDS_${PN} = "connman python-dbus python-pprint" | ||
diff --git a/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.1.0.bb b/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.1.0.bb new file mode 100644 index 000000000..e0f3fdd75 --- /dev/null +++ b/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.1.0.bb | |||
@@ -0,0 +1,5 @@ | |||
1 | require python-pyconnman.inc | ||
2 | |||
3 | inherit setuptools3 | ||
4 | |||
5 | RDEPENDS_${PN} += "python3-dbus python3-pprint" | ||