diff options
author | Andre McCurdy <armccurdy@gmail.com> | 2015-10-30 12:19:49 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-11-06 17:49:41 +0100 |
commit | d931801de77a9cbb13c916231583b3526a7d3e11 (patch) | |
tree | e77fb5e3f7112c859f693a7bef73f304ae52e8de | |
parent | b6a62aa38242a2bd0cebbe18219af36da5b0e6dd (diff) | |
download | meta-openembedded-d931801de77a9cbb13c916231583b3526a7d3e11.tar.gz |
ninja-native: add initial recipe, ninja 1.6.0
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/ninja/ninja-native_1.6.0.bb | 25 |
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/ninja/ninja-native_1.6.0.bb b/meta-oe/recipes-devtools/ninja/ninja-native_1.6.0.bb new file mode 100644 index 000000000..c00710afd --- /dev/null +++ b/meta-oe/recipes-devtools/ninja/ninja-native_1.6.0.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | SUMMARY = "Ninja is a small build system with a focus on speed." | ||
2 | HOMEPAGE = "http://martine.github.com/ninja/" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e" | ||
5 | |||
6 | DEPENDS = "re2c-native" | ||
7 | |||
8 | inherit native | ||
9 | |||
10 | SRCREV="484c16336f19bd8970bb6e75322d61b92a229899" | ||
11 | |||
12 | SRC_URI = "git://github.com/martine/ninja.git;branch=release" | ||
13 | |||
14 | S="${WORKDIR}/git" | ||
15 | |||
16 | do_configure[noexec] = "1" | ||
17 | |||
18 | do_compile() { | ||
19 | python ${S}/configure.py --bootstrap | ||
20 | } | ||
21 | |||
22 | do_install() { | ||
23 | install -d ${D}${bindir} | ||
24 | install -m 0755 ${S}/ninja ${D}${bindir}/ | ||
25 | } | ||