summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-06-11 16:55:02 +0000
committerArmin Kuster <akuster808@gmail.com>2019-06-16 08:15:18 -0700
commitd3e23c402f04910baba59dc3d05186e345111655 (patch)
tree9761d22729ae954d3255cec3773b89e368355c55
parentc239fef3987efde94614715ffe927d1b8684ebc4 (diff)
downloadmeta-openembedded-d3e23c402f04910baba59dc3d05186e345111655.tar.gz
igmpproxy: remove 0001-src-igmpproxy.h-Include-sys-types.h-for-u_short-u_in.patch and _GNU_SOURCE
* it was upgraded to 0.2.1 in: commit 50979151e69e5707580b2f3d263a9b36b6a190d5 Author: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Date: Sat Mar 16 18:22:59 2019 +0100 igmpproxy: update to 0.2.1 * which includes _GNU_SOURCE: https://github.com/pali/igmpproxy/commit/7d790aa2f16afad63418e573db13ea39d76ed141 * and includes sys/types.h in os-linux.h: https://github.com/pali/igmpproxy/commit/6f92242b23178e979f4a806abe4ac9652b51c593 * and the patch doesn't apply cleanly: ERROR: Fuzz detected: checking file src/igmpproxy.h Hunk #1 succeeded at 51 with fuzz 2 (offset 5 lines). patching file src/igmpproxy.h Hunk #1 succeeded at 51 with fuzz 2 (offset 5 lines). The context lines in the patches can be updated with devtool: devtool modify lib32-igmpproxy devtool finish --force-patch-refresh lib32-igmpproxy <layer_path> Don't forget to review changes done by devtool! ERROR: QA Issue: Patch log indicates that patches do not apply cleanly. [patch-fuzz] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-daemons/igmpproxy/igmpproxy/0001-src-igmpproxy.h-Include-sys-types.h-for-u_short-u_in.patch25
-rw-r--r--meta-networking/recipes-daemons/igmpproxy/igmpproxy_0.2.1.bb6
2 files changed, 1 insertions, 30 deletions
diff --git a/meta-networking/recipes-daemons/igmpproxy/igmpproxy/0001-src-igmpproxy.h-Include-sys-types.h-for-u_short-u_in.patch b/meta-networking/recipes-daemons/igmpproxy/igmpproxy/0001-src-igmpproxy.h-Include-sys-types.h-for-u_short-u_in.patch
deleted file mode 100644
index 82cdc36ac..000000000
--- a/meta-networking/recipes-daemons/igmpproxy/igmpproxy/0001-src-igmpproxy.h-Include-sys-types.h-for-u_short-u_in.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1From a557651a08e21e3c7c7f5eca9f5405f86624903f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 14 Jul 2017 22:42:51 -0700
4Subject: [PATCH] src/igmpproxy.h: Include sys/types.h for u_short/u_init
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 src/igmpproxy.h | 1 +
9 1 file changed, 1 insertion(+)
10
11diff --git a/src/igmpproxy.h b/src/igmpproxy.h
12index 4dabd1c..4454729 100644
13--- a/src/igmpproxy.h
14+++ b/src/igmpproxy.h
15@@ -46,6 +46,7 @@
16 #include <stdbool.h>
17
18 #include <sys/socket.h>
19+#include <sys/types.h>
20 #include <sys/un.h>
21 #include <sys/time.h>
22 #include <sys/ioctl.h>
23--
242.13.3
25
diff --git a/meta-networking/recipes-daemons/igmpproxy/igmpproxy_0.2.1.bb b/meta-networking/recipes-daemons/igmpproxy/igmpproxy_0.2.1.bb
index c99ebe0e9..db96d487b 100644
--- a/meta-networking/recipes-daemons/igmpproxy/igmpproxy_0.2.1.bb
+++ b/meta-networking/recipes-daemons/igmpproxy/igmpproxy_0.2.1.bb
@@ -4,12 +4,8 @@ HOMEPAGE = "http://sourceforge.net/projects/igmpproxy/"
4LICENSE = "GPLv2+" 4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=432040ff3a55670c1dec0c32b209ad69" 5LIC_FILES_CHKSUM = "file://COPYING;md5=432040ff3a55670c1dec0c32b209ad69"
6 6
7SRC_URI = "https://github.com/pali/igmpproxy/releases/download/${PV}/igmpproxy-${PV}.tar.gz \ 7SRC_URI = "https://github.com/pali/igmpproxy/releases/download/${PV}/${BP}.tar.gz"
8 file://0001-src-igmpproxy.h-Include-sys-types.h-for-u_short-u_in.patch \
9"
10SRC_URI[md5sum] = "3a9c2cb42c1f5ee0cb769a4884545641" 8SRC_URI[md5sum] = "3a9c2cb42c1f5ee0cb769a4884545641"
11SRC_URI[sha256sum] = "d351e623037390f575c1203d9cbb7ba33a8bdef85a3c5e1d2901c5a2a38449a1" 9SRC_URI[sha256sum] = "d351e623037390f575c1203d9cbb7ba33a8bdef85a3c5e1d2901c5a2a38449a1"
12 10
13inherit autotools pkgconfig 11inherit autotools pkgconfig
14
15CFLAGS += "-D_GNU_SOURCE"