summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-05-22 23:28:35 +0000
committerArmin Kuster <akuster808@gmail.com>2019-06-16 08:15:34 -0700
commitd210e225b45a3bfe805780d557bed384bba4716a (patch)
tree6d64a3924631e2e538f5f2c59c9beb8e347e7310
parenta6d674b089ece172dce4cb2e5bc5f4f4498f4bae (diff)
downloadmeta-openembedded-d210e225b45a3bfe805780d557bed384bba4716a.tar.gz
ne10, libopus: add armv7ve override as well
* fix the override in packagegroup-meta-oe.bb * alllow building ne10 for armv7ve (e.g. Cortex-A15) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb3
-rw-r--r--meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb3
-rw-r--r--meta-oe/recipes-support/ne10/ne10_1.2.1.bb4
3 files changed, 7 insertions, 3 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index 5fcf9899b..af3e84812 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -220,7 +220,8 @@ RDEPENDS_packagegroup-meta-oe-shells ="\
220 220
221NE10 = "" 221NE10 = ""
222NE10_aarch64 = "ne10" 222NE10_aarch64 = "ne10"
223NE10_arm7 = "ne10" 223NE10_armv7a = "ne10"
224NE10_armv7ve = "ne10"
224 225
225RDEPENDS_packagegroup-meta-oe-support ="\ 226RDEPENDS_packagegroup-meta-oe-support ="\
226 anthy asio atop augeas avro-c bdwgc frame grail \ 227 anthy asio atop augeas avro-c bdwgc frame grail \
diff --git a/meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb b/meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb
index 50d49370b..fb9bdc70f 100644
--- a/meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb
+++ b/meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb
@@ -28,9 +28,10 @@ EXTRA_OECONF = " \
28 --enable-custom-modes \ 28 --enable-custom-modes \
29" 29"
30 30
31# ne10 is available only for armv7a and aarch64 31# ne10 is available only for armv7a, armv7ve and aarch64
32DEPENDS_append_aarch64 = " ne10" 32DEPENDS_append_aarch64 = " ne10"
33DEPENDS_append_armv7a = " ne10" 33DEPENDS_append_armv7a = " ne10"
34DEPENDS_append_armv7ve = " ne10"
34 35
35python () { 36python () {
36 if d.getVar('TARGET_FPU') in [ 'soft' ]: 37 if d.getVar('TARGET_FPU') in [ 'soft' ]:
diff --git a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
index 4e8986de1..f37ccde1c 100644
--- a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
+++ b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
@@ -15,13 +15,15 @@ PV .= "gitr+${SRCPV}"
15 15
16inherit cmake 16inherit cmake
17 17
18# Incompatible with archs other than armv7 and aarch64 18# Incompatible with archs other than armv7, armv7ve and aarch64
19COMPATIBLE_MACHINE = "(^$)" 19COMPATIBLE_MACHINE = "(^$)"
20COMPATIBLE_MACHINE_aarch64 = "(.*)" 20COMPATIBLE_MACHINE_aarch64 = "(.*)"
21COMPATIBLE_MACHINE_armv7a = "(.*)" 21COMPATIBLE_MACHINE_armv7a = "(.*)"
22COMPATIBLE_MACHINE_armv7ve = "(.*)"
22NE10_TARGET_ARCH = "" 23NE10_TARGET_ARCH = ""
23NE10_TARGET_ARCH_aarch64 = "aarch64" 24NE10_TARGET_ARCH_aarch64 = "aarch64"
24NE10_TARGET_ARCH_armv7a = "armv7" 25NE10_TARGET_ARCH_armv7a = "armv7"
26NE10_TARGET_ARCH_armv7ve = "armv7"
25 27
26EXTRA_OECMAKE = '-DGNULINUX_PLATFORM=ON -DNE10_BUILD_SHARED=ON -DNE10_LINUX_TARGET_ARCH="${NE10_TARGET_ARCH}"' 28EXTRA_OECMAKE = '-DGNULINUX_PLATFORM=ON -DNE10_BUILD_SHARED=ON -DNE10_LINUX_TARGET_ARCH="${NE10_TARGET_ARCH}"'
27 29