summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-06-11 16:54:59 +0000
committerArmin Kuster <akuster808@gmail.com>2019-06-16 08:15:18 -0700
commitce306eed9b67557a19d1c0e670834ab5343631df (patch)
tree493399bfa740f5c55c9a1e0f3d870b7e2229a4f6
parentb1adb492e70a472125f287ab7f01a4689bf0ecc1 (diff)
downloadmeta-openembedded-ce306eed9b67557a19d1c0e670834ab5343631df.tar.gz
triggerhappy: fix issues
* using PN instead of BPN in S causes all tasks to fail: make: *** No targets specified and no makefile found. Stop. * using github archives is bad, because they are regenerated from time to time with different checksums * set PV, because this isn't exactly 0.5.0, because of the debian changes mostly the systemd support * fix indentation Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb (renamed from meta-oe/recipes-extended/triggerhappy/triggerhappy_0.5.0.bb)22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta-oe/recipes-extended/triggerhappy/triggerhappy_0.5.0.bb b/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb
index 037ce063e..24df750e0 100644
--- a/meta-oe/recipes-extended/triggerhappy/triggerhappy_0.5.0.bb
+++ b/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb
@@ -4,12 +4,12 @@ HOMEPAGE = "https://github.com/wertarbyte/triggerhappy"
4LICENSE = "GPLv3" 4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6 6
7SRC_URI = "https://github.com/wertarbyte/triggerhappy/archive/debian/0.5.0-1.tar.gz" 7# matches debian/0.5.0-1 tag
8SRCREV = "44a173195986d0d853316cb02a58785ded66c12b"
9PV = "0.5.0+git${SRCPV}"
10SRC_URI = "git://github.com/wertarbyte/${BPN}.git;branch=debian"
8 11
9SRC_URI[md5sum] = "77f90a18c775e47c4c5e9e08987ca32f" 12S = "${WORKDIR}/git"
10SRC_URI[sha256sum] = "9150bafbf7f2de7d57e6cc154676c33da98dc11ac6442e1ca57e5dce82bd4292"
11
12S = "${WORKDIR}/${PN}-debian-${PV}-1"
13 13
14inherit autotools-brokensep pkgconfig update-rc.d systemd 14inherit autotools-brokensep pkgconfig update-rc.d systemd
15 15
@@ -21,12 +21,12 @@ INITSCRIPT_PARAMS = "defaults"
21SYSTEMD_SERVICE_${PN} = "triggerhappy.service triggerhappy.socket" 21SYSTEMD_SERVICE_${PN} = "triggerhappy.service triggerhappy.socket"
22 22
23FILES_${PN} = "\ 23FILES_${PN} = "\
24${sbindir}/thd \ 24 ${sbindir}/thd \
25${sbindir}/th-cmd \ 25 ${sbindir}/th-cmd \
26${sysconfdir}/triggerhappy/triggers.d \ 26 ${sysconfdir}/triggerhappy/triggers.d \
27${nonarch_base_libdir}/udev/rules.d/80-triggerhappy.rules \ 27 ${nonarch_base_libdir}/udev/rules.d/80-triggerhappy.rules \
28${sysconfdir}/init.d/triggerhappy \ 28 ${sysconfdir}/init.d/triggerhappy \
29${systemd_unitdir}/system \ 29 ${systemd_unitdir}/system \
30" 30"
31CONFFILES_${PN} = "${sysconfdir}/udev/rules.d/80-triggerhappy.rules" 31CONFFILES_${PN} = "${sysconfdir}/udev/rules.d/80-triggerhappy.rules"
32 32