summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2018-10-05 15:41:59 +0200
committerKhem Raj <raj.khem@gmail.com>2018-10-05 14:51:14 -0700
commitbb36a6190bd91e1e4906f2db4fdc5f057229f8bb (patch)
tree257e5b2208ae0c40179e764080d641b30712bf0c
parentbbd963f3e4858057ff0c5259cc892dda6bd1c753 (diff)
downloadmeta-openembedded-bb36a6190bd91e1e4906f2db4fdc5f057229f8bb.tar.gz
libcec: update to 4.0.2
This also removes a warning that /usr/bin/python is not provided by any package. Further it moves all binaires to a separate package libcec-tools Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libcec/files/0001-Explicitly-use-python3-in-pyCecClient.patch24
-rw-r--r--meta-oe/recipes-extended/libcec/files/python-install-location.patch28
-rw-r--r--meta-oe/recipes-extended/libcec/libcec_git.bb16
3 files changed, 35 insertions, 33 deletions
diff --git a/meta-oe/recipes-extended/libcec/files/0001-Explicitly-use-python3-in-pyCecClient.patch b/meta-oe/recipes-extended/libcec/files/0001-Explicitly-use-python3-in-pyCecClient.patch
new file mode 100644
index 000000000..ec1f5d0d5
--- /dev/null
+++ b/meta-oe/recipes-extended/libcec/files/0001-Explicitly-use-python3-in-pyCecClient.patch
@@ -0,0 +1,24 @@
1From 16e8c072709572ccefa6c7f835136db01f031323 Mon Sep 17 00:00:00 2001
2From: Pascal Bach <pascal.bach@siemens.com>
3Date: Fri, 28 Sep 2018 16:56:14 +0200
4Subject: [PATCH] Explicitly use python3 in pyCecClient
5
6Upstream-Status: Submitted [https://github.com/Pulse-Eight/libcec/pull/433]
7
8---
9 src/pyCecClient/pyCecClient.py | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/src/pyCecClient/pyCecClient.py b/src/pyCecClient/pyCecClient.py
13index 6d47857..d0504ac 100755
14--- a/src/pyCecClient/pyCecClient.py
15+++ b/src/pyCecClient/pyCecClient.py
16@@ -1,4 +1,4 @@
17-#! /usr/bin/python
18+#! /usr/bin/python3
19 ## demo of the python-libcec API
20
21 # This file is part of the libCEC(R) library.
22--
232.11.0
24
diff --git a/meta-oe/recipes-extended/libcec/files/python-install-location.patch b/meta-oe/recipes-extended/libcec/files/python-install-location.patch
deleted file mode 100644
index b6be78dd4..000000000
--- a/meta-oe/recipes-extended/libcec/files/python-install-location.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 330fa6777d51d41eefacff8e98e4250d210fde35 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Javi=20Mart=C3=ADnez?= <javi@flamingalah.net>
3Date: Tue, 13 Dec 2016 22:31:13 +0100
4Subject: [PATCH] Improve/fix installation of Python bindings
5
6Upstream-Status: Backport
7
8dist-packages is a Debian-specific directory for distribution packages (and used in derivatives such as Ubuntu). Therefore changed to site-packages.
9---
10 src/libcec/cmake/CheckPlatformSupport.cmake | 4 ++--
11 1 file changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/src/libcec/cmake/CheckPlatformSupport.cmake b/src/libcec/cmake/CheckPlatformSupport.cmake
14index fcd0ef7..7661107 100644
15--- a/src/libcec/cmake/CheckPlatformSupport.cmake
16+++ b/src/libcec/cmake/CheckPlatformSupport.cmake
17@@ -195,9 +195,9 @@ else()
18 RENAME __init__.py)
19 else()
20 install(TARGETS ${SWIG_MODULE_cec_REAL_NAME}
21- DESTINATION lib/python${PYTHON_VERSION}/dist-packages/cec)
22+ DESTINATION lib/python${PYTHON_VERSION}/site-packages/cec)
23 install(FILES ${CMAKE_BINARY_DIR}/src/libcec/cec.py
24- DESTINATION lib/python${PYTHON_VERSION}/dist-packages/cec
25+ DESTINATION lib/python${PYTHON_VERSION}/site-packages/cec
26 RENAME __init__.py)
27 endif()
28 endif()
diff --git a/meta-oe/recipes-extended/libcec/libcec_git.bb b/meta-oe/recipes-extended/libcec/libcec_git.bb
index cb65caad8..4ad49971a 100644
--- a/meta-oe/recipes-extended/libcec/libcec_git.bb
+++ b/meta-oe/recipes-extended/libcec/libcec_git.bb
@@ -4,24 +4,30 @@ HOMEPAGE = "http://libcec.pulse-eight.com/"
4LICENSE = "GPLv2+" 4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715" 5LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715"
6 6
7DEPENDS = "p8platform udev lockdev ncurses swig-native python3" 7DEPENDS = "p8platform udev ncurses swig-native python3"
8 8
9DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}" 9DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}"
10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}" 10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
11 11
12PV = "4.0.1+gitr${SRCPV}" 12PV = "4.0.2+gitr${SRCPV}"
13 13
14SRCREV = "2fc92b5f02dca702da92ccc5ed7b805b240ef5df" 14SRCREV = "0a97062dd4b196ceeb003ec41841c7a7edc36dd1"
15SRC_URI = "git://github.com/Pulse-Eight/libcec.git \ 15SRC_URI = "git://github.com/Pulse-Eight/libcec.git \
16 file://python-install-location.patch" 16 file://0001-Explicitly-use-python3-in-pyCecClient.patch"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
20inherit cmake pkgconfig 20inherit cmake pkgconfig
21 21
22# Put client tools into a separate package
23PACKAGE_BEFORE_PN += "${PN}-tools"
24FILES_${PN}-tools = "${bindir}"
25RDEPENDS_${PN}-tools = "python3-${BPN}"
26
22# Create the wrapper for python3 27# Create the wrapper for python3
23PACKAGES += "python3-${BPN}" 28PACKAGES += "python3-${BPN}"
24FILES_python3-${BPN} = "${libdir}/python3*" 29FILES_python3-${BPN} = "${libdir}/python3* ${bindir}/py*"
30RDEPENDS_${PN} = "python3-core"
25 31
26# cec-client and xbmc need the .so present to work :( 32# cec-client and xbmc need the .so present to work :(
27FILES_${PN} += "${libdir}/*.so" 33FILES_${PN} += "${libdir}/*.so"