summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2019-04-22 02:06:34 -0700
committerKhem Raj <raj.khem@gmail.com>2019-04-29 10:13:56 -0700
commit9fa40ad5f45ed7bf91181609a3feca3a2508ef53 (patch)
tree31ca5f7cf000f83991feb355fa75953f1784d4e4
parentb655a3ea602eaad6b604ddab0c191039a09158d5 (diff)
downloadmeta-openembedded-9fa40ad5f45ed7bf91181609a3feca3a2508ef53.tar.gz
indent: Upgrade to 2.2.12
Add two patches to fix the build error. Add -Wno-error=unused-value for native build to silence below error: | In file included from ../../indent-2.2.12/src/indent.h:60:0, from ../../indent-2.2.12/src/indent.c:77: | ../../indent-2.2.12/src/indent.c: In function 'main': | ../../indent-2.2.12/src/libgettext.h:88:5: error: statement with no effect [-Werror=unused-value] ((void) (Domainname), (const char *) (Dirname)) ^ | ../../indent-2.2.12/src/indent.c:1064:5: note: in expansion of macro 'bindtextdomain' bindtextdomain(PACKAGE, LOCALEDIR); Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/indent/indent/0001-Makefile.am-remove-regression-dir.patch67
-rw-r--r--meta-oe/recipes-extended/indent/indent/0001-src-indent.c-correct-the-check-for-locale.h.patch40
-rw-r--r--meta-oe/recipes-extended/indent/indent_2.2.12.bb (renamed from meta-oe/recipes-extended/indent/indent_2.2.10.bb)11
3 files changed, 115 insertions, 3 deletions
diff --git a/meta-oe/recipes-extended/indent/indent/0001-Makefile.am-remove-regression-dir.patch b/meta-oe/recipes-extended/indent/indent/0001-Makefile.am-remove-regression-dir.patch
new file mode 100644
index 000000000..357d77d83
--- /dev/null
+++ b/meta-oe/recipes-extended/indent/indent/0001-Makefile.am-remove-regression-dir.patch
@@ -0,0 +1,67 @@
1From 27bda5ee884e79d6d0e76955124d2b0c5798d6cf Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Mon, 25 Feb 2019 00:34:17 -0800
4Subject: [PATCH] Makefile.am: remove regression dir
5
6Remove regression dir to fix below do_compile
7error:
8| Making all in regression
9| /bin/sh: line 20: cd: regression: No such file or directory
10| Makefile:451: recipe for target 'all-recursive' failed
11
12BTW, it should be safe not to cover regression dir
13as there is no Makefile.in under ${S}/regression
14and the content of ${S}/regression/Makefile as below.
15-------------------------------------
16all:
17
18install:
19
20check:
21 ./TEST
22
23distclean: clean
24
25maintainer-clean: clean
26
27distdir:
28
29clean:
30 @rm -rf output
31
32.PHONY: all install
33-------------------------------------
34
35Upstream-Status: Pending
36
37Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
38---
39 Makefile.am | 5 ++---
40 1 file changed, 2 insertions(+), 3 deletions(-)
41
42diff --git a/Makefile.am b/Makefile.am
43index ba37a42..548fea7 100644
44--- a/Makefile.am
45+++ b/Makefile.am
46@@ -1,7 +1,7 @@
47 ## Process this file with automake to produce Makefile.in
48 AUTOMAKE_OPTIONS = no-texinfo.tex
49
50-SUBDIRS = intl src doc po man regression
51+SUBDIRS = intl src doc po man
52
53 BUILT_SOURCES =
54
55@@ -13,8 +13,7 @@ EXTRA_DIST = README.md \
56 aclocal/UTIMBUF.m4 \
57 miscel/Makefile.mingw32 \
58 miscel/README.vc++ \
59- bootstrap \
60- regression
61+ bootstrap
62
63 DISTCLEANFILES=config/config.cache config/config.log config.h
64
65--
662.17.1
67
diff --git a/meta-oe/recipes-extended/indent/indent/0001-src-indent.c-correct-the-check-for-locale.h.patch b/meta-oe/recipes-extended/indent/indent/0001-src-indent.c-correct-the-check-for-locale.h.patch
new file mode 100644
index 000000000..7df7ecb38
--- /dev/null
+++ b/meta-oe/recipes-extended/indent/indent/0001-src-indent.c-correct-the-check-for-locale.h.patch
@@ -0,0 +1,40 @@
1From 75369ce004ec0f5e46a432fa1dac8cfc7ae1ef8d Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Sun, 24 Feb 2019 22:35:08 -0800
4Subject: [PATCH] src/indent.c: correct the check for locale.h
5
6Adjust to check HAVE_LC_MESSAGES or HAVE_LOCALE_H
7to determine whether include locale.h or not to
8fix below issue:
9
10| ../../indent-2.2.12/src/indent.c: In function 'main':
11| ../../indent-2.2.12/src/indent.c:1062:5: error: implicit declaration of function 'setlocale'; did you mean 'setstate'? [-Werror=implicit-function-declaration]
12| setlocale(LC_ALL, "");
13| ^~~~~~~~~
14| setstate
15| ../../indent-2.2.12/src/indent.c:1062:5: error: nested extern declaration of 'setlocale' [-Werror=nested-externs]
16| ../../indent-2.2.12/src/indent.c:1062:15: error: 'LC_ALL' undeclared (first use in this function)
17
18Upstream-Status: Pending
19
20Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
21---
22 src/indent.c | 2 +-
23 1 file changed, 1 insertion(+), 1 deletion(-)
24
25diff --git a/src/indent.c b/src/indent.c
26index 4d666e2..0c2780b 100644
27--- a/src/indent.c
28+++ b/src/indent.c
29@@ -71,7 +71,7 @@
30 #include <string.h>
31 #include <ctype.h>
32 #include <stdlib.h>
33-#ifdef HAVE_LOCALE_H
34+#if defined(HAVE_LC_MESSAGES) || defined(HAVE_LOCALE_H)
35 #include <locale.h>
36 #endif
37 #include "indent.h"
38--
392.17.1
40
diff --git a/meta-oe/recipes-extended/indent/indent_2.2.10.bb b/meta-oe/recipes-extended/indent/indent_2.2.12.bb
index d25e8e317..f2891df50 100644
--- a/meta-oe/recipes-extended/indent/indent_2.2.10.bb
+++ b/meta-oe/recipes-extended/indent/indent_2.2.12.bb
@@ -11,12 +11,17 @@ LICENSE = "GPLv3"
11LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 11LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
12DEPENDS = "virtual/gettext" 12DEPENDS = "virtual/gettext"
13 13
14SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz" 14SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
15SRC_URI[md5sum] = "be35ea62705733859fbf8caf816d8959" 15 file://0001-src-indent.c-correct-the-check-for-locale.h.patch \
16SRC_URI[sha256sum] = "8a9b41be5bfcab5d8c1be74204b10ae78789fc3deabea0775fdced8677292639" 16 file://0001-Makefile.am-remove-regression-dir.patch \
17"
18SRC_URI[md5sum] = "4764b6ac98f6654a35da117b8e5e8e14"
19SRC_URI[sha256sum] = "e77d68c0211515459b8812118d606812e300097cfac0b4e9fb3472664263bb8b"
17 20
18inherit autotools gettext 21inherit autotools gettext
19 22
23CFLAGS_class-native += " -Wno-error=unused-value"
24
20FILES_${PN}-doc += "/usr/doc/indent/indent.html" 25FILES_${PN}-doc += "/usr/doc/indent/indent.html"
21 26
22BBCLASSEXTEND = "native" 27BBCLASSEXTEND = "native"