diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-01-29 14:51:47 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-01-30 13:34:49 -0800 |
commit | 920265d47a9d75a8f4054ec2291c7a1c6dc904e8 (patch) | |
tree | 03e8f9d766d84093d0b7987226e65a4a87512dbb | |
parent | 6fd901de5a59c660a7e9e6d9abec000c7b849b3c (diff) | |
download | meta-openembedded-920265d47a9d75a8f4054ec2291c7a1c6dc904e8.tar.gz |
xmlrpc-c: Update to 1.51.03
Fix build with clang while here
Signed-off-by: Khem Raj <raj.khem@gmail.com>
4 files changed, 76 insertions, 76 deletions
diff --git a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0001-fix-compile-failure-against-musl-C-library.patch b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0001-fix-compile-failure-against-musl-C-library.patch deleted file mode 100644 index 234d696f1..000000000 --- a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0001-fix-compile-failure-against-musl-C-library.patch +++ /dev/null | |||
@@ -1,52 +0,0 @@ | |||
1 | From 950b27f8320b841490cafcb3e6e3b818c7174c0d Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Thu, 20 Jul 2017 22:32:50 -0400 | ||
4 | Subject: [PATCH] fix compile failure against musl C library | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
9 | --- | ||
10 | test/cpp/server_abyss.cpp | 2 +- | ||
11 | tools/xmlrpc_pstream/xmlrpc_pstream.cpp | 10 +++++++--- | ||
12 | 2 files changed, 8 insertions(+), 4 deletions(-) | ||
13 | |||
14 | diff --git a/test/cpp/server_abyss.cpp b/test/cpp/server_abyss.cpp | ||
15 | index 2458a8f..82f91da 100644 | ||
16 | --- a/test/cpp/server_abyss.cpp | ||
17 | +++ b/test/cpp/server_abyss.cpp | ||
18 | @@ -18,7 +18,7 @@ | ||
19 | #ifdef WIN32 | ||
20 | #include <winsock2.h> | ||
21 | #else | ||
22 | - #include <sys/unistd.h> | ||
23 | + #include <unistd.h> | ||
24 | #include <sys/socket.h> | ||
25 | #include <arpa/inet.h> | ||
26 | #include <netinet/in.h> | ||
27 | diff --git a/tools/xmlrpc_pstream/xmlrpc_pstream.cpp b/tools/xmlrpc_pstream/xmlrpc_pstream.cpp | ||
28 | index d39e105..1fd8900 100644 | ||
29 | --- a/tools/xmlrpc_pstream/xmlrpc_pstream.cpp | ||
30 | +++ b/tools/xmlrpc_pstream/xmlrpc_pstream.cpp | ||
31 | @@ -15,11 +15,15 @@ | ||
32 | #include "xmlrpc-c/girerr.hpp" | ||
33 | using girerr::throwf; | ||
34 | |||
35 | -#include <features.h> // for __BEGIN_DECLS | ||
36 | +#ifdef __cplusplus | ||
37 | +extern "C" { | ||
38 | +#endif | ||
39 | |||
40 | -__BEGIN_DECLS | ||
41 | #include "dumpvalue.h" /* An internal Xmlrpc-c header file ! */ | ||
42 | -__END_DECLS | ||
43 | + | ||
44 | +#ifdef __cplusplus | ||
45 | +} | ||
46 | +#endif | ||
47 | |||
48 | |||
49 | #include <xmlrpc-c/base.hpp> | ||
50 | -- | ||
51 | 2.8.1 | ||
52 | |||
diff --git a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0001-test-cpp-server_abyss-Fix-build-with-clang-libc.patch b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0001-test-cpp-server_abyss-Fix-build-with-clang-libc.patch new file mode 100644 index 000000000..be83b0166 --- /dev/null +++ b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0001-test-cpp-server_abyss-Fix-build-with-clang-libc.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From dba3c5bf34ed530fd41ed50968825af2158f142e Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 29 Jan 2019 13:31:39 -0800 | ||
4 | Subject: [PATCH] test/cpp/server_abyss: Fix build with clang/libc++ | ||
5 | |||
6 | /mnt/a/yoe/workspace/sources/xmlrpc-c/test/cpp/server_abyss.cpp:87:14: error: assigning to 'int' from incompatible type '__bind<int | ||
7 | &, sockaddr *, unsigned int>' | ||
8 | rc = bind(this->fd, (struct sockaddr *)&sockAddr, sizeof(sockAddr)); | ||
9 | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | test/cpp/server_abyss.cpp | 56 +++++++++++++++++++-------------------- | ||
15 | 1 file changed, 28 insertions(+), 28 deletions(-) | ||
16 | |||
17 | --- a/test/cpp/server_abyss.cpp | ||
18 | +++ b/test/cpp/server_abyss.cpp | ||
19 | @@ -85,7 +85,7 @@ public: | ||
20 | sockAddr.sin_port = htons(portNumber); | ||
21 | sockAddr.sin_addr.s_addr = 0; | ||
22 | |||
23 | - rc = bind(this->fd, (struct sockaddr *)&sockAddr, sizeof(sockAddr)); | ||
24 | + rc = ::bind(this->fd, (struct sockaddr *)&sockAddr, sizeof(sockAddr)); | ||
25 | |||
26 | if (rc != 0) { | ||
27 | closesock(this->fd); | ||
diff --git a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.31.0.bb b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.31.0.bb deleted file mode 100644 index efa58f198..000000000 --- a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.31.0.bb +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | DESCRIPTION = "XML-RPC for C/C++ is programming libraries and related tools to help you \ | ||
2 | write an XML-RPC server or client in C or C++." | ||
3 | |||
4 | HOMEPAGE = "http://xmlrpc-c.sourceforge.net/" | ||
5 | LICENSE = "BSD & MIT" | ||
6 | LIC_FILES_CHKSUM = "file://doc/COPYING;md5=aefbf81ba0750f02176b6f86752ea951" | ||
7 | |||
8 | SRC_URI = "git://github.com/ensc/xmlrpc-c.git;branch=master \ | ||
9 | file://0001-fix-compile-failure-against-musl-C-library.patch \ | ||
10 | file://0002-fix-formatting-issues.patch \ | ||
11 | " | ||
12 | SRCREV = "81443a9dc234cc275449dbc17867ad77ae189124" | ||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | DEPENDS = "curl libxml2" | ||
16 | RDEPENDS_${PN} = "curl perl" | ||
17 | |||
18 | inherit cmake | ||
19 | |||
20 | EXTRA_OECMAKE = "-D_lib:STRING=${baselib}" | ||
21 | |||
22 | BBCLASSEXTEND = "native" | ||
23 | |||
24 | TARGET_CFLAGS += "-Wno-narrowing" | ||
diff --git a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.51.03.bb b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.51.03.bb new file mode 100644 index 000000000..02ea8cc5f --- /dev/null +++ b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.51.03.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | DESCRIPTION = "XML-RPC for C/C++ is programming libraries and related tools to help you \ | ||
2 | write an XML-RPC server or client in C or C++." | ||
3 | |||
4 | HOMEPAGE = "http://xmlrpc-c.sourceforge.net/" | ||
5 | LICENSE = "BSD & MIT" | ||
6 | LIC_FILES_CHKSUM = "file://doc/COPYING;md5=aefbf81ba0750f02176b6f86752ea951" | ||
7 | |||
8 | SRC_URI = "git://github.com/mirror/xmlrpc-c.git \ | ||
9 | file://0001-test-cpp-server_abyss-Fix-build-with-clang-libc.patch \ | ||
10 | file://0002-fix-formatting-issues.patch \ | ||
11 | " | ||
12 | #Release 1.51.03 | ||
13 | SRCREV = "343a3b98e54999d67edb644bcd395aa9784fb16e" | ||
14 | |||
15 | S = "${WORKDIR}/git/stable" | ||
16 | |||
17 | DEPENDS = "libxml2" | ||
18 | RDEPENDS_${PN} = "perl" | ||
19 | |||
20 | inherit autotools-brokensep pkgconfig | ||
21 | |||
22 | TARGET_CFLAGS += "-Wno-narrowing" | ||
23 | |||
24 | EXTRA_OEMAKE += "CC_FOR_BUILD='${BUILD_CC}' \ | ||
25 | LD_FOR_BUILD='${BUILD_LD}' \ | ||
26 | CFLAGS_FOR_BUILD='${BUILD_CFLAGS}' \ | ||
27 | LDFLAGS_FOR_BUILD='${BUILD_LDFLAGS}' \ | ||
28 | " | ||
29 | |||
30 | EXTRA_OECONF += "--disable-libwww-client --disable-wininet-client" | ||
31 | |||
32 | PACKAGECONFIG ??= "curl cplusplus" | ||
33 | |||
34 | PACKAGECONFIG[abyss] = "--enable-abyss-server --enable-abyss-threads --enable-abyss-openssl,--disable-abyss-server --disable-abyss-threads --disable-abyss-openssl,openssl," | ||
35 | PACKAGECONFIG[cplusplus] = "--enable-cplusplus,--disable-cplusplus,," | ||
36 | PACKAGECONFIG[curl] = "--enable-curl-client,--disable-curl-client,curl,curl" | ||
37 | |||
38 | do_configure() { | ||
39 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S} | ||
40 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S} | ||
41 | autoconf | ||
42 | oe_runconf | ||
43 | # license is incompatible with lib/util/getoptx.* | ||
44 | rm -fv ${S}/tools/turbocharger/mod_gzip.c | ||
45 | } | ||
46 | |||
47 | BBCLASSEXTEND = "native" | ||
48 | |||
49 | CLEANBROKEN = "1" | ||