summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-10-03 21:24:49 +0200
committerKhem Raj <raj.khem@gmail.com>2018-10-04 08:52:54 -0700
commit9029f051de742aa95c2879fc990ece704ab85c26 (patch)
treeeaeb6854a27729dbe17aa776a4e8b4b93104f128
parent184c1366147b5e05db94283c767431d154bc7941 (diff)
downloadmeta-openembedded-9029f051de742aa95c2879fc990ece704ab85c26.tar.gz
openjpeg: cmake fixes to prepare update of poppler
* Move *,cmake from ${libdir}/cmake to ${libdir}/cmake/<name-and-version> That is standard location cmake files are installed. * Do not export executables - they will not be found in dependant's sysroot Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/openjpeg/openjpeg/0001-Ensure-cmake-files-are-installed-at-common-location.patch48
-rw-r--r--meta-oe/recipes-graphics/openjpeg/openjpeg/0002-Do-not-ask-cmake-to-export-binaries-they-don-t-make-.patch31
-rw-r--r--meta-oe/recipes-graphics/openjpeg/openjpeg_2.3.0.bb10
3 files changed, 84 insertions, 5 deletions
diff --git a/meta-oe/recipes-graphics/openjpeg/openjpeg/0001-Ensure-cmake-files-are-installed-at-common-location.patch b/meta-oe/recipes-graphics/openjpeg/openjpeg/0001-Ensure-cmake-files-are-installed-at-common-location.patch
new file mode 100644
index 000000000..5c5fe64f2
--- /dev/null
+++ b/meta-oe/recipes-graphics/openjpeg/openjpeg/0001-Ensure-cmake-files-are-installed-at-common-location.patch
@@ -0,0 +1,48 @@
1From fe491c0919f5adc8d626cb98c5ec19d0b99dfe20 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Thu, 27 Sep 2018 23:45:04 +0200
4Subject: [PATCH] Ensure cmake files are installed at common location
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9* Otherwise recent poppler is not able to find them
10* Include path needs adjustment with this change
11
12Upstream-Status: Inappropriate [Configuration]
13
14Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
15---
16 CMakeLists.txt | 2 +-
17 cmake/OpenJPEGConfig.cmake.in | 2 +-
18 2 files changed, 2 insertions(+), 2 deletions(-)
19
20diff --git a/CMakeLists.txt b/CMakeLists.txt
21index ff70a06f..23d2fac4 100644
22--- a/CMakeLists.txt
23+++ b/CMakeLists.txt
24@@ -150,7 +150,7 @@ if(NOT OPENJPEG_INSTALL_PACKAGE_DIR)
25 # We could install *.cmake files in share/ however those files contains
26 # hardcoded path to libraries on a multi-arch system (fedora/debian) those
27 # path will be different (lib/i386-linux-gnu vs lib/x86_64-linux-gnu)
28- set(OPENJPEG_INSTALL_PACKAGE_DIR "${OPENJPEG_INSTALL_LIB_DIR}/${OPENJPEG_INSTALL_SUBDIR}")
29+ set(OPENJPEG_INSTALL_PACKAGE_DIR "${OPENJPEG_INSTALL_LIB_DIR}/cmake/${OPENJPEG_INSTALL_SUBDIR}")
30 endif()
31
32 if (APPLE)
33diff --git a/cmake/OpenJPEGConfig.cmake.in b/cmake/OpenJPEGConfig.cmake.in
34index b20294ca..6a2f4baf 100644
35--- a/cmake/OpenJPEGConfig.cmake.in
36+++ b/cmake/OpenJPEGConfig.cmake.in
37@@ -26,7 +26,7 @@ get_filename_component(SELF_DIR "${CMAKE_CURRENT_LIST_FILE}" PATH)
38 if(EXISTS ${SELF_DIR}/OpenJPEGTargets.cmake)
39 # This is an install tree
40 include(${SELF_DIR}/OpenJPEGTargets.cmake)
41- get_filename_component(OPENJPEG_INCLUDE_ROOT "${SELF_DIR}/../../@OPENJPEG_INSTALL_INCLUDE_DIR@" ABSOLUTE)
42+ get_filename_component(OPENJPEG_INCLUDE_ROOT "${SELF_DIR}/../../../@OPENJPEG_INSTALL_INCLUDE_DIR@" ABSOLUTE)
43 set(OPENJPEG_INCLUDE_DIRS ${OPENJPEG_INCLUDE_ROOT})
44
45 else()
46--
472.14.4
48
diff --git a/meta-oe/recipes-graphics/openjpeg/openjpeg/0002-Do-not-ask-cmake-to-export-binaries-they-don-t-make-.patch b/meta-oe/recipes-graphics/openjpeg/openjpeg/0002-Do-not-ask-cmake-to-export-binaries-they-don-t-make-.patch
new file mode 100644
index 000000000..0ba13cf88
--- /dev/null
+++ b/meta-oe/recipes-graphics/openjpeg/openjpeg/0002-Do-not-ask-cmake-to-export-binaries-they-don-t-make-.patch
@@ -0,0 +1,31 @@
1From 4681de07e21f17aa28710d3a51fabe7da60463f9 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Fri, 28 Sep 2018 00:38:50 +0200
4Subject: [PATCH] Do not ask cmake to export binaries - they don't make it
5 dependants sysroots
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10Upstream-Status: Inappropriate [OE-Specific]
11
12Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
13---
14 src/bin/jp2/CMakeLists.txt | 1 -
15 1 file changed, 1 deletion(-)
16
17diff --git a/src/bin/jp2/CMakeLists.txt b/src/bin/jp2/CMakeLists.txt
18index 4324c36d..2c11fe02 100644
19--- a/src/bin/jp2/CMakeLists.txt
20+++ b/src/bin/jp2/CMakeLists.txt
21@@ -66,7 +66,6 @@ foreach(exe opj_decompress opj_compress opj_dump)
22 endif()
23 # Install exe
24 install(TARGETS ${exe}
25- EXPORT OpenJPEGTargets
26 DESTINATION ${OPENJPEG_INSTALL_BIN_DIR} COMPONENT Applications
27 )
28 if(OPJ_USE_DSYMUTIL)
29--
302.14.4
31
diff --git a/meta-oe/recipes-graphics/openjpeg/openjpeg_2.3.0.bb b/meta-oe/recipes-graphics/openjpeg/openjpeg_2.3.0.bb
index d5d06206d..c50d55e4b 100644
--- a/meta-oe/recipes-graphics/openjpeg/openjpeg_2.3.0.bb
+++ b/meta-oe/recipes-graphics/openjpeg/openjpeg_2.3.0.bb
@@ -5,12 +5,12 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c648878b4840d7babaade1303e7f108c"
5 5
6DEPENDS = "libpng tiff lcms zlib" 6DEPENDS = "libpng tiff lcms zlib"
7 7
8SRC_URI = "git://github.com/uclouvain/openjpeg.git" 8SRC_URI = " \
9 git://github.com/uclouvain/openjpeg.git \
10 file://0001-Ensure-cmake-files-are-installed-at-common-location.patch \
11 file://0002-Do-not-ask-cmake-to-export-binaries-they-don-t-make-.patch \
12"
9SRCREV = "081de4b15f54cb4482035b7bf5e3fb443e4bc84b" 13SRCREV = "081de4b15f54cb4482035b7bf5e3fb443e4bc84b"
10S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
11 15
12inherit cmake 16inherit cmake
13
14# standard path for *.cmake
15EXTRA_OECMAKE += "-DOPENJPEG_INSTALL_PACKAGE_DIR=${baselib}/cmake \
16 -DOPENJPEG_INSTALL_LIB_DIR:PATH=${libdir}"