summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-22 16:01:23 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:27:37 +0200
commit7d5ec62fed0bd822b2d96f916b691359ec446226 (patch)
tree907aceca1f8b8374a4f141ea4136c6d9e127123e
parentc4728e0f7b3c7ba5d218700ecb41e103d28e999e (diff)
downloadmeta-openembedded-7d5ec62fed0bd822b2d96f916b691359ec446226.tar.gz
python-iso8601: Extend recipe to support Python 3
- Add Python 3 recipe - Add native and nativesdk to BBCLASSEXTEND Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-iso8601.inc8
-rw-r--r--meta-python/recipes-devtools/python/python-iso8601_0.1.11.bb8
-rw-r--r--meta-python/recipes-devtools/python/python3-iso8601_0.1.11.bb2
3 files changed, 11 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python-iso8601.inc b/meta-python/recipes-devtools/python/python-iso8601.inc
new file mode 100644
index 000000000..dd4b83cc9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-iso8601.inc
@@ -0,0 +1,8 @@
1SUMMARY = "Simple module to parse ISO 8601 dates"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=b05625f2336fa024e8d57e65c6595844"
4
5SRC_URI[md5sum] = "b06d11cd14a64096f907086044f0fe38"
6SRC_URI[sha256sum] = "e8fb52f78880ae063336c94eb5b87b181e6a0cc33a6c008511bac9a6e980ef30"
7
8BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-iso8601_0.1.11.bb b/meta-python/recipes-devtools/python/python-iso8601_0.1.11.bb
index 484cf1243..c543cf9f9 100644
--- a/meta-python/recipes-devtools/python/python-iso8601_0.1.11.bb
+++ b/meta-python/recipes-devtools/python/python-iso8601_0.1.11.bb
@@ -1,8 +1,2 @@
1SUMMARY = "Simple module to parse ISO 8601 dates"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=b05625f2336fa024e8d57e65c6595844"
4
5SRC_URI[md5sum] = "b06d11cd14a64096f907086044f0fe38"
6SRC_URI[sha256sum] = "e8fb52f78880ae063336c94eb5b87b181e6a0cc33a6c008511bac9a6e980ef30"
7
8inherit pypi setuptools 1inherit pypi setuptools
2require python-iso8601.inc
diff --git a/meta-python/recipes-devtools/python/python3-iso8601_0.1.11.bb b/meta-python/recipes-devtools/python/python3-iso8601_0.1.11.bb
new file mode 100644
index 000000000..4a332b53b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-iso8601_0.1.11.bb
@@ -0,0 +1,2 @@
1inherit pypi setuptools3
2require python-iso8601.inc