summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLei Yang <lei.yang@windriver.com>2013-01-07 01:38:24 +0000
committerJoe MacDonald <joe.macdonald@windriver.com>2013-01-07 15:20:37 -0500
commit7bbb2e57c3c0e170844d24b69b2986c278977a16 (patch)
tree7b49d50c5c70281bea326ed923350aaff63656d0
parenta0292fc5fc84ac016392706de0a531e3ca2b03ea (diff)
downloadmeta-openembedded-7bbb2e57c3c0e170844d24b69b2986c278977a16.tar.gz
Add netcat-bsd into meta-networking for meta-virutalization libvirt virt-test
The netcat-openbsd in meta-virtualization layer has bugs. This update version will fix "nc: Protocol no available." error. As bruce point, we want to keep netcat in the meta-networking, which meta-virtualization will depend on,and this patch will let netcat-openbsd with low priority to install Signed-off-by: Lei Yang <lei.yang@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
-rw-r--r--meta-networking/recipes-support/netcat/netcat-openbsd_1.89.bb30
-rw-r--r--meta-networking/recipes-support/netcat/netcat.inc5
-rw-r--r--meta-networking/recipes-support/netcat/netcat_0.7.1.bb11
3 files changed, 40 insertions, 6 deletions
diff --git a/meta-networking/recipes-support/netcat/netcat-openbsd_1.89.bb b/meta-networking/recipes-support/netcat/netcat-openbsd_1.89.bb
new file mode 100644
index 000000000..f83caee94
--- /dev/null
+++ b/meta-networking/recipes-support/netcat/netcat-openbsd_1.89.bb
@@ -0,0 +1,30 @@
1require netcat.inc
2DESCRIPTION = "OpenBSD Netcat"
3HOMEPAGE = "http://ftp.debian.org"
4LICENSE = "BSD-3-Clause"
5PR = "r0"
6
7SRC_URI = "${DEBIAN_MIRROR}/main/n/netcat-openbsd/netcat-openbsd_1.89.orig.tar.gz;name=netcat \
8 ${DEBIAN_MIRROR}/main/n/netcat-openbsd/netcat-openbsd_1.89-4.diff.gz;name=netcat-patch"
9
10SRC_URI[netcat.md5sum] = "7238ce15aae43069e96ba7faf03f153e"
11SRC_URI[netcat.sha256sum] = "72e844dde8a2a7cba61971d493758dbea9ef0b164bccef15fd4a36490dc77f2b"
12SRC_URI[netcat-patch.md5sum] = "00c65aa22243b76998174c733cbb64cc"
13SRC_URI[netcat-patch.sha256sum] = "d5b6b2bd9788114bdcfbb71acad0263720b4fdc41529e287adf451b8610f84f1"
14
15S = "${WORKDIR}/${PN}-${PV}.orig"
16
17do_configure[noexec] = "1"
18
19do_compile() {
20 cd ${S}
21 while read line; do patch -p1 <debian/patches/$line; done <debian/patches/series
22 pkgrel=4
23 oe_runmake CFLAGS="$CFLAGS -DDEBIAN_VERSION=\"\\\"${pkgrel}\\\"\""
24}
25
26do_install() {
27 install -d ${D}${bindir}
28 install -m 755 ${S}/nc ${D}${bindir}/nc.${PN}
29}
30ALTERNATIVE_PRIORITY = "50"
diff --git a/meta-networking/recipes-support/netcat/netcat.inc b/meta-networking/recipes-support/netcat/netcat.inc
new file mode 100644
index 000000000..6c815d97e
--- /dev/null
+++ b/meta-networking/recipes-support/netcat/netcat.inc
@@ -0,0 +1,5 @@
1SECTION = "console/network"
2inherit update-alternatives gettext
3
4ALTERNATIVE_${PN} = "nc"
5
diff --git a/meta-networking/recipes-support/netcat/netcat_0.7.1.bb b/meta-networking/recipes-support/netcat/netcat_0.7.1.bb
index c5ab85d19..c4f1f331a 100644
--- a/meta-networking/recipes-support/netcat/netcat_0.7.1.bb
+++ b/meta-networking/recipes-support/netcat/netcat_0.7.1.bb
@@ -1,21 +1,20 @@
1require netcat.inc
1DESCRIPTION = "GNU Netcat" 2DESCRIPTION = "GNU Netcat"
2HOMEPAGE = "http://netcat.sourceforge.net" 3HOMEPAGE = "http://netcat.sourceforge.net"
3SECTION = "console/network"
4LICENSE = "GPLv2" 4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6 6
7PR = "r0" 7PR = "r1"
8 8
9SRC_URI = "${SOURCEFORGE_MIRROR}/netcat/netcat-${PV}.tar.bz2" 9SRC_URI = "${SOURCEFORGE_MIRROR}/netcat/netcat-${PV}.tar.bz2"
10 10
11SRC_URI[md5sum] = "0a29eff1736ddb5effd0b1ec1f6fe0ef" 11SRC_URI[md5sum] = "0a29eff1736ddb5effd0b1ec1f6fe0ef"
12SRC_URI[sha256sum] = "b55af0bbdf5acc02d1eb6ab18da2acd77a400bafd074489003f3df09676332bb" 12SRC_URI[sha256sum] = "b55af0bbdf5acc02d1eb6ab18da2acd77a400bafd074489003f3df09676332bb"
13 13
14inherit autotools update-alternatives gettext 14inherit autotools
15 15
16do_install_append() { 16do_install_append() {
17 mv ${D}${bindir}/nc ${D}${bindir}/nc.${PN} 17 install -d ${D}${bindir}
18 mv ${D}${bindir}/nc ${D}${bindir}/nc.${PN}
18} 19}
19
20ALTERNATIVE_${PN} = "nc"
21ALTERNATIVE_PRIORITY = "100" 20ALTERNATIVE_PRIORITY = "100"