summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-04-25 09:13:41 +0000
committerKhem Raj <raj.khem@gmail.com>2019-04-29 10:13:56 -0700
commit6294e0e6bc55d71f2fafab8e90924bd2a34a061c (patch)
tree0e6c7a12e0915f917f27d3eb00dea0ce95b2d9ac
parenta687e017604db0f00a2c486b52825e75f9dd48ee (diff)
downloadmeta-openembedded-6294e0e6bc55d71f2fafab8e90924bd2a34a061c.tar.gz
libopus: use armv7a, aarch64 overrides when adding ne10 dependency
* to match what ne10 recipe does now * fixes: ERROR: Nothing PROVIDES 'ne10' (but meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb DEPENDS on or otherwise requires it) ne10 was skipped: incompatible with machine qemuarm (not in COMPATIBLE_MACHINE) ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'libopus', 'ne10'] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb b/meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb
index dd6789dc0..50d49370b 100644
--- a/meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb
+++ b/meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb
@@ -28,13 +28,13 @@ EXTRA_OECONF = " \
28 --enable-custom-modes \ 28 --enable-custom-modes \
29" 29"
30 30
31# ne10 is available only for armv7a and aarch64
32DEPENDS_append_aarch64 = " ne10"
33DEPENDS_append_armv7a = " ne10"
34
31python () { 35python () {
32 if d.getVar('TARGET_FPU') in [ 'soft' ]: 36 if d.getVar('TARGET_FPU') in [ 'soft' ]:
33 d.appendVar('PACKAGECONFIG', ' fixed-point') 37 d.appendVar('PACKAGECONFIG', ' fixed-point')
34
35 # Ne10 is only available for armv7 and aarch64
36 if any((t.startswith('armv7') or t.startswith('aarch64')) for t in d.getVar('TUNE_FEATURES').split()):
37 d.appendVar('DEPENDS', ' ne10')
38} 38}
39 39
40# Fails to build with thumb-1 (qemuarm) 40# Fails to build with thumb-1 (qemuarm)