summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2019-04-25 19:10:31 -0700
committerKhem Raj <raj.khem@gmail.com>2019-04-29 10:13:57 -0700
commit50108c18e5ca21cc5c014a45b81c66c5b110fc8b (patch)
treefb1c1e585a1a24c064c6422a47becd24ebada7a2
parent57967659f4724a8b614faa7fceec79bee5701b99 (diff)
downloadmeta-openembedded-50108c18e5ca21cc5c014a45b81c66c5b110fc8b.tar.gz
libdbd-mysql-perl: Upgrade to 4.050
Update homepage and make SRC_URI to fetch from git. Remove one backported patch. Add libdev-checklib-perl-native to DEPENDS as the new libdbd-mysql-perl depends on another module (Devel::CheckLib) at configure time. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/perl/libdbd-mysql-perl/0001-Use-API-function-for-reconnect.patch53
-rw-r--r--meta-oe/recipes-devtools/perl/libdbd-mysql-perl_4.050.bb (renamed from meta-oe/recipes-devtools/perl/libdbd-mysql-perl_4.043.bb)14
2 files changed, 5 insertions, 62 deletions
diff --git a/meta-oe/recipes-devtools/perl/libdbd-mysql-perl/0001-Use-API-function-for-reconnect.patch b/meta-oe/recipes-devtools/perl/libdbd-mysql-perl/0001-Use-API-function-for-reconnect.patch
deleted file mode 100644
index 60d88c3d1..000000000
--- a/meta-oe/recipes-devtools/perl/libdbd-mysql-perl/0001-Use-API-function-for-reconnect.patch
+++ /dev/null
@@ -1,53 +0,0 @@
1From edb6b202b7e233864aa5dd84532646c50097b0b8 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Mon, 4 Mar 2019 00:49:17 -0800
4Subject: [PATCH] Use API function for reconnect
5
6For configuring reconnect functionality use standard API function
7MYSQL_OPT_RECONNECT instead of direct modification of internal structures
8which does not work for MariaDB. Fixes compilation with MariaDB 10.2.6+.
9
10Upstream-Status: Backport [https://github.com/perl5-dbi/DBD-mysql/commit/0b1884f4153d3de0a91bae4d3b3cc1771ffdf4f3]
11
12Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
13---
14 dbdimp.c | 16 ++++++++++------
15 1 file changed, 10 insertions(+), 6 deletions(-)
16
17diff --git a/dbdimp.c b/dbdimp.c
18index 9b8b313..3bed213 100644
19--- a/dbdimp.c
20+++ b/dbdimp.c
21@@ -1979,6 +1979,16 @@ MYSQL *mysql_dr_connect(
22
23 if (result)
24 {
25+ /*
26+ we turn off Mysql's auto reconnect and handle re-connecting ourselves
27+ so that we can keep track of when this happens.
28+ */
29+#if MYSQL_VERSION_ID >= 50013
30+ my_bool reconnect = FALSE;
31+ mysql_options(result, MYSQL_OPT_RECONNECT, &reconnect);
32+#else
33+ result->reconnect = 0;
34+#endif
35 #if MYSQL_VERSION_ID >=SERVER_PREPARE_VERSION
36 /* connection succeeded. */
37 /* imp_dbh == NULL when mysql_dr_connect() is called from mysql.xs
38@@ -1992,12 +2002,6 @@ MYSQL *mysql_dr_connect(
39 imp_dbh->async_query_in_flight = NULL;
40 }
41 #endif
42-
43- /*
44- we turn off Mysql's auto reconnect and handle re-connecting ourselves
45- so that we can keep track of when this happens.
46- */
47- result->reconnect=0;
48 }
49 else {
50 /*
51--
522.17.1
53
diff --git a/meta-oe/recipes-devtools/perl/libdbd-mysql-perl_4.043.bb b/meta-oe/recipes-devtools/perl/libdbd-mysql-perl_4.050.bb
index e185f48f7..049dc665d 100644
--- a/meta-oe/recipes-devtools/perl/libdbd-mysql-perl_4.043.bb
+++ b/meta-oe/recipes-devtools/perl/libdbd-mysql-perl_4.050.bb
@@ -6,21 +6,17 @@ with the MySQL relational database management system. Most functions \
6provided by this programming API are supported. Some rarely used \ 6provided by this programming API are supported. Some rarely used \
7functions are missing, mainly because no-one ever requested them. \ 7functions are missing, mainly because no-one ever requested them. \
8" 8"
9HOMEPAGE = "http://search.cpan.org/~michielb/DBD-mysql-4.036/lib/DBD/mysql.pm" 9HOMEPAGE = "https://github.com/perl5-dbi/DBD-mysql"
10 10
11SECTION = "libs" 11SECTION = "libs"
12LICENSE = "Artistic-1.0 | GPL-1.0+" 12LICENSE = "Artistic-1.0 | GPL-1.0+"
13DEPENDS += "libdbi-perl-native libmysqlclient" 13DEPENDS += "libdev-checklib-perl-native libdbi-perl-native libmysqlclient"
14 14
15LIC_FILES_CHKSUM = "file://LICENSE;md5=d0a06964340e5c0cde88b7af611f755c" 15LIC_FILES_CHKSUM = "file://LICENSE;md5=d0a06964340e5c0cde88b7af611f755c"
16 16
17SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MICHIELB/DBD-mysql-${PV}.tar.gz \ 17SRCREV = "9b5b70ea372f49fe9bc9e592dae3870596d1e3d6"
18 file://0001-Use-API-function-for-reconnect.patch \ 18SRC_URI = "git://github.com/perl5-dbi/DBD-mysql.git;protocol=https"
19"
20
21SRC_URI[md5sum] = "4a00dd7f1c057931147c65dfc4901c36"
22SRC_URI[sha256sum] = "629f865e8317f52602b2f2efd2b688002903d2e4bbcba5427cb6188b043d6f99"
23 19
24S = "${WORKDIR}/DBD-mysql-${PV}" 20S = "${WORKDIR}/git"
25 21
26inherit cpan 22inherit cpan