diff options
author | Derek Straka <derek@asterius.io> | 2017-11-01 12:41:24 -0400 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-11-15 16:31:31 -0800 |
commit | 2b6ae2d951df1050bf4fe0734ece750d0fef2faf (patch) | |
tree | d4f39f8b20316463039d445e3d2706fcfff7fcae | |
parent | bd827cb9ff57b8e42768add8e8b206c95cd6aea2 (diff) | |
download | meta-openembedded-2b6ae2d951df1050bf4fe0734ece750d0fef2faf.tar.gz |
python-automat: add an initial recipe for version 0.6.0
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
3 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-automat.inc b/meta-python/recipes-devtools/python/python-automat.inc new file mode 100644 index 000000000..1ac5d3b32 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-automat.inc | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "Self-service finite-state machines for the programmer on the go" | ||
2 | HOMEPAGE = "https://github.com/glyph/Automat" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477" | ||
5 | |||
6 | SRC_URI[md5sum] = "ad7bba58d262d8956d732330cb5ef53d" | ||
7 | SRC_URI[sha256sum] = "3c1fd04ecf08ac87b4dd3feae409542e9bf7827257097b2b6ed5692f69d6f6a8" | ||
8 | |||
9 | PYPI_PACKAGE = "Automat" | ||
10 | |||
11 | inherit pypi | ||
12 | |||
13 | RDEPENDS_${PN} += "\ | ||
14 | ${PYTHON_PN}-attrs \ | ||
15 | ${PYTHON_PN}-six \ | ||
16 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-automat_0.6.0.bb b/meta-python/recipes-devtools/python/python-automat_0.6.0.bb new file mode 100644 index 000000000..8ac8c9c0f --- /dev/null +++ b/meta-python/recipes-devtools/python/python-automat_0.6.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-automat.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-automat_0.6.0.bb b/meta-python/recipes-devtools/python/python3-automat_0.6.0.bb new file mode 100644 index 000000000..0469e6138 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-automat_0.6.0.bb | |||
@@ -0,0 +1,4 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-automat.inc | ||
3 | |||
4 | RDEPENDS_${PN} += "${PYTHON_PN}-enum " | ||