summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-08-12 07:34:32 +0000
committerArmin Kuster <akuster808@gmail.com>2019-09-02 19:39:29 -0700
commit15b369f6e158e1b241d6c674a080287ddb623c00 (patch)
treee866e3358852621cb39593f1b25d420d5715afa0
parentdbf9ffc3a3b2b59c46db1c74eeaafb2c1c99d459 (diff)
downloadmeta-openembedded-15b369f6e158e1b241d6c674a080287ddb623c00.tar.gz
ntop: fix missing return from non-void function
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/ntop/ntop/fix-missing-return-from-non-void-function.patch19
-rw-r--r--meta-networking/recipes-support/ntop/ntop_5.0.1.bb1
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntop/ntop/fix-missing-return-from-non-void-function.patch b/meta-networking/recipes-support/ntop/ntop/fix-missing-return-from-non-void-function.patch
new file mode 100644
index 000000000..e627e59a5
--- /dev/null
+++ b/meta-networking/recipes-support/ntop/ntop/fix-missing-return-from-non-void-function.patch
@@ -0,0 +1,19 @@
1Fix following error:
2
3netflowPlugin.c: In function 'netflowUtilsLoop':
4netflowPlugin.c:2144:1: error: no return statement in function returning non-void [-Werror=return-type]
5 2144 | }
6 | ^
7
8Return NULL like netflowMainLoop does.
9
10--- ntop-5.0.1.orig/plugins/netflowPlugin.c 2012-03-09 17:44:17.000000000 +0000
11+++ ntop-5.0.1/plugins/netflowPlugin.c 2019-08-09 10:25:40.878799852 +0000
12@@ -2141,6 +2141,7 @@
13 waitCondvar(&myGlobals.device[deviceId].netflowGlobals->ifStatsQueueCondvar);
14 }
15 }
16+ return(NULL);
17 }
18 #endif
19
diff --git a/meta-networking/recipes-support/ntop/ntop_5.0.1.bb b/meta-networking/recipes-support/ntop/ntop_5.0.1.bb
index 2a7a7f2cb..80f009b7c 100644
--- a/meta-networking/recipes-support/ntop/ntop_5.0.1.bb
+++ b/meta-networking/recipes-support/ntop/ntop_5.0.1.bb
@@ -18,6 +18,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/ntop/ntop-${PV}.tar.gz \
18 file://use-static-inline.patch \ 18 file://use-static-inline.patch \
19 file://0001-nDPI-Include-sys-types.h.patch \ 19 file://0001-nDPI-Include-sys-types.h.patch \
20 file://0001-plugins-Makefile.am-fix-for-automake-1.16.1.patch \ 20 file://0001-plugins-Makefile.am-fix-for-automake-1.16.1.patch \
21 file://fix-missing-return-from-non-void-function.patch \
21 " 22 "
22SRC_URI[md5sum] = "01710b6925a8a5ffe1a41b8b512ebd69" 23SRC_URI[md5sum] = "01710b6925a8a5ffe1a41b8b512ebd69"
23SRC_URI[sha256sum] = "7e8e84cb14d2173beaca4d4cb991a14d84a4bef84ec37b2276bc363f45c52ef8" 24SRC_URI[sha256sum] = "7e8e84cb14d2173beaca4d4cb991a14d84a4bef84ec37b2276bc363f45c52ef8"