diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-05 16:32:53 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-06 12:40:28 +0200 |
commit | a6c172e2713f0018c5ebac0f957cff28b7ac2630 (patch) | |
tree | 6f2ccb3c4c1b4977c44df5b9b1763fcf1d3aab2d | |
parent | 9087a59b1c3f9708642a2327b0cf6ecceac0a66f (diff) | |
download | meta-openembedded-a6c172e2713f0018c5ebac0f957cff28b7ac2630.tar.gz |
poppler: add --std=c++11 to fix build with Qt 5.7
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler/0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch | 39 | ||||
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler_0.41.0.bb | 4 |
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler/0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch b/meta-oe/recipes-support/poppler/poppler/0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch new file mode 100644 index 000000000..d5c34a6a0 --- /dev/null +++ b/meta-oe/recipes-support/poppler/poppler/0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From a8e3399487258e53df0fd4a79c570c8d71188bed Mon Sep 17 00:00:00 2001 | ||
2 | From: Takahiro Hashimoto <kenya888.en@gmail.com> | ||
3 | Date: Wed, 27 Apr 2016 00:16:52 +0200 | ||
4 | Subject: [PATCH] Compile with C++11 compilers that don't define isinfinite | ||
5 | |||
6 | Bug #94761 | ||
7 | --- | ||
8 | poppler/SplashOutputDev.cc | 8 ++++++++ | ||
9 | 1 file changed, 8 insertions(+) | ||
10 | |||
11 | diff --git a/poppler/SplashOutputDev.cc b/poppler/SplashOutputDev.cc | ||
12 | index 13d090c..0e50702 100644 | ||
13 | --- a/poppler/SplashOutputDev.cc | ||
14 | +++ b/poppler/SplashOutputDev.cc | ||
15 | @@ -36,6 +36,7 @@ | ||
16 | // Copyright (C) 2014 Richard PALO <richard@netbsd.org> | ||
17 | // Copyright (C) 2015 Tamas Szekeres <szekerest@gmail.com> | ||
18 | // Copyright (C) 2015 Kenji Uno <ku@digitaldolphins.jp> | ||
19 | +// Copyright (C) 2016 Takahiro Hashimoto <kenya888.en@gmail.com> | ||
20 | // | ||
21 | // To see a description of the changes please see the Changelog file that | ||
22 | // came with your tarball or type make ChangeLog if you are building from git | ||
23 | @@ -94,6 +95,13 @@ extern "C" int unlink(char *filename); | ||
24 | #endif | ||
25 | #endif | ||
26 | |||
27 | +#if __cplusplus > 199711L | ||
28 | +#include <cmath> | ||
29 | +#ifndef isfinite | ||
30 | +#define isfinite(x) std::isfinite(x) | ||
31 | +#endif | ||
32 | +#endif | ||
33 | + | ||
34 | static inline void convertGfxColor(SplashColorPtr dest, | ||
35 | SplashColorMode colorMode, | ||
36 | GfxColorSpace *colorSpace, | ||
37 | -- | ||
38 | 2.8.2 | ||
39 | |||
diff --git a/meta-oe/recipes-support/poppler/poppler_0.41.0.bb b/meta-oe/recipes-support/poppler/poppler_0.41.0.bb index 432040846..f7cc07681 100644 --- a/meta-oe/recipes-support/poppler/poppler_0.41.0.bb +++ b/meta-oe/recipes-support/poppler/poppler_0.41.0.bb | |||
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | |||
5 | SRC_URI = " \ | 5 | SRC_URI = " \ |
6 | http://poppler.freedesktop.org/${BP}.tar.xz \ | 6 | http://poppler.freedesktop.org/${BP}.tar.xz \ |
7 | file://0001-add-manadatory-options-to-find-qt4-qt5-moc.patch \ | 7 | file://0001-add-manadatory-options-to-find-qt4-qt5-moc.patch \ |
8 | file://0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch \ | ||
8 | " | 9 | " |
9 | SRC_URI[md5sum] = "849a8bd6af5794efb961b70418414e5a" | 10 | SRC_URI[md5sum] = "849a8bd6af5794efb961b70418414e5a" |
10 | SRC_URI[sha256sum] = "420abaab63caed9e1ee28964a0ba216d1979506726164bc99ad5ade289192a1b" | 11 | SRC_URI[sha256sum] = "420abaab63caed9e1ee28964a0ba216d1979506726164bc99ad5ade289192a1b" |
@@ -22,6 +23,9 @@ PACKAGECONFIG[openjpeg] = "--enable-libopenjpeg=openjpeg2,--disable-libopenjpeg, | |||
22 | PACKAGECONFIG[qt5] = "--enable-poppler-qt5 --with-moc-qt5=${STAGING_BINDIR_NATIVE}/qt5/moc,--disable-poppler-qt5,qtbase" | 23 | PACKAGECONFIG[qt5] = "--enable-poppler-qt5 --with-moc-qt5=${STAGING_BINDIR_NATIVE}/qt5/moc,--disable-poppler-qt5,qtbase" |
23 | PACKAGECONFIG[qt4e] = "--enable-poppler-qt4 --with-moc-qt4=${STAGING_BINDIR_NATIVE}/moc4,--disable-poppler-qt4,qt4-embedded" | 24 | PACKAGECONFIG[qt4e] = "--enable-poppler-qt4 --with-moc-qt4=${STAGING_BINDIR_NATIVE}/moc4,--disable-poppler-qt4,qt4-embedded" |
24 | 25 | ||
26 | # Needed for qt5 | ||
27 | CXXFLAGS += "--std=c++11" | ||
28 | |||
25 | EXTRA_OECONF = "\ | 29 | EXTRA_OECONF = "\ |
26 | --enable-xpdf-headers \ | 30 | --enable-xpdf-headers \ |
27 | --disable-gtk-test \ | 31 | --disable-gtk-test \ |