diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2012-10-12 10:13:12 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-10-19 11:42:13 +0200 |
commit | 8402b7ac0f2e3b0afd9d56e16e7935e1887c7698 (patch) | |
tree | a91a90f104a11aa51c5abc40c3dfd4972f735881 | |
parent | 4cd60deb11a8a6f9134d7f6ec39255a35d921426 (diff) | |
download | meta-openembedded-8402b7ac0f2e3b0afd9d56e16e7935e1887c7698.tar.gz |
PACKAGES_DYNAMIC: use regexp not glob
* bitbake uses PACKAGES_DYNAMIC as regexp
^ could make matching faster (and it will be more clear that we're expecting regexp not glob)
* made all those last '-' optional, use .* (or nothing)
* use += instead of = in most cases to keep ${PN}-locale from
bitbake.conf:PACKAGES_DYNAMIC = "^${PN}-locale-.*"
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
17 files changed, 17 insertions, 17 deletions
diff --git a/meta-efl/recipes-efl/efl/evas-generic-loaders.inc b/meta-efl/recipes-efl/efl/evas-generic-loaders.inc index 7556eb2ac..cb1133490 100644 --- a/meta-efl/recipes-efl/efl/evas-generic-loaders.inc +++ b/meta-efl/recipes-efl/efl/evas-generic-loaders.inc | |||
@@ -30,4 +30,4 @@ python populate_packages_prepend () { | |||
30 | FILES_evas-generic-loader-xcf += "${libdir}/evas/utils/*.xcf.gz" | 30 | FILES_evas-generic-loader-xcf += "${libdir}/evas/utils/*.xcf.gz" |
31 | FILES_${PN}-dbg += "${libdir}/evas/utils/.debug" | 31 | FILES_${PN}-dbg += "${libdir}/evas/utils/.debug" |
32 | 32 | ||
33 | PACKAGES_DYNAMIC = "evas-generic-loader-*" | 33 | PACKAGES_DYNAMIC += "^evas-generic-loader-.*" |
diff --git a/meta-efl/recipes-efl/efl/evas.inc b/meta-efl/recipes-efl/efl/evas.inc index b0ec0cf75..e3e5d39cd 100644 --- a/meta-efl/recipes-efl/efl/evas.inc +++ b/meta-efl/recipes-efl/efl/evas.inc | |||
@@ -40,7 +40,7 @@ FILES_${PN}-dbg += "${libdir}/evas/modules/*/*/*/.debug/ ${libdir}/evas/cserve2/ | |||
40 | FILES_${PN}-cserve2 += "${libexecdir}/evas_cserve2* ${libexecdir}/dummy_slave" | 40 | FILES_${PN}-cserve2 += "${libexecdir}/evas_cserve2* ${libexecdir}/dummy_slave" |
41 | 41 | ||
42 | PACKAGES += "${PN}-cserve2" | 42 | PACKAGES += "${PN}-cserve2" |
43 | PACKAGES_DYNAMIC = "evas-engine-* evas-loader-* evas-saver-* evas-cserve2-*" | 43 | PACKAGES_DYNAMIC += "^evas-engine-.* ^evas-loader-.* ^evas-saver-.* ^evas-cserve2-.*" |
44 | 44 | ||
45 | # evas-loader-svg is gone as we don't have esvg and probably won't have anytime soon | 45 | # evas-loader-svg is gone as we don't have esvg and probably won't have anytime soon |
46 | # http://www.intesis.hr/news/16-esvg-source | 46 | # http://www.intesis.hr/news/16-esvg-source |
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb index 8c3aab455..60b970bab 100644 --- a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb +++ b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb | |||
@@ -99,7 +99,7 @@ FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/AbiWord/strings" | |||
99 | FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*" | 99 | FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*" |
100 | FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates" | 100 | FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates" |
101 | 101 | ||
102 | PACKAGES_DYNAMIC = "${PN}-meta ${PN}-plugin-*" | 102 | PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*" |
103 | 103 | ||
104 | python populate_packages_prepend () { | 104 | python populate_packages_prepend () { |
105 | abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d) | 105 | abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d) |
diff --git a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb index 586eed84f..46be86fce 100644 --- a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb +++ b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb | |||
@@ -40,7 +40,7 @@ FILES_${PN}-dbg += " ${libdir}/gnome-vfs-2.0/modules/.debug" | |||
40 | FILES_${PN}-dev += " ${libdir}/gnome-vfs-2.0/include" | 40 | FILES_${PN}-dev += " ${libdir}/gnome-vfs-2.0/include" |
41 | FILES_${PN}-doc += " ${datadir}/gtk-doc" | 41 | FILES_${PN}-doc += " ${datadir}/gtk-doc" |
42 | 42 | ||
43 | PACKAGES_DYNAMIC = "gnome-vfs-plugin-*" | 43 | PACKAGES_DYNAMIC += "^gnome-vfs-plugin-.*" |
44 | 44 | ||
45 | python populate_packages_prepend () { | 45 | python populate_packages_prepend () { |
46 | print bb.data.getVar('FILES_gnome-vfs', d, 1) | 46 | print bb.data.getVar('FILES_gnome-vfs', d, 1) |
diff --git a/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb b/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb index c1f535bd4..32b54ef0c 100644 --- a/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb +++ b/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb | |||
@@ -72,7 +72,7 @@ FILES_${PN}-dbg += " \ | |||
72 | ${libdir}/gtk-3.0/modules/.debug" | 72 | ${libdir}/gtk-3.0/modules/.debug" |
73 | 73 | ||
74 | 74 | ||
75 | PACKAGES_DYNAMIC += "gtk3-immodule-* gtk3-printbackend-*" | 75 | PACKAGES_DYNAMIC += "^gtk3-immodule-.* ^gtk3-printbackend-.*" |
76 | 76 | ||
77 | python populate_packages_prepend () { | 77 | python populate_packages_prepend () { |
78 | import os.path | 78 | import os.path |
diff --git a/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb index c55a8acf6..4b6473149 100644 --- a/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb +++ b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb | |||
@@ -36,7 +36,7 @@ FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} | |||
36 | ${datadir}/idl ${datadir}/omf ${datadir}/sounds \ | 36 | ${datadir}/idl ${datadir}/omf ${datadir}/sounds \ |
37 | ${libdir}/bonobo/servers" | 37 | ${libdir}/bonobo/servers" |
38 | 38 | ||
39 | PACKAGES_DYNAMIC = "goffice-plugin-*" | 39 | PACKAGES_DYNAMIC += "^goffice-plugin-.*" |
40 | 40 | ||
41 | python populate_packages_prepend () { | 41 | python populate_packages_prepend () { |
42 | goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d) | 42 | goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d) |
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc-utils.inc b/meta-initramfs/recipes-devtools/klibc/klibc-utils.inc index cd55dc2ee..2190ca29c 100644 --- a/meta-initramfs/recipes-devtools/klibc/klibc-utils.inc +++ b/meta-initramfs/recipes-devtools/klibc/klibc-utils.inc | |||
@@ -92,7 +92,7 @@ RDEPENDS_klibc-utils-true = "${THIS_LIBKLIBC}" | |||
92 | RDEPENDS_klibc-utils-umount = "${THIS_LIBKLIBC}" | 92 | RDEPENDS_klibc-utils-umount = "${THIS_LIBKLIBC}" |
93 | RDEPENDS_klibc-utils-uname = "${THIS_LIBKLIBC}" | 93 | RDEPENDS_klibc-utils-uname = "${THIS_LIBKLIBC}" |
94 | 94 | ||
95 | PACKAGES_DYNAMIC = "${KLIBC_UTILS_PKGNAME}-*" | 95 | PACKAGES_DYNAMIC += "^${KLIBC_UTILS_PKGNAME}-.*" |
96 | 96 | ||
97 | python populate_packages_prepend () { | 97 | python populate_packages_prepend () { |
98 | 98 | ||
diff --git a/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb b/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb index 00030d3b2..c2f1cc82e 100644 --- a/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb +++ b/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb | |||
@@ -35,7 +35,7 @@ python populate_packages_prepend() { | |||
35 | 35 | ||
36 | PACKAGES =+ "${PN}-gtk" | 36 | PACKAGES =+ "${PN}-gtk" |
37 | 37 | ||
38 | PACKAGES_DYNAMIC = "libcanberra-*" | 38 | PACKAGES_DYNAMIC += "^libcanberra-.*" |
39 | 39 | ||
40 | FILES_${PN}-gtk = "\ | 40 | FILES_${PN}-gtk = "\ |
41 | ${sysconfdir}/gconf \ | 41 | ${sysconfdir}/gconf \ |
diff --git a/meta-oe/recipes-extended/lcdproc/lcdproc5.inc b/meta-oe/recipes-extended/lcdproc/lcdproc5.inc index 50b6b0efb..76669be2e 100644 --- a/meta-oe/recipes-extended/lcdproc/lcdproc5.inc +++ b/meta-oe/recipes-extended/lcdproc/lcdproc5.inc | |||
@@ -73,5 +73,5 @@ python populate_packages_prepend() { | |||
73 | do_split_packages(d, plugindir, '(.*)\.so$', 'lcdd-driver-%s', 'LCDd driver for %s', prepend=True) | 73 | do_split_packages(d, plugindir, '(.*)\.so$', 'lcdd-driver-%s', 'LCDd driver for %s', prepend=True) |
74 | } | 74 | } |
75 | 75 | ||
76 | PACKAGES_DYNAMIC = "lcdd-driver-*" | 76 | PACKAGES_DYNAMIC += "^lcdd-driver-.*" |
77 | 77 | ||
diff --git a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb index 0d0388988..8e842c48f 100644 --- a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb +++ b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb | |||
@@ -20,7 +20,7 @@ EXTRA_OECONF += "--with-plugins=none" | |||
20 | 20 | ||
21 | PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome" | 21 | PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome" |
22 | 22 | ||
23 | PACKAGES_DYNAMIC += "${PN}-theme-*" | 23 | PACKAGES_DYNAMIC += "^${PN}-theme-.*" |
24 | 24 | ||
25 | python populate_packages_prepend() { | 25 | python populate_packages_prepend() { |
26 | theme_dir = bb.data.expand('${datadir}/themes/', d) | 26 | theme_dir = bb.data.expand('${datadir}/themes/', d) |
diff --git a/meta-oe/recipes-multimedia/libav/libav.inc b/meta-oe/recipes-multimedia/libav/libav.inc index 4a1716f3a..0e80430eb 100644 --- a/meta-oe/recipes-multimedia/libav/libav.inc +++ b/meta-oe/recipes-multimedia/libav/libav.inc | |||
@@ -119,4 +119,4 @@ python populate_packages_prepend() { | |||
119 | allow_links=True) | 119 | allow_links=True) |
120 | } | 120 | } |
121 | 121 | ||
122 | PACKAGES_DYNAMIC = "lib(av(codec|device|filter|format|util)|postproc)*" | 122 | PACKAGES_DYNAMIC += "^lib(av(codec|device|filter|format|util)|postproc).*" |
diff --git a/meta-oe/recipes-support/freerdp/freerdp.inc b/meta-oe/recipes-support/freerdp/freerdp.inc index 46aecf613..673b37240 100644 --- a/meta-oe/recipes-support/freerdp/freerdp.inc +++ b/meta-oe/recipes-support/freerdp/freerdp.inc | |||
@@ -23,7 +23,7 @@ PACKAGES =+ "libfreerdp" | |||
23 | LEAD_SONAME = "libfreerdp.so" | 23 | LEAD_SONAME = "libfreerdp.so" |
24 | FILES_libfreerdp = "${libdir}/lib*${SOLIBS}" | 24 | FILES_libfreerdp = "${libdir}/lib*${SOLIBS}" |
25 | 25 | ||
26 | PACKAGES_DYNAMIC = "libfreerdp-plugin-*" | 26 | PACKAGES_DYNAMIC += "^libfreerdp-plugin-.*" |
27 | 27 | ||
28 | python populate_packages_prepend () { | 28 | python populate_packages_prepend () { |
29 | freerdp_root = bb.data.expand('${libdir}/freerdp', d) | 29 | freerdp_root = bb.data.expand('${libdir}/freerdp', d) |
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.23.bb b/meta-oe/recipes-support/openldap/openldap_2.4.23.bb index 3ef12d3a1..8d9bd6c6b 100644 --- a/meta-oe/recipes-support/openldap/openldap_2.4.23.bb +++ b/meta-oe/recipes-support/openldap/openldap_2.4.23.bb | |||
@@ -249,7 +249,7 @@ pkg_prerm_${PN}-slapd () { | |||
249 | update-rc.d $D openldap remove | 249 | update-rc.d $D openldap remove |
250 | } | 250 | } |
251 | 251 | ||
252 | PACKAGES_DYNAMIC = "openldap-backends openldap-backend-*" | 252 | PACKAGES_DYNAMIC += "^openldap-backends.* ^openldap-backend-.*" |
253 | 253 | ||
254 | python populate_packages_prepend () { | 254 | python populate_packages_prepend () { |
255 | backend_dir = bb.data.expand('${libexecdir}/openldap', d) | 255 | backend_dir = bb.data.expand('${libexecdir}/openldap', d) |
diff --git a/meta-oe/recipes-support/pidgin/pidgin.inc b/meta-oe/recipes-support/pidgin/pidgin.inc index 90e2fd4b6..cb2a59799 100644 --- a/meta-oe/recipes-support/pidgin/pidgin.inc +++ b/meta-oe/recipes-support/pidgin/pidgin.inc | |||
@@ -56,7 +56,7 @@ RRECOMMENDS_${PN} = "${PN}-data libpurple-plugin-ssl-gnutls libpurple-protocol-i | |||
56 | FILES_${PN}-data = "${datadir}/pixmaps ${datadir}/sounds ${datadir}/icons" | 56 | FILES_${PN}-data = "${datadir}/pixmaps ${datadir}/sounds ${datadir}/icons" |
57 | FILES_${PN}-dev += "${libdir}/${PN}/*.la" | 57 | FILES_${PN}-dev += "${libdir}/${PN}/*.la" |
58 | 58 | ||
59 | PACKAGES_DYNAMIC = "libpurple-protocol-* libpurple-plugin-* pidgin-plugin-* finch-plugin-*" | 59 | PACKAGES_DYNAMIC += "^libpurple-protocol-.* ^libpurple-plugin-.* ^pidgin-plugin-.* ^finch-plugin-.*" |
60 | 60 | ||
61 | python populate_packages_prepend () { | 61 | python populate_packages_prepend () { |
62 | pidgroot = bb.data.expand('${libdir}/pidgin', d) | 62 | pidgroot = bb.data.expand('${libdir}/pidgin', d) |
diff --git a/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb b/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb index c018cb528..1826dd23a 100644 --- a/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb +++ b/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb | |||
@@ -16,4 +16,4 @@ python populate_packages_prepend () { | |||
16 | do_split_packages(d, themedir, '^(.*)', 'xfwm4-old-theme-%s', 'XFWM4 theme %s', allow_dirs=True) | 16 | do_split_packages(d, themedir, '^(.*)', 'xfwm4-old-theme-%s', 'XFWM4 theme %s', allow_dirs=True) |
17 | } | 17 | } |
18 | 18 | ||
19 | PACKAGES_DYNAMIC += "xfwm4-old-theme-*" | 19 | PACKAGES_DYNAMIC += "^xfwm4-old-theme-.*" |
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb index 5d034258e..bb914ba8d 100644 --- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb +++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb | |||
@@ -20,7 +20,7 @@ python populate_packages_prepend() { | |||
20 | '${bindir}/*%s*']) | 20 | '${bindir}/*%s*']) |
21 | } | 21 | } |
22 | 22 | ||
23 | PACKAGES_DYNAMIC = "${PN}-plugin-*" | 23 | PACKAGES_DYNAMIC += "^${PN}-plugin-.*" |
24 | 24 | ||
25 | FILES_${PN} += "${libdir}/xfce4/panel/migrate \ | 25 | FILES_${PN} += "${libdir}/xfce4/panel/migrate \ |
26 | ${libdir}/xfce4/panel/wrapper" | 26 | ${libdir}/xfce4/panel/wrapper" |
diff --git a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.0.bb b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.0.bb index 049ac6fb6..f17d4e505 100644 --- a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.0.bb +++ b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.0.bb | |||
@@ -14,7 +14,7 @@ python populate_packages_prepend () { | |||
14 | do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True) | 14 | do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True) |
15 | } | 15 | } |
16 | 16 | ||
17 | PACKAGES_DYNAMIC += "xfwm4-theme-*" | 17 | PACKAGES_DYNAMIC += "^xfwm4-theme-.*" |
18 | 18 | ||
19 | ALTERNATIVE_${PN} = "x-window-manager" | 19 | ALTERNATIVE_${PN} = "x-window-manager" |
20 | ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/xfwm4" | 20 | ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/xfwm4" |