diff options
author | Ross Burton <ross.burton@intel.com> | 2016-11-23 14:13:39 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-12-02 09:16:18 +0100 |
commit | 533826b7652a2cf86ca7b665c25b98c89afc266e (patch) | |
tree | 95a8341dd6b9f8864c2617086c97f7e1fbb6d615 | |
parent | fc2fc9097b2fa437d4af0338e418692b4dd6c989 (diff) | |
download | meta-openembedded-533826b7652a2cf86ca7b665c25b98c89afc266e.tar.gz |
meta-oe: add explicit dependencies on gnome-common
gnome-common is deprecated and gnomebase.bbclass will soon stop depending on it,
so add gnome-common to DEPENDS for the recipes that still use it.
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb | 3 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libgxim/libgxim_0.5.0.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-gnome/vte9/vte9.inc | 3 |
3 files changed, 3 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb b/meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb index 77416d45b..e490ae50b 100644 --- a/meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb +++ b/meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb | |||
@@ -8,7 +8,7 @@ inherit autotools pkgconfig gnomebase distutils-base gobject-introspection | |||
8 | PYTHON_BASEVERSION = "2.7" | 8 | PYTHON_BASEVERSION = "2.7" |
9 | PYTHON_PN = "python" | 9 | PYTHON_PN = "python" |
10 | 10 | ||
11 | DEPENDS += "python glib-2.0" | 11 | DEPENDS += "gnome-common-native python glib-2.0" |
12 | 12 | ||
13 | SRCNAME="pygobject" | 13 | SRCNAME="pygobject" |
14 | SRC_URI = " \ | 14 | SRC_URI = " \ |
@@ -31,4 +31,3 @@ do_install_append() { | |||
31 | # Remove files that clash with python3-pygobject; their content is same | 31 | # Remove files that clash with python3-pygobject; their content is same |
32 | rm ${D}${includedir}/pygobject-3.0/pygobject.h ${D}${libdir}/pkgconfig/pygobject-3.0.pc | 32 | rm ${D}${includedir}/pygobject-3.0/pygobject.h ${D}${libdir}/pkgconfig/pygobject-3.0.pc |
33 | } | 33 | } |
34 | |||
diff --git a/meta-oe/recipes-extended/libgxim/libgxim_0.5.0.bb b/meta-oe/recipes-extended/libgxim/libgxim_0.5.0.bb index 772babf5b..1d5ae95d9 100644 --- a/meta-oe/recipes-extended/libgxim/libgxim_0.5.0.bb +++ b/meta-oe/recipes-extended/libgxim/libgxim_0.5.0.bb | |||
@@ -20,6 +20,6 @@ LIC_FILES_CHKSUM = "\ | |||
20 | file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1" | 20 | file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1" |
21 | 21 | ||
22 | EXTRA_OECONF = " --disable-static --disable-rebuilds" | 22 | EXTRA_OECONF = " --disable-static --disable-rebuilds" |
23 | DEPENDS += "gtk+ glib-2.0 ruby-native intltool-native" | 23 | DEPENDS += "gtk+ glib-2.0 ruby-native intltool-native gnome-common-native" |
24 | 24 | ||
25 | inherit autotools pkgconfig gettext | 25 | inherit autotools pkgconfig gettext |
diff --git a/meta-oe/recipes-gnome/vte9/vte9.inc b/meta-oe/recipes-gnome/vte9/vte9.inc index 6a5c63cf9..206c430da 100644 --- a/meta-oe/recipes-gnome/vte9/vte9.inc +++ b/meta-oe/recipes-gnome/vte9/vte9.inc | |||
@@ -1,7 +1,7 @@ | |||
1 | SUMMARY = "Virtual terminal emulator GTK+ widget library" | 1 | SUMMARY = "Virtual terminal emulator GTK+ widget library" |
2 | BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte" | 2 | BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte" |
3 | LICENSE = "LGPLv2.0" | 3 | LICENSE = "LGPLv2.0" |
4 | DEPENDS = " glib-2.0 gtk+ intltool-native ncurses" | 4 | DEPENDS = " glib-2.0 gtk+ intltool-native gnome-common-native ncurses" |
5 | RDEPENDS_libvte = "vte-termcap" | 5 | RDEPENDS_libvte = "vte-termcap" |
6 | 6 | ||
7 | # help gnomebase get the SRC_URI correct | 7 | # help gnomebase get the SRC_URI correct |
@@ -16,4 +16,3 @@ EXTRA_OECONF = "--disable-python" | |||
16 | PACKAGES =+ "libvte9 vte9-termcap" | 16 | PACKAGES =+ "libvte9 vte9-termcap" |
17 | FILES_libvte9 = "${libdir}/*.so.* ${libexecdir}/gnome-pty-helper" | 17 | FILES_libvte9 = "${libdir}/*.so.* ${libexecdir}/gnome-pty-helper" |
18 | FILES_vte9-termcap = "${datadir}/vte/termcap-0.0" | 18 | FILES_vte9-termcap = "${datadir}/vte/termcap-0.0" |
19 | |||