summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-02-13 14:52:05 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:45:45 +0100
commit4b84687da0a9c27a2d10cf90719b8b3d55d79035 (patch)
tree78105644833a3c8ea3c1298c39d2f15e30b738ac
parent459571cfa3ceda21688a77cf890dc0641ef52c3d (diff)
downloadmeta-openembedded-4b84687da0a9c27a2d10cf90719b8b3d55d79035.tar.gz
source-han-sans-jp-fonts: initial add 1.004
Based on [1]. [1] https://projects.archlinux.org/svntogit/community.git/tree/trunk?h=packages/adobe-source-han-sans-fonts Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/source-han-sans-jp-fonts/44-source-han-sans-jp.conf19
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/source-han-sans-jp-fonts_1.004.bb34
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-jp-fonts/44-source-han-sans-jp.conf b/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-jp-fonts/44-source-han-sans-jp.conf
new file mode 100644
index 000000000..a7a93feea
--- /dev/null
+++ b/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-jp-fonts/44-source-han-sans-jp.conf
@@ -0,0 +1,19 @@
1<?xml version="1.0" encoding="UTF-8"?>
2<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
3<fontconfig>
4 <!--
5 - Medium variant is used instead of Regular on Qt apps:
6 https://bugs.launchpad.net/ubuntu-font-family/+bug/744812
7 - Medium and Bold looks the same in certain applications:
8 https://bugs.launchpad.net/ubuntu/+source/gnome-specimen/+bug/813373
9 -->
10 <match target="scan">
11 <test name="fullname" compare="eq">
12 <string>Source Han Sans JP Medium</string>
13 </test>
14 <edit name="weight" mode="assign">
15 <const>demibold</const>
16 </edit>
17 </match>
18</fontconfig>
19
diff --git a/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-jp-fonts_1.004.bb b/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-jp-fonts_1.004.bb
new file mode 100644
index 000000000..4a26a2f57
--- /dev/null
+++ b/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-jp-fonts_1.004.bb
@@ -0,0 +1,34 @@
1require ttf.inc
2
3SUMMARY = "Adobe OpenType Pan-CJK font family for Japanese"
4HOMEPAGE = "https://github.com/adobe-fonts/source-han-sans"
5LICENSE = "OFL-1.1"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=55719faa0112708e946b820b24b14097"
7
8inherit allarch fontcache
9
10# Download tends to break - so - or not?
11#EXCLUDE_FROM_WORLD = "1"
12
13SRC_URI = " \
14 https://github.com/adobe-fonts/source-han-sans/raw/release/SubsetOTF/SourceHanSansJP.zip \
15 file://44-source-han-sans-jp.conf \
16"
17SRC_URI[md5sum] = "908fbf97f3df04a6838708c093f1e900"
18SRC_URI[sha256sum] = "dc6dbae3fba35f220bac88ba7130b826c7efe1282f472788fae3628b79be3f54"
19
20S = "${WORKDIR}/SourceHanSansJP"
21
22do_install() {
23 install -d ${D}${sysconfdir}/fonts/conf.d/
24 install -m 0644 ${WORKDIR}/44-source-han-sans-jp.conf ${D}${sysconfdir}/fonts/conf.d/
25
26 install -d ${D}${datadir}/fonts/truetype/
27 find ./ -name '*.otf' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \;
28}
29
30FILES_${PN} = " \
31 ${sysconfdir}/fonts \
32 ${datadir}/fonts \
33"
34