summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-02-04 17:02:03 +0200
committerArmin Kuster <akuster808@gmail.com>2019-03-24 18:44:58 -0700
commitfafc38e4900b3131bc9a6ca538697b1c92925872 (patch)
tree789cf8b4b89830b5e563d97321d8fe3ac420c147
parent8b95f6ad33e4ca2eeba9e20cc8acb0921b1e2a79 (diff)
downloadmeta-openembedded-fafc38e4900b3131bc9a6ca538697b1c92925872.tar.gz
Split ntpq into an own package
ntpq is the standard query program for ntp, but ntp-utils depends on perl. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb
index 53e41297a..289d2645b 100644
--- a/meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb
@@ -105,7 +105,7 @@ do_install_append() {
105 rmdir --ignore-fail-on-non-empty ${D}${libexecdir} 105 rmdir --ignore-fail-on-non-empty ${D}${libexecdir}
106} 106}
107 107
108PACKAGES += "ntpdate sntp ${PN}-tickadj ${PN}-utils" 108PACKAGES += "ntpdate sntp ntpq ${PN}-tickadj ${PN}-utils"
109# NOTE: you don't need ntpdate, use "ntpd -q -g -x" 109# NOTE: you don't need ntpdate, use "ntpd -q -g -x"
110 110
111# ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms 111# ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms
@@ -117,6 +117,8 @@ RDEPENDS_${PN} += "libgcc"
117RPROVIDES_${PN}-utils = "${PN}-bin" 117RPROVIDES_${PN}-utils = "${PN}-bin"
118RREPLACES_${PN}-utils = "${PN}-bin" 118RREPLACES_${PN}-utils = "${PN}-bin"
119RCONFLICTS_${PN}-utils = "${PN}-bin" 119RCONFLICTS_${PN}-utils = "${PN}-bin"
120# ntpq was split out of ntp-utils
121RDEPENDS_${PN}-utils = "ntpq"
120 122
121SYSTEMD_PACKAGES = "${PN} ntpdate sntp" 123SYSTEMD_PACKAGES = "${PN} ntpdate sntp"
122SYSTEMD_SERVICE_${PN} = "ntpd.service" 124SYSTEMD_SERVICE_${PN} = "ntpd.service"
@@ -151,6 +153,7 @@ FILES_sntp = "${sbindir}/sntp \
151 ${sysconfdir}/default/sntp \ 153 ${sysconfdir}/default/sntp \
152 ${systemd_unitdir}/system/sntp.service \ 154 ${systemd_unitdir}/system/sntp.service \
153 " 155 "
156FILES_ntpq = "${sbindir}/ntpq"
154 157
155CONFFILES_${PN} = "${sysconfdir}/ntp.conf" 158CONFFILES_${PN} = "${sysconfdir}/ntp.conf"
156CONFFILES_ntpdate = "${sysconfdir}/default/ntpdate" 159CONFFILES_ntpdate = "${sysconfdir}/default/ntpdate"