diff options
author | Andre McCurdy <armccurdy@gmail.com> | 2016-04-06 18:56:07 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-04-21 21:33:17 +0200 |
commit | cc6b324f1b5318dc4be9c500f2384a73651c0467 (patch) | |
tree | 14aa2f489616a7fc9482eb9be9df6a8a3918dd59 | |
parent | 536d146e08c3c80304c3be3b620acf87341cc3f1 (diff) | |
download | meta-openembedded-cc6b324f1b5318dc4be9c500f2384a73651c0467.tar.gz |
libtinyxml2: update 2.2.0 -> 3.0.0
Also misc recipe cleanup, take license text from tinyxml2.cpp source
file instead of using the entire readme.md, and build using cmake.
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/libtinyxml2/libtinyxml2_3.0.0.bb | 15 | ||||
-rw-r--r-- | meta-oe/recipes-support/libtinyxml2/libtinyxml2_git.bb | 37 |
2 files changed, 15 insertions, 37 deletions
diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_3.0.0.bb b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_3.0.0.bb new file mode 100644 index 000000000..af0b785a6 --- /dev/null +++ b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_3.0.0.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "TinyXML-2 is a simple, small, efficient, C++ XML parser that can be easily integrating into other programs" | ||
2 | HOMEPAGE = "http://www.grinninglizard.com/tinyxml2/" | ||
3 | SECTION = "libs" | ||
4 | LICENSE = "Zlib" | ||
5 | LIC_FILES_CHKSUM = "file://tinyxml2.cpp;endline=22;md5=c19221dbd8a66ad3090462af4c5de5e7" | ||
6 | |||
7 | SRC_URI = "git://github.com/leethomason/tinyxml2.git" | ||
8 | |||
9 | SRCREV = "1977a7258cc66fd4da7f1e9da05a4933646a7803" | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | inherit cmake | ||
14 | |||
15 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_git.bb b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_git.bb deleted file mode 100644 index 6ca6f7cbf..000000000 --- a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_git.bb +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | SUMMARY = "TinyXML-2 is a simple, small, efficient, C++ XML parser that can be easily integrating into other programs." | ||
2 | HOMEPAGE = "http://www.grinninglizard.com/tinyxml2/" | ||
3 | LICENSE = "Zlib" | ||
4 | LIC_FILES_CHKSUM = "file://readme.md;md5=0033b2f8a25283414b21354670bb1334" | ||
5 | SECTION = "libs" | ||
6 | |||
7 | SRCREV = "d211bb13512cf4edb408e2c4badbcf4100ce0fd0" | ||
8 | |||
9 | PV = "2.2.0+git${SRCPV}" | ||
10 | |||
11 | SRC_URI = "git://github.com/leethomason/tinyxml2.git" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | EXTRA_CXXFLAGS = "-I. -fPIC" | ||
16 | |||
17 | do_compile() { | ||
18 | ${CXX} ${CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o tinyxml2.o tinyxml2.cpp | ||
19 | ${CXX} ${CXXFLAGS} \ | ||
20 | -shared \ | ||
21 | -Wl,-soname,libtinyxml2.so.${PV} \ | ||
22 | -o libtinyxml2.so.${PV} \ | ||
23 | ${LDFLAGS} \ | ||
24 | tinyxml2.o | ||
25 | } | ||
26 | |||
27 | do_install() { | ||
28 | install -d ${D}${libdir} | ||
29 | install -m 0755 ${S}/libtinyxml2.so.${PV} ${D}${libdir} | ||
30 | ln -sf libtinyxml2.so.${PV} ${D}${libdir}/libtinyxml2.so | ||
31 | |||
32 | install -d ${D}${includedir} | ||
33 | install -m 0644 ${S}/tinyxml2.h ${D}${includedir} | ||
34 | } | ||
35 | |||
36 | BBCLASSEXTEND += "native" | ||
37 | |||