summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorQian Lei <qianl.fnst@cn.fujitsu.com>2014-12-11 17:36:20 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-19 20:10:55 +0100
commit6781f9b5dc60bbd39727aeaa74c13dd31eb73838 (patch)
treedb4a340412cbc75567286c7ea5a3a05faba9d84f
parent2a1cbf5ca9e5aa9d49bc8779a625f93d70b59487 (diff)
downloadmeta-openembedded-6781f9b5dc60bbd39727aeaa74c13dd31eb73838.tar.gz
lldpad: Add new recipe
LLDPAD contains the Linux user space daemon and configuration tool for Intel LLDP Agent with Enhanced Ethernet support for the Data Center. Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb b/meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb
new file mode 100644
index 000000000..4dad80d3e
--- /dev/null
+++ b/meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Intel LLDP Agent"
2DESCRIPTION = "\
3This package contains the Linux user space daemon and configuration tool for \
4Intel LLDP Agent with Enhanced Ethernet support for the Data Center."
5SECTION = "System Environment/Daemons"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8c2bc283e65df398ced5f5b747e78162"
8DEPENDS = "libconfig libnl"
9SRCREV = "48a5f38778b18d6659a672ccb4640f25c6720827"
10
11SRC_URI = "git://github.com/jrfastab/lldpad.git;protocol=http"
12
13S = "${WORKDIR}/git"
14
15inherit autotools-brokensep pkgconfig systemd
16
17do_install_append () {
18 install -m 0755 -d ${D}${systemd_unitdir}
19 mv ${D}${prefix}${systemd_unitdir}/* ${D}${systemd_unitdir}/
20 rmdir ${D}${prefix}${systemd_unitdir}
21}
22
23FILES_${PN} += "${systemd_unitdir}"