summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-08-30 13:10:07 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-05 10:05:03 +0200
commit605e8f47b2ace1f6c7cb44aef463de10d9f41edd (patch)
treec8a62e5594707860cbcbb5cdaa94ad42ac4cd3f6
parent945134094d2e6bab0978c81c1784c20c185ba842 (diff)
downloadmeta-openembedded-605e8f47b2ace1f6c7cb44aef463de10d9f41edd.tar.gz
terminology: add version 0.1.0, negative D_P to svn and bump PE
* PE bump is needed for upgrade path from svn recipe to 0.1.0 release Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-efl/conf/distro/include/efl-from-svn-recipes.inc2
-rw-r--r--meta-efl/recipes-efl/e17/terminology.inc23
-rw-r--r--meta-efl/recipes-efl/e17/terminology_0.1.0.bb10
-rw-r--r--meta-efl/recipes-efl/e17/terminology_svn.bb22
4 files changed, 38 insertions, 19 deletions
diff --git a/meta-efl/conf/distro/include/efl-from-svn-recipes.inc b/meta-efl/conf/distro/include/efl-from-svn-recipes.inc
index b01764596..c28e281fb 100644
--- a/meta-efl/conf/distro/include/efl-from-svn-recipes.inc
+++ b/meta-efl/conf/distro/include/efl-from-svn-recipes.inc
@@ -37,3 +37,5 @@ PREFERRED_VERSION_python-edbus ?= "${EFL_PYTHON_PREFERRED_VERSION}"
37PREFERRED_VERSION_python-edje ?= "${EFL_PYTHON_PREFERRED_VERSION}" 37PREFERRED_VERSION_python-edje ?= "${EFL_PYTHON_PREFERRED_VERSION}"
38PREFERRED_VERSION_python-emotion ?= "${EFL_PYTHON_PREFERRED_VERSION}" 38PREFERRED_VERSION_python-emotion ?= "${EFL_PYTHON_PREFERRED_VERSION}"
39PREFERRED_VERSION_python-evas ?= "${EFL_PYTHON_PREFERRED_VERSION}" 39PREFERRED_VERSION_python-evas ?= "${EFL_PYTHON_PREFERRED_VERSION}"
40
41PREFERRED_VERSION_terminology ?= "0.1.0+svn%"
diff --git a/meta-efl/recipes-efl/e17/terminology.inc b/meta-efl/recipes-efl/e17/terminology.inc
new file mode 100644
index 000000000..15af6ea50
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/terminology.inc
@@ -0,0 +1,23 @@
1DESCRIPTION = "Enlightenment Terminal Emulator"
2LICENSE = "MIT BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=03f6c2cf2bef233fadf7d0769f5bfda7"
4DEPENDS = "evas ecore edje elementary eina eet emotion"
5
6inherit e gettext
7INC_PR = "r2"
8
9# Because latest release we have is 0.1.0 which sorts lower then 0.1.0+svnr${SRCPV} already in feeds
10PE = "2"
11
12EXTRA_OECONF = "\
13 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
14"
15
16FILES_${PN} += "\
17 ${datadir}/icons/terminology.png \
18"
19
20# doesn't start without own theme
21# ERR<770>:terminology utils.c:26 theme_apply() Could not load any theme for group=terminology/background: No Error
22# CRI<770>:terminology main.c:448 elm_main() Couldn't find terminology theme! Forgot 'make install'?
23RDEPENDS_${PN} += "${PN}-themes"
diff --git a/meta-efl/recipes-efl/e17/terminology_0.1.0.bb b/meta-efl/recipes-efl/e17/terminology_0.1.0.bb
new file mode 100644
index 000000000..7a04069db
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/terminology_0.1.0.bb
@@ -0,0 +1,10 @@
1require ${BPN}.inc
2
3PR = "${INC_PR}.0"
4
5SRC_URI = "\
6 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
7"
8
9SRC_URI[md5sum] = "30867692e44799cd9bbe6562d69ae62d"
10SRC_URI[sha256sum] = "87f32089b2731c3e9a72b5bde92695eb91097fa79dbb70388774c9dcb5442ebb"
diff --git a/meta-efl/recipes-efl/e17/terminology_svn.bb b/meta-efl/recipes-efl/e17/terminology_svn.bb
index 48d229b4e..9fa130412 100644
--- a/meta-efl/recipes-efl/e17/terminology_svn.bb
+++ b/meta-efl/recipes-efl/e17/terminology_svn.bb
@@ -1,25 +1,9 @@
1DESCRIPTION = "Enlightenment Terminal Emulator" 1require ${BPN}.inc
2LICENSE = "MIT BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=03f6c2cf2bef233fadf7d0769f5bfda7"
4DEPENDS = "evas ecore edje elementary eina eet emotion"
5 2
3DEFAULT_PREFERENCE = "-1"
6PV = "0.1.0+svnr${SRCPV}" 4PV = "0.1.0+svnr${SRCPV}"
7PR = "r1" 5PR = "${INC_PR}.0"
8SRCREV = "${EFL_SRCREV}" 6SRCREV = "${EFL_SRCREV}"
9 7
10inherit e gettext
11SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};protocol=http;scmdata=keep" 8SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};protocol=http;scmdata=keep"
12S = "${WORKDIR}/${SRCNAME}" 9S = "${WORKDIR}/${SRCNAME}"
13
14EXTRA_OECONF = "\
15 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
16"
17
18FILES_${PN} += "\
19 ${datadir}/icons/terminology.png \
20"
21
22# doesn't start without own theme
23# ERR<770>:terminology utils.c:26 theme_apply() Could not load any theme for group=terminology/background: No Error
24# CRI<770>:terminology main.c:448 elm_main() Couldn't find terminology theme! Forgot 'make install'?
25RDEPENDS_${PN} += "${PN}-themes"