summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2018-12-12 16:29:38 +0100
committerArmin Kuster <akuster808@gmail.com>2019-02-04 21:37:32 -0800
commit33eb23c379fe66e69e9b6f2978cecca41f27f26d (patch)
treeef72f6046cdca68a1ba78f023033eb4503ee85ce
parent526bf5c5993178cf3609ff220d57ba62dada2ce4 (diff)
downloadmeta-openembedded-33eb23c379fe66e69e9b6f2978cecca41f27f26d.tar.gz
samba: fix build on qemumips64 with musl
There is the same issue as for libldb, the header has conflicting defs for unitptr_t. Fix it as done for the other recipe. Fix /cmocka/cmocka.h:126:28: error: conflicting types for 'uintptr_t' typedef unsigned int uintptr_t; ^~~~~~~~~ Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/samba/samba/cmocka-uintptr_t.patch51
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.8.4.bb1
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba/cmocka-uintptr_t.patch b/meta-networking/recipes-connectivity/samba/samba/cmocka-uintptr_t.patch
new file mode 100644
index 000000000..5c299d617
--- /dev/null
+++ b/meta-networking/recipes-connectivity/samba/samba/cmocka-uintptr_t.patch
@@ -0,0 +1,51 @@
1From 5bd7b5d04435bd593349825973ce32290f5f604d Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Wed, 25 Jul 2018 09:55:25 +0800
4Subject: [PATCH] samba: cmocka.h: fix musl libc conflicting types error
5
6Fix build on qemumips64(el)
7
8taken from:
9[PATCH] libldb: fix musl libc conflicting types error
10
11/third_party/cmocka/cmocka.h:126:28: error: conflicting types for 'uintptr_t'
12 typedef unsigned int uintptr_t;
13 ^~~~~~~~~
14use __DEFINED_uintptr_t in alltypes.h to check if uintptr already defined
15
16Upstream-Status: Pending
17
18Signed-off-by: Changqing Li <changqing.li@windriver.com>
19Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
20---
21 third_party/cmocka/cmocka.h | 7 +++----
22 1 file changed, 3 insertions(+), 4 deletions(-)
23
24diff --git a/third_party/cmocka/cmocka.h b/third_party/cmocka/cmocka.h
25index 4fd82a9..5443a08 100644
26--- a/third_party/cmocka/cmocka.h
27+++ b/third_party/cmocka/cmocka.h
28@@ -110,7 +110,7 @@ typedef uintmax_t LargestIntegralType;
29 ((LargestIntegralType)(value))
30
31 /* Smallest integral type capable of holding a pointer. */
32-#if !defined(_UINTPTR_T) && !defined(_UINTPTR_T_DEFINED)
33+#if !defined(__DEFINED_uintptr_t)
34 # if defined(_WIN32)
35 /* WIN32 is an ILP32 platform */
36 typedef unsigned int uintptr_t;
37@@ -134,9 +134,8 @@ typedef uintmax_t LargestIntegralType;
38 # endif /* __WORDSIZE */
39 # endif /* _WIN32 */
40
41-# define _UINTPTR_T
42-# define _UINTPTR_T_DEFINED
43-#endif /* !defined(_UINTPTR_T) || !defined(_UINTPTR_T_DEFINED) */
44+# define __DEFINED_uintptr_t
45+#endif /* !defined(__DEFINED_uintptr_t) */
46
47 /* Perform an unsigned cast to uintptr_t. */
48 #define cast_to_pointer_integral_type(value) \
49--
502.7.4
51
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb b/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb
index da0ac322a..f1aaeb83d 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb
@@ -28,6 +28,7 @@ SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \
28SRC_URI_append_libc-musl = " \ 28SRC_URI_append_libc-musl = " \
29 file://samba-pam.patch \ 29 file://samba-pam.patch \
30 file://samba-4.3.9-remove-getpwent_r.patch \ 30 file://samba-4.3.9-remove-getpwent_r.patch \
31 file://cmocka-uintptr_t.patch \
31 " 32 "
32 33
33SRC_URI[md5sum] = "ca5bfbebd8d9eb95506e16594b2bbee2" 34SRC_URI[md5sum] = "ca5bfbebd8d9eb95506e16594b2bbee2"