diff options
author | yanjun.zhu <yanjun.zhu@windriver.com> | 2013-01-15 12:45:44 +0800 |
---|---|---|
committer | Joe MacDonald <joe.macdonald@windriver.com> | 2013-01-17 09:10:40 -0500 |
commit | 1edcda74a810c631107a8ec969ecd117bcdcff07 (patch) | |
tree | a5a76f6ad13c22acad1ae494e5d477a08b5bf118 | |
parent | 13be4a07ec1d2933bd4320c8e06f0c810f4d6a13 (diff) | |
download | meta-openembedded-1edcda74a810c631107a8ec969ecd117bcdcff07.tar.gz |
autofs: do not check for modprobe
Reference: http://www.spinics.net/lists/autofs/msg00139.html
Loading autofs module is #ifdef'ed in the source, so
there is no need to check for /proc (which is only used
to load module) or modprobe. Both modprobe and /proc
are always in the fixed location so there's no need to
check for these to start with.
Signed-off-by: yanjun.zhu <yanjun.zhu@windriver.com>
Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-do-not-check-for-modprobe.patch | 75 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb | 1 |
2 files changed, 76 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-do-not-check-for-modprobe.patch b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-do-not-check-for-modprobe.patch new file mode 100644 index 000000000..af5be6a83 --- /dev/null +++ b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-do-not-check-for-modprobe.patch | |||
@@ -0,0 +1,75 @@ | |||
1 | Description: Loading autofs module is #ifdef'ed in the source, so | ||
2 | there is no need to check for /proc (which is only used | ||
3 | to load module) or modprobe. Both modprobe and /proc | ||
4 | are always in the fixed location so there's no need to | ||
5 | check for these to start with. | ||
6 | |||
7 | Upstream-Status: Backport [1] | ||
8 | [1] http://www.spinics.net/lists/autofs/msg00139.html | ||
9 | |||
10 | diff -urpN a/configure.in b/configure.in | ||
11 | --- a/configure.in 2013-01-15 11:30:22.000000000 +0800 | ||
12 | +++ b/configure.in 2013-01-15 11:31:45.000000000 +0800 | ||
13 | @@ -34,11 +34,6 @@ AC_MSG_CHECKING([for binaries in]) | ||
14 | AC_MSG_RESULT([$searchpath]) | ||
15 | |||
16 | # | ||
17 | -# Make sure we have "/proc" | ||
18 | -# | ||
19 | -AF_LINUX_PROCFS() | ||
20 | - | ||
21 | -# | ||
22 | # Location of init.d directory? | ||
23 | # | ||
24 | AF_INIT_D() | ||
25 | @@ -142,7 +137,6 @@ AF_PATH_INCLUDE(UMOUNT, umount, /bin/umo | ||
26 | AF_PATH_INCLUDE(E2FSCK, fsck.ext2 e2fsck, , $searchpath) | ||
27 | AF_PATH_INCLUDE(E3FSCK, fsck.ext3 e3fsck, , $searchpath) | ||
28 | AF_PATH_INCLUDE(E4FSCK, fsck.ext4 e4fsck, , $searchpath) | ||
29 | -AF_PATH_INCLUDE(MODPROBE, modprobe, , $searchpath) | ||
30 | |||
31 | AF_CHECK_PROG(LEX, flex lex, , $searchpath) | ||
32 | AF_CHECK_PROG(YACC, bison, , $searchpath) | ||
33 | diff -urpN a/daemon/module.c b/daemon/module.c | ||
34 | --- a/daemon/module.c 2013-01-15 11:30:49.000000000 +0800 | ||
35 | +++ b/daemon/module.c 2013-01-15 11:32:00.000000000 +0800 | ||
36 | @@ -18,6 +18,8 @@ | ||
37 | #include <stdlib.h> | ||
38 | #include "automount.h" | ||
39 | |||
40 | +#if 0 | ||
41 | +/* see comment in daemon/automount.c around load_autofs4_module() call */ | ||
42 | int load_autofs4_module(void) | ||
43 | { | ||
44 | FILE *fp; | ||
45 | @@ -52,6 +54,7 @@ int load_autofs4_module(void) | ||
46 | |||
47 | return 1; | ||
48 | } | ||
49 | +#endif | ||
50 | |||
51 | struct lookup_mod *open_lookup(const char *name, const char *err_prefix, | ||
52 | const char *mapfmt, int argc, const char *const *argv) | ||
53 | diff -urpN a/include/automount.h b/include/automount.h | ||
54 | --- a/include/automount.h 2013-01-15 11:31:10.000000000 +0800 | ||
55 | +++ b/include/automount.h 2013-01-15 11:32:06.000000000 +0800 | ||
56 | @@ -50,16 +50,11 @@ | ||
57 | #error Failed to locate umount(8)! | ||
58 | #endif | ||
59 | |||
60 | -#ifndef HAVE_MODPROBE | ||
61 | -#error Failed to locate modprobe(8)! | ||
62 | -#endif | ||
63 | - | ||
64 | -#ifndef HAVE_LINUX_PROCFS | ||
65 | -#error Failed to verify existence of procfs filesystem! | ||
66 | -#endif | ||
67 | - | ||
68 | +#if 0 | ||
69 | +/* see comment in daemon/automount.c around load_autofs4_module() call */ | ||
70 | #define FS_MODULE_NAME "autofs4" | ||
71 | int load_autofs4_module(void); | ||
72 | +#endif | ||
73 | |||
74 | /* The -s (sloppy) option to mount is good, if we have it... */ | ||
75 | |||
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb index ad737e372..bf679b4e6 100644 --- a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb +++ b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb | |||
@@ -30,6 +30,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.bz2 \ | |||
30 | file://cross.patch \ | 30 | file://cross.patch \ |
31 | file://libtirpc.patch \ | 31 | file://libtirpc.patch \ |
32 | file://libtirpc-name-clash-backout.patch \ | 32 | file://libtirpc-name-clash-backout.patch \ |
33 | file://autofs-5.0.7-do-not-check-for-modprobe.patch \ | ||
33 | " | 34 | " |
34 | 35 | ||
35 | SRC_URI[md5sum] = "bc46838dece83c02d800ff144ed9f431" | 36 | SRC_URI[md5sum] = "bc46838dece83c02d800ff144ed9f431" |